SOLVED XOA Update patches fails

  • My pool says it has 268 patches.
    When I click Install all patches I get this error:


      "hosts": [
      "message": "Update install failed",
      "name": "Error",
      "stack": "Error: Update install failed
        at /usr/local/lib/node_modules/xo-server/src/xapi/mixins/patching.js:354:14
        at (<anonymous>)
        at asyncGeneratorStep (/usr/local/lib/node_modules/xo-server/dist/xapi/mixins/patching.js:44:103)
        at _next (/usr/local/lib/node_modules/xo-server/dist/xapi/mixins/patching.js:46:194)
        at run (/usr/local/lib/node_modules/xo-server-xoa/node_modules/core-js/modules/es6.promise.js:75:22)
        at /usr/local/lib/node_modules/xo-server-xoa/node_modules/core-js/modules/es6.promise.js:92:30
        at flush (/usr/local/lib/node_modules/xo-server-xoa/node_modules/core-js/modules/_microtask.js:18:9)
        at _combinedTickCallback (internal/process/next_tick.js:132:7)
        at process._tickCallback (internal/process/next_tick.js:181:9)"

  • Some questions for you --

    • Is your XOA up-to-date?

    • What version of XCP-ng / XS / CH?

    • Is this a fresh install or are you just way behind on installing updates? 😃

  • Says XOA is up-to-date

    XCP-NG = v7.6.0

    This is a fresh install is of 2 hours ago.

    DNS is configured in iDRAC

  • @bazzacad said in XOA Update patches fails:

    DNS is configured in iDRAC

    Pretty sure that isn't applicable. In XOA, go to the host's Network tab. Find the PIF associated with the management interface and then click the "pencil" icon to configure the IP address. If DNS isn't properly configured here, then that's likely the issue.

    FWIW, this can also be done from either XSConsole or XCP-ng Center.

  • Yes, DNS is configured correctly on my PIF


  • XCP-ng Team

    @bazzacad said in XOA Update patches fails:

    My pool says it has 268 patches

    Hmm. I think it's not an XOA issue but a problem on your XCP-ng host. Why do you have such high number of updates? Did you tinker the repo conf files?

  • Oops, sorry. I had enabled the Centos-Base repo.
    I've disabled it now & the 268 patches are gone now.

  • XCP-ng Team

    That's why I thought. NEVER enable base repo. If you want a package from their, just enable it during the yum install command line.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support