Try to import .ova



  • I'm trying, once again, to import vms exported from vmware in .ova format. I was successfull to import One vm that I just installed and updated before export, more or less. But all others vms throw an error, see below (I've uninstalled vmware-tools):

    xo.getAllObjects
    {
      "ndjson": true
    }
    {
      "code": 10,
      "data": {
        "errors": [
          {
            "code": null,
            "reason": "strict",
            "message": "should not contains property [\"ndjson\"]",
            "property": "@"
          }
        ]
      },
      "message": "invalid parameters",
      "name": "XoError",
      "stack": "XoError: invalid parameters
        at Object.factory [as invalidParameters] (/etc/xo/xo-builds/xen-orchestra-201907062054/packages/xo-common/src/api-errors.js:21:31)
        at Xo.checkParams (/etc/xo/xo-builds/xen-orchestra-201907062054/packages/xo-server/src/xo-mixins/api.js:71:17)
        at /etc/xo/xo-builds/xen-orchestra-201907062054/packages/xo-server/src/xo-mixins/api.js:273:18
        at Generator.next (<anonymous>)
        at asyncGeneratorStep (/etc/xo/xo-builds/xen-orchestra-201907062054/packages/xo-server/dist/xo-mixins/api.js:38:103)
        at _next (/etc/xo/xo-builds/xen-orchestra-201907062054/packages/xo-server/dist/xo-mixins/api.js:40:194)
        at tryCatcher (/etc/xo/xo-builds/xen-orchestra-201907062054/node_modules/bluebird/js/release/util.js:16:23)
        at Promise._settlePromiseFromHandler (/etc/xo/xo-builds/xen-orchestra-201907062054/node_modules/bluebird/js/release/promise.js:517:31)
        at Promise._settlePromise (/etc/xo/xo-builds/xen-orchestra-201907062054/node_modules/bluebird/js/release/promise.js:574:18)
        at Promise._settlePromiseCtx (/etc/xo/xo-builds/xen-orchestra-201907062054/node_modules/bluebird/js/release/promise.js:611:10)
        at _drainQueueStep (/etc/xo/xo-builds/xen-orchestra-201907062054/node_modules/bluebird/js/release/async.js:142:12)
        at _drainQueue (/etc/xo/xo-builds/xen-orchestra-201907062054/node_modules/bluebird/js/release/async.js:131:9)
        at Async._drainQueues (/etc/xo/xo-builds/xen-orchestra-201907062054/node_modules/bluebird/js/release/async.js:147:5)
        at Immediate.Async.drainQueues (/etc/xo/xo-builds/xen-orchestra-201907062054/node_modules/bluebird/js/release/async.js:17:14)
        at runCallback (timers.js:810:20)
        at tryOnImmediate (timers.js:768:5)
        at processImmediate [as _immediateCallback] (timers.js:745:5)"
    }
    


  • There was a recent commit that is likely causing this and other issues. I suggest that you try with XOA or else build your XO VM from an earlier point-in-time.

    @olivierlambert Do you agree?


  • XCP-ng Team

    I have no idea about this commit, but XOA will work, yes.



  • I tried yesterday and import the VM but it failed. I also upgrade XO yesterday and checked for available upgrades to xcp-ng itself, but without luck. Is it possible to enable some debug-mode or something while importing via gui?


  • XCP-ng Team

    Are you using XO from the sources or XOA?



  • @olivierlambert
    Hmm I use a script to install it: "This repo consist of script to install and update Xen Orchestra for CentOS 7/Ubuntu 18/Debian 9". https://github.com/ronivay/XenOrchestraInstallerUpdater

    Edit: xo-server 5.42.1


  • XCP-ng Team

    Okay so please try with XOA 🙂

    https://xen-orchestra.com/#!/xoa



  • @olivierlambert
    Ah its isnt the same? 🙂 Is that the free opensource version with all futures? I run that from the xcp-ng server I guess?


  • XCP-ng Team

    It's the turnkey appliance with QA, web updater and dedicated support ticket system (even on XOA Free).

    Unlike pulling from the sources directly, you are on a "frozen" state that's validated 🙂



  • @olivierlambert
    Okej sweet. I thought that was only available for paying customers? I'll try it and come back with the outcome 😃


  • XCP-ng Team

    XOA Free is available to everyone. If you need to test a feature that's isn't in XOA Free, you can enable a 15 days trial, which will be enough to test everything you want to test.

    This should be the default way to discover Xen Orchestra 🙂



  • @olivierlambert
    Hmm I would like to have all feats without paying. But I might be able to use it to import and then use the other one as my daily driver. I dont mind paying tho, but its just a bit too much for a home lab 😃 I would love to see a "lifetime" or "homelab" alternative for maybe 100$ or something.


  • XCP-ng Team

    We simply don't sell to individuals 🙂 (ironically, this will cost us more money that we could get from it).

    XOA Free is "like" XCP-ng Center in terms of features, enough for all administrations tasks.

    Higher tier feature are coming with support, hence targeting companies.

    But as I said, to discover Xen Orchestra, XOA is the best choice: 15 days to test everything, and even a dedicated ticket pro support available.

    Then you can decide to go from the source later if you want all features for free.



  • @olivierlambert
    I understand that, but if you skip support to us/them, it wouldn't cost you anything. But we are able to use the turnkey appliance and get smooth updates possibilities. But yea I will try and import my vms and then run the other one.


  • XCP-ng Team

    Not true. Selling to individuals is not straightforward, administratively speaking, and the cost can only be counterbalanced if you have a big enough market (or a big enough average sell, which isn't the case here for both).

    Keep us posted on OVA import in XOA, and if it doesn't work feel free to open a ticket so we can do a remote check on your XOA.



  • @olivierlambert
    I tried and import it now. Actually it thrown an error almost immediately. And I couldn't see the process under "task" as before. I tried again and I can see a task "create .vdi" and then "destory .vdi" and it disappear in like 3-4 seconds.

    EDIT: And when I look into the logs I can't see anything.
    EDIT2: Now I can see the error: "Task: host.call_plugin (on servername)". It keeps trying every 5s
    EDIT3: It didn't stop till I reboot the machine.


  • XCP-ng Team

    When you import XOA or the OVA?



  • @olivierlambert
    When I'm trying to import the VM from vmware in .OVA format.


  • XCP-ng Team

    1. So I suppose your XOA is fully up-to-date?
    2. Anything is settings/logs?
    3. Check also the browser console for errors (Chrome or Firefox)


  • @olivierlambert
    Everything is default except the vms im trying to import. The machine i could import was a new installed one just upgraded. The vms that doesnt work, and gives me the error above, are vms that i've been running for a while. I just shut them down and take away snapshot and unstinall vmware-tools. Then export them as OVAs and try and import them into xcp-ng via XO/XOA.

    edit: This was the reason i stayed with vmware, because i couldnt import them last time either (1-2y) agho


  • XCP-ng Team

    Ok but that weren't my questions:

    1. Is your XOA fully up-to-date?
    2. Anything is Xen Orchestra menu, Settings/Logs?
    3. Check also the browser console for errors (Chrome or Firefox) when importing the OVA

    Ultimately, if you can upload this OVA somewhere, it would be possible for us to see if it comes from the OVA itself and fix it 🙂


Log in to reply
 

XCP-ng Pro Support

XCP-ng Pro Support