Try to import .ova



  • @olivierlambert
    I understand that, but if you skip support to us/them, it wouldn't cost you anything. But we are able to use the turnkey appliance and get smooth updates possibilities. But yea I will try and import my vms and then run the other one.


  • Admin

    Not true. Selling to individuals is not straightforward, administratively speaking, and the cost can only be counterbalanced if you have a big enough market (or a big enough average sell, which isn't the case here for both).

    Keep us posted on OVA import in XOA, and if it doesn't work feel free to open a ticket so we can do a remote check on your XOA.



  • @olivierlambert
    I tried and import it now. Actually it thrown an error almost immediately. And I couldn't see the process under "task" as before. I tried again and I can see a task "create .vdi" and then "destory .vdi" and it disappear in like 3-4 seconds.

    EDIT: And when I look into the logs I can't see anything.
    EDIT2: Now I can see the error: "Task: host.call_plugin (on servername)". It keeps trying every 5s
    EDIT3: It didn't stop till I reboot the machine.


  • Admin

    When you import XOA or the OVA?



  • @olivierlambert
    When I'm trying to import the VM from vmware in .OVA format.


  • Admin

    1. So I suppose your XOA is fully up-to-date?
    2. Anything is settings/logs?
    3. Check also the browser console for errors (Chrome or Firefox)


  • @olivierlambert
    Everything is default except the vms im trying to import. The machine i could import was a new installed one just upgraded. The vms that doesnt work, and gives me the error above, are vms that i've been running for a while. I just shut them down and take away snapshot and unstinall vmware-tools. Then export them as OVAs and try and import them into xcp-ng via XO/XOA.

    edit: This was the reason i stayed with vmware, because i couldnt import them last time either (1-2y) agho


  • Admin

    Ok but that weren't my questions:

    1. Is your XOA fully up-to-date?
    2. Anything is Xen Orchestra menu, Settings/Logs?
    3. Check also the browser console for errors (Chrome or Firefox) when importing the OVA

    Ultimately, if you can upload this OVA somewhere, it would be possible for us to see if it comes from the OVA itself and fix it 🙂



  • @olivierlambert
    Sure give me a server to upload it too 😃 5 GB. Since I can upload 1 it would seem to me that there is either a problem with the importer or de .ova file. Is there a logfile I can look into while importing to see anything?

    @olivierlambert said in Try to import .ova:

    Ok but that weren't my questions:

    1. Is your XOA fully up-to-date?

    Yes it is.

    1. Anything is Xen Orchestra menu, Settings/Logs?
      Nopes nothing but the message i typed above.
    1. Check also the browser console for errors (Chrome or Firefox) when importing the OVA
      I'll do that now.

    Ultimately, if you can upload this OVA somewhere, it would be possible for us to see if it comes from the OVA itself and fix it 🙂



  • @olivierlambert
    I'm not sure what to do in FF. But the console gave me this info
    "fileSize Minecraft vanilla server.ovf 8390 B 0.000007813796401023865 GB index.js:105:10
    fileSize Minecraft_vanilla_server-disk1.vmdk 5117238272 B 4.765799522399902 GB index.js:105:10
    fileSize Minecraft vanilla server.mf 163 B 1.51805579662323e-7 GB index.js:105:10"

    Edit: In the other XO version I could see the VM in the list inside XO. But with this turnkey version I cant even see the vm. SO the problem seems to be before it even trying to create/importing it.


  • Admin

    Yep, probably a malformed OVA (or with special stuff inside).

    Please upload it somewhere so I can test it. Create a support ticket if you want to provide a private link.



  • @olivierlambert
    Okej I will do that now. Will create a ticket too.

    Edit: Hmm were do I create a ticket? 😄


  • Admin

    Thanks, this way we'll have a way to understand what's wrong with this OVA, if it's something really specific or a VMWare way to make something we didn't expected 🙂


Log in to reply
 

XCP-ng Pro Support