XCP-ng 8.0.0 Release Candidate

  • XCP-ng Team

    @EliasSeccom Does ALT + Arrow keys (Left/Right) show you any erroneous messages? On one of the screen, there is a shell available.

    If its a hang which is not letting you do anything, you can attach a serial console and see if it outputs any stacktraces.

  • kern.log.txt

    Kern log file shows that it booted at that time, at least i don't see any errors. (file attached)
    It looks like it was just reset and started booting, but i doubt there was an electricity outage, as my xcp is powered by ippon back basic 1050.

  • XCP-ng Team

    @dave-opc To know more on next incident, you may add noreboot options to multiboot2 /boot/xen.gz in /etc/grub.cfg file against default kernel boot entry.

  • Got another issue with RC1:

    I got 2 xcp ng servers. 1st at home on 8.0rc1 and 2nd remote on 7.6
    When i had at home 7.6 (before upgrade) my continuous replication task in XOA was working fine. Every night copying VM to home server.
    After upgrading to 8.0RC1 XOA starts copying. I can see [importing....] in xcp center, but after transfering the file, xoa ends with error XOA.JPG
    I thought i had a problem with iscsi drive, connected to xcp, but i also tried copying to my main sr (nvme) and got the same error.

  • XCP-ng Team

    You are doing CR from 8.0 to 7.6?

  • @olivierlambert
    from 7.6 to 8
    P.S. just checked. the other way from 8 to 7.6 CR is working fine.
    Also copying VM from 7.6 to 8 is working. - problem with CR 7.6 -> 8

  • XCP-ng Team

    Okay so it's maybe something related to how VDI are handled in the "opposite" way (newer to older).

    I would suggest to get everything at the same level if possible. Ideally, try to test from a 8.0 to a 8.0 to be sure it's a version diff that cause the issue.

  • @olivierlambert
    Of course i will try that, but can't install 8.0 on production pc yet. Will wait for 8.0 release.
    I just posted this issue, so maybe you or someone will try to do CR 7.6 -> 8.0RC1 and see if the issue still exists.

  • XCP-ng Team

    XCP-ng 8.0 will now have the EPEL repositories added - but disabled - by default, in order to avoid users add it and not notice that adding it automatically leaves it enabled.

    I have also written this detailed page that attempts to cover the subjet of installing additional packages to dom0: https://github.com/xcp-ng/xcp/wiki/Additional-packages

    By the way, various new utilities have been added to XCP-ng repositories for 8.0, I won't list them here, but you can find the answer in that page (how to lure people into reading it...)

  • Hello

    now it looks like 8.0 will be ready soon. I like to write a article for a big german IT magazin 😉

  • XCP-ng Team

    We plan to release in the next few day, and there have been important changes that need testing before that:

    • the updater XAPI plugin, that handles patch detection and application (through yum) and is used by Xen Orchestra in the pool and hosts views, has been vastly modified to prevent it from running multiple times concurrently (in extreme cases, this could crash your host due to lack of available RAM)
    • updated kernel for http://xenbits.xen.org/xsa/advisory-300.html
    • EPEL repos added by default, in disabled state http://xenbits.xen.org/xsa/advisory-300.html

    Testers who already run XCP-ng 8.0 beta/RC

    To test this, I suggest to:

    1. Update the XAPI plugins only, so that you can test the updater plugin: yum update xcp-ng-xapi-plugins
    2. Update your hosts with Xen Orchestra (if you don't use Xen Orchestra, then you won't be able to test the updater plugin... then just run yum update on your hosts).
    3. Restart the XAPI toolstack (xe-toolstack restart) on your hosts, starting with the pool master.
    4. Reboot your hosts, starting with the pool master as usual, so that the kernel security fix is applied and you can test that everything works well with the updated kernel.

    Testers who could test the "final" installation ISO

    I'll also make pre-release ISOs available to those who want to test them before the final release (we need as many tests as we can get in this final stage). Unless there's an important bug that is found during the tests, the pre-release ISOs and the final ISOs should be identical.

  • XCP-ng Team

    The "prefinal" ISO images are available there:

    The net-install online repository has been updated too.

  • Hello stormi

    Thx for your info i will try your pre release next few days 🙂

  • Upgrade from XCP-NG 7.6 > 8.0.0 with prefinal .iso went smooth without any problem on a single host. Host system quite old Intel System S5520UR with dual XEON E5645 and 48GB RAM.

    Just a quick note: Old Windows XP VM does not boot anymore with XenTools 6.5 or 7.3 installed. When removed in safe mode the VM can be started... On XCP-NG 7.6 this was not the case. VM has booted also with XenTools 6.5.

  • Upgrade from Citrix XenServer 6.5 > Citrix XenServer 7.6 > XCP-ng 8.0.0 with prefinal .iso went smooth without any problem on a 3 box pool. Moved to the "new" partition scheme from XS6.5 -> XS7.6 and used the prepare_host_upgrade.py (rolling pool) method. Had no issues migrating the existing VM's upward.

    Perhaps it would've been possible to go from XS6.5 straight to XCP-ng 8.0.0 (after applying hotfix RPU002) but since this is a production cluster I didn't want to make it too risky (yes, I know this is not quite final yet). 😉

    //edit: Forgot to mention these are Dell PowerEdge R720s on Intel E5 2660's using FC storage.

    Thanks XCP-ng team! 👍

  • Quick (hopefully not dumb) question: Will XCP-ng 8.0 support VDIs larger than 2TB? I see mention of the qcow2 format dotted around but nothing concrete about if/when it will be implemented. Cheers. 🙂

  • XCP-ng Team

    I wouldn't consider SMAPIv3 production ready yet. Our first objective would be exporting qcow2 files to be able to backup those (so if you have an issue, at least you have backups!)

    Surprisingly (or not 😆 ) Citrix didn't planned any way to export VM disk in the format they chose themselves 😆 (qcow2)

    So now @ronan-a is working on integrating that into SMAPIv3. As soon it's done (a PoC should be around this summer), we'll try to publish various "drivers" (ZFS, ext4, xfs, NFS) for people who want to experiment, with also a PoC in Xen Orchestra to be able to "save"/backup those QCOW2 files.

  • @olivierlambert Thanks for the super-quick reply as usual! I feel like I should make a new thread for it, but what are you views on using raw VDIs to get around the limit? http://www.ervik.as/how-to-create-a-raw-logical-volume-manager-virtual-disk-infrastructure-with-xenserver/

    I realise you can't snapshot raw disks, but are there any other pitfalls to it?

  • XCP-ng Team

    Doing hat is like plugin a disk directly to the VM, you'll lose all virtualization flexibility:

    • no snapshot
    • no backup
    • no migration

    So do that in last resort, if you can't avoid a 2TiB disk or you can't afford a NAS.

  • This post is deleted!

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support