XCP-ng 7.5.0 Release Candidate

  • XCP-ng Team

    Yeah but Citrix isn't relying on Yum to upgrade 😉 If you want to be "defensive", then upgrade via the ISO on boot, not on a live system 🙂

    Problably a dependency thing.

  • @olivierlambert

    I do not quite understand your answer, please can you clarify.
    The system was clean installed from 7.4, 7.41 to 7.5, all xcp-ng.
    The ony addition was the ups yum , as described in my thread.
    Are you suggesting that a clean install will

    1. fix the pass through for the Ublox?
    2. To get ups support I must repeat my extra ups software install,?
      unless xcp-ng is going to provide an alternative package for UPS support?



  • XCP-ng Team

    1. Nope
    2. Yes.

  • XCP-ng Team

    This thread is having several discussions in parallel. If nobody minds, I'll move them to separate threads soon.

    Update: done.

  • XCP-ng Team

    I pushed several update candidates to the RC in the updates_testing repository:

    To test: yum update --enablerepo='xcp-ng-updates_testing*' and reboot.

    What we need is to make sure they cause no regressions.


  • XCP-ng Team

    @stormi said in XCP-ng 7.5.0 Release Candidate:

    yum update --enablerepo='xcp-ng-updates_testing*'

    Is this interfering with the ZFS packages or there is no issue to do it? (especially blktap)

  • XCP-ng Team

    @olivierlambert No issue to do it.

  • XCP-ng Team

    👍 Great!

  • @christianuhlmann said in XCP-ng 7.5.0 Release Candidate:

    my first host with xcp-ng upgraded successful to 7.5 (Intel NUC) without an error.
    thanks for the great job !

    second server has also been updated successfully.

    the third server I use pci passthroug for 2 DVB cards.
    So far that was excellent under 7.4.1.

    Since upgrading to 7.5 I get the following error if i want to start the vm with the passthroug pci devices:

      "id": "40bcca30-d07a-db7c-5744-c134a30af5d1"
      "message": "INTERNAL_ERROR(xenopsd internal error: (Failure
      \"Error from xenguesthelper: Populate on Demand and PCI Passthrough are mutually exclusive\"))",
      "stack": "XapiError: INTERNAL_ERROR(xenopsd internal error: (Failure
      \"Error from xenguesthelper: Populate on Demand and PCI Passthrough are mutually exclusive\"))
        at wrapError (/home/node/xen-orchestra/packages/xen-api/src/index.js:197:9)
        at /home/node/xen-orchestra/packages/xen-api/src/index.js:1064:18
        at run (/home/node/xen-orchestra/node_modules/core-js/modules/es6.promise.js:75:22)
        at /home/node/xen-orchestra/node_modules/core-js/modules/es6.promise.js:92:30
        at flush (/home/node/xen-orchestra/node_modules/core-js/modules/_microtask.js:18:9)
        at _combinedTickCallback (internal/process/next_tick.js:131:7)
        at process._tickCallback (internal/process/next_tick.js:180:9)",
      "code": "INTERNAL_ERROR",
      "params": [
        "xenopsd internal error: (Failure
      \"Error from xenguesthelper: Populate on Demand and PCI Passthrough are mutually exclusive\")"
      "method": "VM.start"

    all seem ok

    # lspci
    02:00.0 Multimedia controller: Digital Devices GmbH Octopus DVB Adapter
    08:00.0 Multimedia controller: Digital Devices GmbH Cine V7
    # xl pci-assignable-list
    # xe vm-param-get uuid=40bcca30-d07a-db7c-5744-c134a30af5d1 param-name=other-config
    pci: 0/0000:02:00.0,0/0000:08:00.0; base_template_name: Debian Stretch 9.0; import_task: OpaqueRef:83a9253c-f3c0-448f-aba6-df5efa2c1c4a; mac_seed: 1113ba83-5709-4ca5-a292-f8b81a047db4; install-methods: cdrom,nfs,http,ftp; linux_template: true

    Does anyone have any idea what that might be?
    does anyone have an upgrade to 7.5 with pci passthroug on the run?

    Thanks and Greetings


  • XCP-ng Team

    @christianuhlmann said in XCP-ng 7.5.0 Release Candidate:

    Populate on Demand

    Do you know what's this? It seems incompatible to have it enable in parallel with PCI Passthrought.

    edit: it seems your dynamix min/max and static max aren't set at the same value.

  • @olivierlambert

    After a bit of googling on populate on demand I realized.
    strange that it worked under 7.4.1.

    if I understood correctly, it is the dynamic ram assign with min / max.

    after I entered a fixed size for ram, the start worked fine.

    thank you for the great work 🙂


  • XCP-ng Team

    I think ballooning + PCI passthrough can cause some crashes, so that's why there is a check to avoid using both at the same time.

  • Updated via YUM, all seemed to go well, except the xcp-ng tools ISO only seems to have the Linux directory and the readme.txt file on it, no windows tools.

    Guests on 3 hosts same.

    file appears to be "guest-tools-7.29.0-2.iso" in /opt/xensource/packages/iso


  • XCP-ng Team

    The windows tools are not free software, we can't distribute them. There's a way to install them though: https://xcp-ng.org/2018/04/23/the-future-of-vm-tools/ (see "a better model")

  • The readme doesn't say that. Might need to adjust it.

  • XCP-ng Team

    Indeed. I'll fix it.

  • XCP-ng Team

    @bungo I uploaded a fixed package, can you test it?

    # only needed if you test so quickly that yum's cache couldn't expire
    yum clean metadata --enablerepo='*'
    # install the update candidate
    yum install xcp-ng-pv-tools --enablerepo='xcp-ng-updates_testing*'

    Here's what you should see in the Windows section of README.txt

    We are not allowed to redistribute the windows tools built and signed by
    Citrix, so they are not included here.
    If you are using Xen Orchestra, you can switch the "Windows Update tools"
    advanced parameter on from the "Advanced" tab of the VM view. This will
    allow you to install the tools directly from Windows Updates.
    Any help in building the tools from the sources to add them back in this
    ISO image is welcome. See https://github.com/xcp-ng/xcp/issues/23
    olivierlambert created this issue in xcp-ng/xcp

    closed Windows PV tools #23

  • Ran, tested, all as expected. Thanks.

  • I installed this RC1 version via a fresh install using the ISO image (from Proxmox). I used EXT3 thin provisioning as usual (one day Citrix will give us the opportunity to use LVM Thin 😔).

    No problem at all ! Great ! XenOrchestra 5.22 works great, same for XCP.

    However, I have not yet had the opportunity to test the USB Passthrough. And finally, my network card does not support SR-IOV, so no opinion on it.

  • XCP-ng Team

    @Ruskofff LVM thin won't happen I'm afraid. They had to many issues doing it when they tried (data corruption). The path they are using not for thin pro on block based (eg iSCSI) is GFS2. But this require a cluster working, and this part isn't Open Source…

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support