XCP-ng 7.5.0 final is here

  • XCP-ng Team

    😨 that's… strange. Could it be a hardware issue? Panic on a CPU is not commong.

  • This post is deleted!

  • @olivierlambert The VDIs are over shared ISCSI on FreeNAS VDEVs. There are other VMs with VDIs on the same RAID10 LUN that are running fine.

    It's actually 2 VDIs and I moved both (boot and swap) of the failed VM to an alternate RAID5 LUN and it made no difference.

    Is there a log I should be looking in to see more detail?

  • XCP-ng Team

    Check the /var/log/xensource.log and SMlog about this VDI error.

    Again, a PANIC on CPU 0 isn't a good news regarding your hardware.

  • well installed from scratch on my 3 servers
    everything fine, but, when trying to activate HA it gives me an error. The same when I upgraded 7.4.1 to 7.5 RC.

    3 hosts are connected via HBA to a one Storage on a fibre channel.

    tried to connect only 2 hosts with a few combinations (host1 and host2, host1 and host3, host2 and host3), also trying to configure HA with one host (yep little strange) it gave me the same error.


  • XCP-ng Team

    Please provide real logs and not just a XCP-ng screenshot πŸ™‚

    How did you enable HA by the way?

  • The CPU PANIC was on server1 (not pool master) so I've shut it down and I'll do a fresh install there later. It won't even show me the NICs that I know are there. Might be a hardware problem indeed.

    I left all VMs powered down and tried to capture SMlog and xensource.log for the duration of the startup failure event.

    I see "Raised Server_error(SESSION_INVALID," but have no idea if this is related to the error.
    I don't have privs to upload the files.

  • XCP-ng Team

    Use pastebin or hastebin to put your logs there πŸ™‚

    SESSION INVALID is not related

  • XCP-ng Center Team



    Aug 10 14:58:43 xs2 xenopsd-xc: [error|xs2|15 |Parallel:task=50.atoms=1.(VBD.plug RO vm=67bd9da9-9cb7-1882-9ad4-68e65e6095a2)|xenops] Re-raising exception VDI_MISSING: OpaqueRef:fa60f4c9-7095-35d7-6c91-2436713508a0; OpaqueRef:e08c2398-4e43-4cdd-af5b-41926a5f9d76

  • Well, I detached the VDIs, deleted the VM, created a new one, attached the VDIs and it booted up. This is solved for me, but I don't know the root cause.

  • XCP-ng Center Team

    Yehaa! πŸ™‚
    I hope you had a backup if it had not worked πŸ”™ πŸ†™

  • @olivierlambert sorry. Where can i get them from?
    I tried to enable HA as always using xcp-ng center.

  • XCP-ng Team

    Same as @dsiminiuk xensource and SMlog πŸ™‚

  • I've installed from CDROM a new clean install of 7.5 and had all my VMs running. I added the 2nd host to the pool and migrated some of the VMs from the pool master to the 2nd server fine. One however, abended with a XenOpts error (don't have the details now). And the VM that was powered off while transferring and now it won't start. Status is "Starting VM..." for 10+ minutes now.
    Something's not quite right here.

  • And when I changed the home host from "do not assign" to the pool master, then the VM started up just fine. It's as if it couldn't identify a host to start on and timed out at 20 minutes.
    Very weird.

  • XCP-ng Team

    What did you use to "assign" a host for the VM? Affinity?

  • Upgrade from 7.4 to 7.5.0 done flawlessly via ISO upgrade. (just saw an Failed to start Load Kernel Modules message after the install, but later it initialize Apply Kernel Variable procesure, I guess it updated the kernel modules)

    Did not try the new USB passthrough but the old style still works.
    Now eager to test ZFS!

    Thank you so much for XCP-ng!

  • @olivierlambert I edited the properties of the VM and changed the "Home Server" property to server1 rather than do not assign. Then it was able to start. When I looked at XCP ng Center this morning the status icon for that VM was yellow. I restarted the tool stack on the server and the VM status turned green. I also received an email from the pool...

    Field                Value
    -----                -----
    Name:                PBD_PLUG_FAILED_ON_SERVER_START
    Priority:        3
    Class:                Host
    Object UUID:        c3970498-bc7f-4a49-8fe2-23e1e6dcb6bb
    Timestamp:        20180811T06:27:04Z
    Message UUID:        88db4c9a-6435-0bd3-2237-5d4d904a5782
    Pool name:        pool1

    Maybe related, maybe not. XCP ng Center crashed twice along the way and mentioned to look in the log in D:\Users\<my_user>\AppData\Roaming\XCP-ng\XCP-ng Center\logs\XCP-ng Center.log

    Recurring ERRORs

    2018-07-12 22:11:48,931 ERROR XenAdmin.Dialogs.LicenseStatus [23] - Couldn't get the server time for pool1 because: Object reference not set to an instance of an object.
    2018-07-12 22:11:48,931 ERROR XenAdmin.Utils.AsyncServerTime [23] - Failed to fetch server time for host pool1 because Object reference not set to an instance of an object.
    2018-07-12 22:34:27,141 ERROR XenAdmin.Program [Named pipe thread] - Exception in Invoke (ControlType=XenAdmin.MainWindow, MethodName=<ConnectPipe>b__1)
    System.ObjectDisposedException: Cannot access a disposed object.
    Object name: 'MainWindow'.
       at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
       at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
       at XenAdmin.Program.Invoke(Control c, MethodInvoker f)
    • other error removed, too old to be pertinent to 7.5

    Everything appears stable at the moment but I'm hesitant to manipulate my VMs just for the sake of doing so. I've taken fresh backups of all my VMs so I have a restore point. If there are specific tests you would recommend to peel back the onion, I am willing to try.

  • I edited that VM again and removed the startup host preference. Shut it down. Started it up again and it worked. That's a good sign.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support