Can't connect to server. Error message: Not Found



  • I have just installed XO from source on a Debian VM on my XCP-NG. It is running fine. However, I can't connect my XCP-NG server to XO. When I try to add it in the settings interface in XO I get the following error message:

    server.enable
    {
      "id": "xxxxxxxxxxxxx"
    }
    {
      "call": {
        "method": "session.login_with_password",
        "params": [
          "root",
          "password"
        ]
      },
      "message": "Not Found",
      "name": "Error",
      "stack": "Error: Not Found
        at Client.<anonymous> (/etc/xo/xo-builds/xen-orchestra-202003041736/node_modules/xmlrpc/lib/client.js:119:30)
        at Object.onceWrapper (events.js:418:26)
        at ClientRequest.apply (events.js:311:20)
        at ClientRequest.patchedEmit [as emit] (/etc/xo/xo-builds/xen-orchestra-202003041736/@xen-orchestra/log/src/configure.js:95:17)
        at HTTPParser.parserOnIncomingClient [as onIncoming] (_http_client.js:603:27)
        at HTTPParser.parserOnHeadersComplete (_http_common.js:119:17)
        at TLSSocket.socketOnData (_http_client.js:476:22)
        at TLSSocket.apply (events.js:311:20)
        at TLSSocket.patchedEmit [as emit] (/etc/xo/xo-builds/xen-orchestra-202003041736/@xen-orchestra/log/src/configure.js:95:17)
        at addChunk (_stream_readable.js:294:12)
        at readableAddChunk (_stream_readable.js:275:11)
        at TLSSocket.Readable.push (_stream_readable.js:209:10)
        at TLSWrap.onStreamRead (internal/stream_base_commons.js:186:23)"
    

    I'm rather new to XCP-NG and XO so I'm sorry if I have missed an obvious solution to the problem.

    I'm running:
    XCP-ng 8.1
    xo-server and web 5.58.1 (build from source)

    Any help will be highly appreciated.



  • I don't know if it's the case here but one not-so-obvious thing in XO(A) is that you have to enable the slider to accept unverified certificates when you try to connect to the XCP-ng server.

    The error here does suggest there's something else going on but make sure to check the above.

    You should also install the XOA to make sure there's nothing wrong with your self-compiled XO.

    Run this in a command shell on your XCP-ng server to install the appliance

    bash -c "$(curl -s http://xoa.io/deploy)"
    


  • Thanks for the reply. And thanks for the tip about XOA.

    I might think that this has something to do with the self-signed certificates of the XCP-ng server. Because when I try to access it from the XCP Center the server is shortly connected and I can see all my VM but then I have to accept an invalid certificate, which I do and then it disconnects.

    After this, whenever I try to reconnect to my XCP-ng server I get the same error but this time from XCP-ng Center. Screenshot 2020-04-05 at 12.28.55.png

    I have made a completely clean reinstall of XCP-ng but I still get the same error message.

    Any ideas on how I can debug this issue?



  • Can you ping the server reliably? Because it kind of seems like it's a network problem.

    Start a CMD prompt on your XCP-ng Center PC and run ping -n 30 192.168.66.17 to see if you get packet losses.
    If you do then it's probably a bad NIC or cable or switch port.



  • @peder - yes no packet losses when running ping -n 30 192.168.66.17.



  • Are you sure you are pinging the right machine? No change you have a duplicate IP address?



  • @jedimarcus - yes I think so. I'm pining the management interface, which is the right interface to ping right?
    Screenshot 2020-04-05 at 15.10.36.png

    I really don't think that I have another machie running on that IP. 192.168.66.17 is out of the DHCP servers scope. And when I enter the IP in the browser I'm shown the welcome to XCP-ng screen where I have the option to install XOA or download the XCP-ng Center app.



  • @runevn

    Isn't there a password field you must type in when connecting XO to a new host? Are you supplying it with a password?

    Its been a long time since I setup a new host so perhaps I'm wrong.



  • @Biggen Yes, I have checked that box/slider. But no luck.



  • I tried to ssh into the XCP-ng server, which worked fine I ran some commands but then the connection got closed (Broken pipe) with the argument that the remote host identification has changed.

    [21:24 vmhost ~]# xe packet_write_wait: Connection to 192.168.66.17 port 22: Broken pipe
    Macbook:~ run$ ssh root@192.168.66.17
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    @    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that a host key has just been changed.
    The fingerprint for the ECDSA key sent by the remote host is
    SHA256:qiZb5QLDgFhJUbNvvC5ry2SFao7td0/JywdeH1mIm1c.
    Please contact your system administrator.
    Add correct host key in /Users/run/.ssh/known_hosts to get rid of this message.
    Offending ECDSA key in /Users/run/.ssh/known_hosts:10
    ECDSA host key for 192.168.66.17 has changed and you have requested strict checking.
    Host key verification failed.
    
    

    This fingerprint key is different from what I can see when I go under "Status Display" on the XCP-ng server.

    I don't know if this helps but it seems that I have some issues with authentication both on the XCP-ng Center, XO and when I SSH into the host?

    Any idea of what I could do? And please let me know if you need more information.

    Thanks


  • XCP-ng Team

    This usually means you have another machine on this IP.



  • Wow - you guys where right. I had a Raspberry pi running with that address on my network. Sorry for the inconvenience and thanks for your help.


  • XCP-ng Team

    No worries, if we knew the answer it means we made the mistake ourselves in the past.

    Isn't that the goal of a great Open Source community? Sharing knowledge and code 🙂


Log in to reply
 

XCP-ng Pro Support

XCP-ng Pro Support