Import OVA silently fails



  • After making those changes, it got further, but still halted at about 10%. (I upped to 8GB RAM)

    Apr  8 16:38:22 xoa xo-server[467]: 2020-04-08T20:38:22.411Z xo:xapi DEBUG Creating VM Spiceworks-Production
    Apr  8 16:38:22 xoa xo-server[467]: 2020-04-08T20:38:22.482Z xo:xapi DEBUG Creating VDI Hard disk 1 on Local storage
    Apr  8 16:38:22 xoa xo-server[467]: 2020-04-08T20:38:22.483Z xo:xapi DEBUG Creating VIF for VM Spiceworks-Production on network MGMT-LAN
    Apr  8 16:38:23 xoa xo-server[467]: 2020-04-08T20:38:23.294Z xo:xapi DEBUG Creating VBD for VDI Hard disk 1 on VM [Importing...] Spiceworks-Production
    Apr  8 16:38:27 xoa kernel: [   66.534931] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:00:18:0a:86:53:c4:08:00 SRC=0.0.0.0 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=2660 PROTO=2 
    Apr  8 16:40:37 xoa kernel: [  196.531337] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:00:18:0a:86:53:c4:08:00 SRC=0.0.0.0 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=2665 PROTO=2 
    Apr  8 16:42:47 xoa kernel: [  326.527746] [UFW BLOCK] IN=eth0 OUT= MAC=01:00:5e:00:00:01:00:18:0a:86:53:c4:08:00 SRC=0.0.0.0 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=2671 PROTO=2 
    Apr  8 16:44:16 xoa xoa-updater[472]: 2020-04-08T20:44:14.045Z xoa-updater WARN onMessage Error: Command failed: xenstore-read vm
    Apr  8 16:44:16 xoa xoa-updater[472]: fatal error: runtime: out of memory
    Apr  8 16:44:16 xoa xoa-updater[472]: runtime stack:
    Apr  8 16:44:16 xoa xoa-updater[472]: runtime.throw(0x8108647, 0x16)
    

    Here is my xo-server.service

    ExecStart=/usr/local/bin/node --max-old-space-size=7680 /usr/local/bin/xo-server
    

    Anything else we can try?


  • XCP-ng Team

    So there's a leak when you import 😕 How big is the OVA?

    Can you try with the OVA CLI?



  • The VM is 138GB. I read those instructions, what i am failing to understand is where and how I point it to my local disk? Do you have an example of using a file in C:\Export (on a windows box)?

    The example the OVA appears to be local to XOA?

    Please advise,
    Thank you



  • I have tried to use a SR that is used for ISO:

    xo-upload-ova --upload Spiceworks-Production.ova 1fee8757-644e-2bce-beb0-9f85380a5842 --override 'nameLabel=test' descriptionLabel='Spiceworks' memory=json:671088640 disks.vmdisk1.descriptionLabel='disk description' disks.vmdisk1.capacity=json:1342177280
    

    The issue of course is, how do i get the settings for disk size and memory. When i try to:

     xo-upload-ova --inspect Spiceworks-Production.ova 1fee8757-644e-2bce-beb0-9f85380a5842
    

    It doesn't know where that file is, does it have to be on a Local SR to XOA?


  • XCP-ng Team

    Ping @nraynaud who did that


  • XCP-ng Team

    I am looking into it on my side. I might come back with questions.



  • OK no problem, i look forward to hearing from you. 😊



  • @nraynaud Any update?


  • XCP-ng Team

    I'm still on it, I think I found an unrelated bug whose effect would be to upload a VM without any disk.


  • XCP-ng Team

    I think I got the bug, there is some cleanup and QA to be done before releasing a fix.



  • @nraynaud Thanks for working on this. Is the fix pushed to the latest stream or still in QA?


  • XCP-ng Team

    It will be released very soon 🙂 (for this month release)



  • @olivierlambert Thanks!


Log in to reply
 

XCP-ng Pro Support

XCP-ng Pro Support