Facing issues while starting xo-server after following install from sources instructions for current master

  • I fetched current master and followed the same instructions that we follow for building xo from sources and start it.
    The initial requirements(exact node version and other build requirements) of building from sources were in place.
    The build worked fine but I was facing issues while starting the xo using yarn start.
    It complains about undefined parameters. e.g. config.blockedAtOptions
    As per installation instructions I copied sample-config.toml and I observed that those parameters are not present in sample-config.toml.
    I found those parameters in config.toml (in packages/xo-server)
    So I copied config.toml file but again I was facing some issues with that configuration file as well.
    I was getting, following response in this case after login and even login page was also appearing without icons. :
    Cannot GET /
    this was related to checking of xo-web in wrong location.
    When I hard coded path of xo-web, it worked.
    If anyone have tried new master and followed same installation from sources instructions, kindly share their experiences.

  • I haven't performed a direct from source install in a while manually, but using my install script just worked.


  • @DustinB Thanks for replying, will definitely try this once.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support