Strange issue with booting XCP-NG

  • Hey R1,

    I tried the first option as well, to keep it running for like 45 mins to 1 hour, but it stays at a black screen... Could not connect to XCP-NG either or ping the machine.

    Well I have knowledge of Grub, though I don't want to change options there as this is one option which is I hope not 'permanent'. So I will just leave the graphics card out of it for now, when I have installed the server in the rack without being connected to a monitor.

  • @Appollonius did you leave the dongles attached or remove them also? If you need them in and don't have a spare monitor may be you can use one of these dummy HDMI plug.

  • Ahh could it be that, when I leave the dongle in the graphics card that XCP-NG detects it? Because when I detached my monitor I also detached the dongle (MiniDP -> DP)

  • I'm not sure it will work, depends on the type of dongle, but doesn't hurt to try.

  • @tony Well I just tried it to keep the dongle in but this gives me the same problem that I cannot connect to XCP-NG. The problem is I also cannot see what is going wrong, as when I plugin my monitor inside the dongle, XCP-NG will boot. But without the monitor screen it wont. It is a strange problem though...

  • @Appollonius the dongle is probably just a physical pin converter then. Does your host have on-board graphics? Do you have another GPU to try, preferably AMD so we can narrow down the issue.

    If you have another host that can run syslog server then you can try remote syslog.

  • Thanks for the suggestions Tony, unfortunately I dont have an AMD GPU nor another host. I think I will just leave the Quadro card out of it for now until there will be an fix for this. I don't know if there is a fix planned? Or will this be something that will stay with XCP-NG forever?

  • @Appollonius there will probably be a fix for this since many people use nVidia GPUs, if they can pinpoint the issue. Since this isn't solved by using gpumon like other cases, they'll need help testing the solution with feedback from people like you who have the problem.

  • @tony Well apparently it has something to do with the input. So when I connect the dongle to my monitor it does properly startup. Though when I disconnect the monitor it does not. So in my opinion it has something to do with input, though I will try to find the service/proces that is handling this.

  • XCP-ng Team

    @Appollonius Your kern.log should be able to tell more. Can you boot without and with, and share that file?

  • Hello @r1 I will send you the kern.log file today, when I finish this document I will try and get the kern.log for you 🙂

  • I am still curious whether or not this is being worked on as I have an Nvidia quadro P400 which is now laying on my desk doing nothing but gathering dust because when I put it in my Server without video output I cannot even use the server because xcp-ng does not properly boot.

  • XCP-ng Team

    @Appollonius can you edit the grub config and remove console=vga vga=mode-0x0311 from multiboot2 /boot/xen.gz line and report back?

  • @r1 As it looks now, this unfortunately did not solve the issue. Though I will send you the recent kern.log data. Is there something I need to configure in the BIOS to be able to boot properly with XCP-NG with a GPU?

    Here is the paste of the recent boot, from timestamp 18:18 is the boot periode with the graphics card:

    I can narrow the issue down a bit more, when I have no monitor connected XCP-NG/Xenserver will not boot. But with monitor connected to the GPU then it will boot. So it has something to do with the display I think.

  • XCP-ng Team

    @Appollonius they are still pretty same. So this means that there is no issue for system to boot (with or without GPU) but must be something to do with network config.

    Can you check if you have something in /var/log/xensource.log indicating a service failure/network start fail?

  • I dont see any failed services, though I have a question. The nvidia GPU (Quadro P400), do I have to configure Passthrough first? Maybe that could be the problem, as when I look into the host GPU's now it does not detect the GPU at all...

  • XCP-ng Team

    @Appollonius if you are using that GPU in a VM, yes, you need to enable passthrough for that pci id.

  • @r1 Well I will be in the future, but XCP-NG does not detect a GPU at all. Maybe that could be the cause of this issue? Atleast I think, as I see no GPU's listed in XCP-NG Center.

  • XCP-ng Team

    @Appollonius check # lspci -k or # lshw -c display

  • @r1 said in Strange issue with booting XCP-NG:

    lshw -c display

    lshw -c display
      *-display UNCLAIMED       
           description: VGA compatible controller
           product: GP107GL [Quadro P400]
           vendor: NVIDIA Corporation
           physical id: 0
           bus info: pci@0000:07:00.0
           version: a1
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress vga_controller bus_master cap_list
           configuration: latency=0
           resources: memory:fb000000-fbffffff memory:d0000000-dfffffff memory:e0000000-e1ffffff ioport:e000(size=128) memory:c0000-dffff

    This is what I see, so I it does see that its there but for some reason it does not see the card in XCP-NG Center.

    Ohh wait, is that the Nvidia 'driver' problem? Which AMD cards dont have?

    In XO it does see the graphics card, so happy about that. Now I am still curious why it does not boot properly when the NVidia GPU is plugged in.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support