• Hi, So I've installed XCP-NG on bare metal and with IP Addr: with Gateway of then
    I go to the webserver and typed then choose quick deploy and setup a root password, and for the IP address I still pick same as my server then after all that I see this!!XCP error 2.PNG .
    Then I tried adding a XOA with different IP address... but I still can't see the new button... XCP error 1.PNG .

    Please help... Should I install XCP-NG in a network with an existing DHCP server? Thanking

  • I think I had this issue before, have you checked the Home tab?

  • Here is my XOA tabXCP3.PNG
    and this is my home tab XCP4.PNG the is my XCP-NG server... Should my XCP-NG server and XOA have the same IP address? or my XOA should be different?

  • XCP-ng Team

    I'm pretty sure the "new" button doesn't show up until XOA succesfully connects to at least one host, and in your screenshot for "servers", it's showing a red warning triangle next to both hosstds you've added, so I don't think it's connected.

    Indeed XOA definitely needs to have it's own IP address, and your hosts all need unique IP addresses to. Then just go to settings > servers as you have and add the IPs of all your xen hosts just like you would in xcp-ng center/xencenter.

    If you hover over the red triangle, it should tell you the error. Another step would be to login to the console (ssh) of the XOA VM, and try to ping those two host IPs to see if it's maybe a network issue (if the XOA appliance can't reach the hosts' IPs, then it's definitely not going to work)

    judging from the network errors I see in your update panel screenshot, it seems the XOA appliance doesn't have it's networking totally set up properly. I'd follow this on the XOA VM to ensure it has a gateway, DNS etc set properly: https://xen-orchestra.com/docs/troubleshooting.html#network-issues

  • Thank you! I'll try that... Should I separate the network for setting up? Like have a separate router as DHCP server then connect XCP-NG-Server.

  • To test you don't need to separate the network, if you are using DHCP, check your DHCP server that XOA is grabbing the IP from it. If you are using static IP, check that you have assigned gateway and DNS as fohdeesha suggested.

    If your XOA VM can ping the internet (ie. then that is a good start.

  • @tony In the XCP-NG-Server > Virtual Machines > All VMs > Should I run the XOA or quick deploy will do that?

  • @IT-Dept you already have XOA VM installed and running so you don't need to deploy it again. Just ssh into the VM (same IP as the web interface you are accessing) and check your network config and try to ping.

  • I did a fresh install of XCP NG with IP addr of then ssh to the server do a yum upgrade after that I go to browser and type and create a XOA Appliance with Address.
    But I received this error... I noticed that on my XCP-NG-Server > Virtual Machines > All VMs there's 2 XOA > Power State :Halted 2GB RAM VMs.

    XCP error 5.png .

    Then I tried to force start the XOA from the XCP-NG-Server but Failed: HVM is required for this operation.

  • I've enabled VT for virtual machine.. and we can see the "New tab" !![0_1600686260955_XCP 6.png](Uploading 100%)

  • @IT-Dept so everything is working fine now or you still need help?

  • My license is free now but everything works fine! Thank you guys!

  • @tony Is it normal to have 2XOA with the same IP address?

  • @IT-Dept nope, it is not normal to have any two VMs running with the same IP period. Why do you have 2 XOA installed anyway?

  • @tony I removed the 2nd XOA... I think that's the reason I'm lagging but now everything is smooth...

XCP-ng Pro Support

XCP-ng Pro Support