Strange issue with booting XCP-NG

  • Hello everybody,
    I recently installed XCP-NG again on my server and it works like a charm. Though I also have an Nvidia Geforce Quadro P400 installed. But when I have no displayport cable or HDMI or whatsoever connected to the P400, XCP-NG does not boot properly for some strange reason. I cannot connect to it through XCP-NG Center neither can I see something on the screen when I connect a DisplayPort cable to the P400 later on.

    Though when I plugin a Displayport cable or HDMI cable and connect it to a monitor from the start when I boot up the whole server I can see all the startup items is processes and it boots up fine. I can now connect to XCP-NG Center.

    So my question is, what is the problem here? Could it be the nvidia drivers not being installed or?
    I am curious about what this could be...

  • Have you checked the Known Issues?

  • Ah thanks, havent seen that yet. Though I did a fresh install yesterday as I builded the server yesterday as well. I installed the newest version of XCP-NG, so this one should have the gpumon installed, which solves the issue?

  • Weird, the new ISO should already include gpumon, can you double check the version? Does your motherboard have on-board graphics? Which version of P400 are you using? Does it come with any dongle in the box?

  • Yeah I double checked the ISO it is version xcp-ng-8.1.0-2.iso so it should have the gpumon.
    I am using the PNY Quadro P400 and comes with a dongle as it does only support Mini Display. So I have dongles for Minid Display to DisplayPort, but also to DVI, HDMI etc.

    My motherboard does not have on-board graphics.

    I also have the EFI_MEMMAP issue on bootup but that one does not bother me at all, it does boot after some minutes, due to the NTP services not responding (As I researched it). But the Graphics Card issue does not boot my system up it just staggers.

  • I wonder if this can be solved with a GRUB modification. Perhaps one of the devs will find time to comment on this.

  • XCP-ng Team

    @Appollonius I think you should let the system boot without cable for some time (30min) and then attach the cable to see what's on screen? Whether system is waiting for something.

    Other option which we are trying on other thread is to use nomodset which should let system boot before loading the display driver. Typically you would add this on vmlinuz line by editing grub option.

  • Hey R1,

    I tried the first option as well, to keep it running for like 45 mins to 1 hour, but it stays at a black screen... Could not connect to XCP-NG either or ping the machine.

    Well I have knowledge of Grub, though I don't want to change options there as this is one option which is I hope not 'permanent'. So I will just leave the graphics card out of it for now, when I have installed the server in the rack without being connected to a monitor.

  • @Appollonius did you leave the dongles attached or remove them also? If you need them in and don't have a spare monitor may be you can use one of these dummy HDMI plug.

  • Ahh could it be that, when I leave the dongle in the graphics card that XCP-NG detects it? Because when I detached my monitor I also detached the dongle (MiniDP -> DP)

  • I'm not sure it will work, depends on the type of dongle, but doesn't hurt to try.

  • @tony Well I just tried it to keep the dongle in but this gives me the same problem that I cannot connect to XCP-NG. The problem is I also cannot see what is going wrong, as when I plugin my monitor inside the dongle, XCP-NG will boot. But without the monitor screen it wont. It is a strange problem though...

  • @Appollonius the dongle is probably just a physical pin converter then. Does your host have on-board graphics? Do you have another GPU to try, preferably AMD so we can narrow down the issue.

    If you have another host that can run syslog server then you can try remote syslog.

  • Thanks for the suggestions Tony, unfortunately I dont have an AMD GPU nor another host. I think I will just leave the Quadro card out of it for now until there will be an fix for this. I don't know if there is a fix planned? Or will this be something that will stay with XCP-NG forever?

  • @Appollonius there will probably be a fix for this since many people use nVidia GPUs, if they can pinpoint the issue. Since this isn't solved by using gpumon like other cases, they'll need help testing the solution with feedback from people like you who have the problem.

  • @tony Well apparently it has something to do with the input. So when I connect the dongle to my monitor it does properly startup. Though when I disconnect the monitor it does not. So in my opinion it has something to do with input, though I will try to find the service/proces that is handling this.

  • XCP-ng Team

    @Appollonius Your kern.log should be able to tell more. Can you boot without and with, and share that file?

  • Hello @r1 I will send you the kern.log file today, when I finish this document I will try and get the kern.log for you 🙂

  • I am still curious whether or not this is being worked on as I have an Nvidia quadro P400 which is now laying on my desk doing nothing but gathering dust because when I put it in my Server without video output I cannot even use the server because xcp-ng does not properly boot.

  • XCP-ng Team

    @Appollonius can you edit the grub config and remove console=vga vga=mode-0x0311 from multiboot2 /boot/xen.gz line and report back?

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support