XCP-ng Windows PV Drivers 8.2.2


  • Admin

    Okay I'll try again to test to see if I can reproduce, but last time I did it worked well. Are you using the Win 10 template?



  • Yes. When I created the VM, I chose the Win 10 64-bit template.

    Are there separate drivers? One from the Win update repo and then this one?


  • Admin

    Don't use both! From Windows updates, they are Citrix drivers. They can enter in conflict with ours. Despite the code is the same, the signature is not and they probably can compete each other.



  • Well then that is the problem. The "Get Windows Update" is defaulted to "On" I think. I didn't know they essentially do similar things.

    I need to create a new VM then and make sure I turn off that feature before booting the Win 10 image. Then I can install your set.


  • Admin

    It's not defaulted on "on", except if it's a custom template. If you chose to have Windows update driver, then don't install PV drivers manually.


  • Admin

    I did a test on my side: works well with our driver package:

    win10.png



  • Mine shows "Allow Windows update" or something similar and I didn't enable that.

    I know I used a template. I'll remove and recreate the VM and see if it defaults the Win update setting.

    I appreciate you checking. Good to know it's working. I just need to see why Windows update pulled it in.

    Is there any difference between the two or is it same things with different names?


  • Admin

    Yes, just leave "Windows Update tools" disabled, that's it 🙂



  • Thanks Olivier. Loving the lab I setup so far. Really impressed with the entire infrastructure you guys have managed to put together.



  • @olivierlambert So I just created a new Win 10 VM and made sure to use the template. I created this VM in the XCP-NG XenCenter. I then went into XOA and "Windows Update Tools" is checked to the on position by default.

    This is what the problem I had earlier was. The VM defaults to grabbing the guest tools from the WU server. So if you boot up the 1st time with this configuration, it will grab the Citrix tools 1st and you can't install the community tools.



  • Will the XCP-NG Windows PV Drivers fixed the network bottleneck issues? I have XenServer drivers installed and a 1Gb connection but only getting 100kbps speed from any of the windows VMs


  • Admin

    @FPIT with PV tools, you should have 1Gbit network transfer rate, yes. This speed you have is more like the default emulated hardware.



  • @olivierlambert I have Xenserver PV drivers but it says they are from 2017 and I have a windows 10 computer hosting quickbooks and an employee is having terrible performance issues but we didnt have these performance issues with Hyper-V. Could it be related to the PV drivers being out of date?


  • Admin

    Check in the device manager to see if all PV drivers are installed. Eg the network interface shouldn't be Realtek 8139 but Xen PV NIC or something like that.



  • Yea I did the windowsupdate checkbox in XO for the windows computers, but we still seem to have the same issues. I saw that broadcom NICs have performance problems with Xen and in general so that might be it. Im going to update the firmware and see and also add another network card to see if its the NICs in general. But im also gonna test the XCP-NG version windows drivers to see if they may be more compatible.


  • Admin

    Please tell us about the NIC name in the device manager.



  • Well I just carved out a new server with Windows 2012 R2 on it to test running quickbooks to see if its maybe windows 10 thats being dumb like usual. But on the new server I am seeing XCP PV network device #0 and on the windows 10 one I was seeing XenServer PV network device #0


  • Admin

    And both have identical network perfs?



  • Yes. I ran tests and everything seems perfectly fine until using quickbooks. Still having issues with Windows Server even. We are running some more scenarios to try to pin point the exact cause of the issue. Everything seems to run normal besides quickbooks. I wouldnt figure the network adapters would have anything to do with it if everything else seems to run fine.



  • Hello 🙂

    I wanted to update the guest via https://github.com/xcp-ng/win-pv-drivers/releases (8.2.2.200);

    Result, blue screen reboot ... Reign an old snapshot, I had to remove and put the VM on the field ....
    So, I do not know how I am going to make this update of the guest tools, because yet the windows update was up to date ...

    (They say that it is necessary to update WindowsUpdate before, it was good though ....; https://xcp-ng.org/forum/topic/1690/windows-10-1803-crash-with-installed-guest-tools I n did not have the same message and the same blue screen, but I still had that (on windows server 2016))

    The option on XOA for Windows drivers is unchecked.
    The language of windows server 2016 is in English (I tried on two servers with Snap happily ...).
    VMs update by Windows update normally.

    An idea for those who have succeeded?

    Thank you very much in advance.

    Hello 🙂

    J'ai voulu mettre à jour les guest via https://github.com/xcp-ng/win-pv-drivers/releases (8.2.2.200);

    Résultat, écran bleu au reboot... Reprit un ancien snapshot, j'ai du enlevé et remettre la VM sur le domaine....
    Du coup, je ne sais pas comment je vais faire pour faire cette mise à jour des guest tools, car pourtant le windows update était à jour...

    (Ils disent qu'il faut bien mettre à jour WindowsUpdate avant, il l'était bien pourtant.... ; https://xcp-ng.org/forum/topic/1690/windows-10-1803-crash-with-installed-guest-tools Je n'ai pas eu le même message et le même écran bleu, mais j'ai tout de même eu ça (Sur windows server 2016))

    L'option sur XOA pour les drivers Windows est bien décochée.
    La langue des windows server 2016 est en anglais (j'ai essayé sur deux serveurs avec du Snap heureusement...).
    Les VMs se mettent à jour via Windows update normalement.

    Une idée pour ceux ayant réussi ?

    Merci beaucoup par avance.


Log in to reply
 

XCP-ng Pro Support