XCP-ng Windows PV Drivers 8.2.2

  • XCP-ng Team

    Please tell us about the NIC name in the device manager.

  • Well I just carved out a new server with Windows 2012 R2 on it to test running quickbooks to see if its maybe windows 10 thats being dumb like usual. But on the new server I am seeing XCP PV network device #0 and on the windows 10 one I was seeing XenServer PV network device #0

  • XCP-ng Team

    And both have identical network perfs?

  • Yes. I ran tests and everything seems perfectly fine until using quickbooks. Still having issues with Windows Server even. We are running some more scenarios to try to pin point the exact cause of the issue. Everything seems to run normal besides quickbooks. I wouldnt figure the network adapters would have anything to do with it if everything else seems to run fine.

  • Hello 🙂

    I wanted to update the guest via https://github.com/xcp-ng/win-pv-drivers/releases (;

    Result, blue screen reboot ... Reign an old snapshot, I had to remove and put the VM on the field ....
    So, I do not know how I am going to make this update of the guest tools, because yet the windows update was up to date ...

    (They say that it is necessary to update WindowsUpdate before, it was good though ....; https://xcp-ng.org/forum/topic/1690/windows-10-1803-crash-with-installed-guest-tools I n did not have the same message and the same blue screen, but I still had that (on windows server 2016))

    The option on XOA for Windows drivers is unchecked.
    The language of windows server 2016 is in English (I tried on two servers with Snap happily ...).
    VMs update by Windows update normally.

    An idea for those who have succeeded?

    Thank you very much in advance.

    Hello 🙂

    J'ai voulu mettre à jour les guest via https://github.com/xcp-ng/win-pv-drivers/releases (;

    Résultat, écran bleu au reboot... Reprit un ancien snapshot, j'ai du enlevé et remettre la VM sur le domaine....
    Du coup, je ne sais pas comment je vais faire pour faire cette mise à jour des guest tools, car pourtant le windows update était à jour...

    (Ils disent qu'il faut bien mettre à jour WindowsUpdate avant, il l'était bien pourtant.... ; https://xcp-ng.org/forum/topic/1690/windows-10-1803-crash-with-installed-guest-tools Je n'ai pas eu le même message et le même écran bleu, mais j'ai tout de même eu ça (Sur windows server 2016))

    L'option sur XOA pour les drivers Windows est bien décochée.
    La langue des windows server 2016 est en anglais (j'ai essayé sur deux serveurs avec du Snap heureusement...).
    Les VMs se mettent à jour via Windows update normalement.

    Une idée pour ceux ayant réussi ?

    Merci beaucoup par avance.

  • @olivierlambert So I moved the quickbooks data files to my computer and hosted them and everything is working without any issues. My server has a Broadcom BCM7520 NIC in it. Could it be an issue with Broadcom NICs that could be causing this issue?

  • XCP-ng Team

    Oh yes. Broadcom NIC are shitty network cards. Take a look at dmesg maybe you'll see some errors there. Also check lost or error packets.

    We have a more recent driver available in our test kernel: https://github.com/xcp-ng/xcp/wiki/Alternate-kernel

  • I just did an iperf test to the server being hosted and even with the 2 broadcom NICs bonded, im getting 1MB transfer rate. Should I change the NIC type to e1000 or does that not matter? Should I just get an intel NIC?

  • Nevermind I ran it again and it now shows 100MBytes

  • Should I still just get a different NIC card?

XCP-ng Pro Support

XCP-ng Pro Support