Windows 7 VM backup issues

  • Hi Guys,
    I am not sure whether these are XOA issues or XCP-ng issues. I am experiencing the following issues when I tried to backup a Windows 7 VM:

    1. When I use "offline snapshot" method to perform a backup, I got:
    Error: VM_LACKS_FEATURE(OpaqueRef:6b7d4cd0-d8e9-414c-a865-66563ba8c27d)
    1. Then when I shutdown windows manually, then tried to perform backup, I got:
    1. Then now, when I detached USB Passthrough (USB NIC for optional remote VPN access) to this VM, then when I tried to perform a backup, I get:
    Error: SR_BACKEND_FAILURE_82(, Failed to snapshot VDI [opterr=Command ['/usr/bin/vhd-util', 'query', '--debug', '-vsf', '-n', '/dev/VG_XenStorage-f70a9d3e-5f10-8788-6f0c-16f592062c23/VHD-e34d8d0a-8fa6-4b25-b88c-4b75b814ebdd'] failed (error opening /dev/VG_XenStorage-f70a9d3e-5f10-8788-6f0c-16f592062c23/VHD-e34d8d0a-8fa6-4b25-b88c-4b75b814ebdd: -2): No such file or directory], )

    I was wondering whether anyone has experienced these issues? If you have, then how did you end up backing up your VM?
    By the way, with vanilla windows 7 installed on a new VM I could perform both delta backup and basic backup. Then after windows installed all the updates, I see this 3rd issue 😞
    I need the updates installed as some of the accounting software requires these windows updates.

Log in to reply

XCP-ng Pro Support