[XCP-ng Center] Enhancement: Add force option to migrate dialog

  • XCP-ng Center Team

    I'm on the way to implement a option to force the migration of VMs.

    We need someone, who has the possibility to test with this special case:

    • two single XCP-ng hosts
    • their CPU-Features should differ
    • the "Migrate to Server" context menu shows: The host does not have some of the CPU features that the VM is currently using

    Details are here: https://github.com/xcp-ng/xenadmin/issues/66#issuecomment-405051703


  • This is a quite ancient thread, but I'm answering anyway.

    I've done some tests with the Force-Migration Wizard in XCP-NG 8.1.

    Expected/Desired behaviour:

    VM is running during migration and after migration. Reboot is done after migration had finished, to activate the new cpu feature mask.

    In no case it worked as desired. The outcomes of the tries:

    • the vm crashed, was halted on source server
    • the migration was logged as successful, but the vm was halted on the target server

    I have 3 different cpu models, with which I tested Force-Migration:

    • Intel(R) Xeon(R) CPU E5506 @ 2.13GHz (oldest)
    • Intel(R) Xeon(R) CPU E5620 @ 2.40GHz
    • Intel(R) Xeon(R) CPU E5-2643 v2 @ 3.50GHz(newest)

    Maybe this feature is only useful, if the cpu features differ only very slightly?


  • @fx991 You cannot live-migrate between hosts with processors that have different instruction sets.

    You would have to shut down the VM and then migrate it and then power it back on after migration completes.

    The E5506 and E5620 have similar instruction sets but the E5506 does not support hyperthreading or AES instructions, so there are some differences here.

    The E5-2643 v2 is completely different.

    If you power off your VM and then migrate it, it should be fine. From what I understood from your post you tried to live-migrate it and then reboot it after it had migrated and run into issues, which I would expect to happen.


  • In the github issue referenced above, I read:

    live migration from e.g. xeon v3 to xeon v4 fails because of cpu mismatch.. xe vm-migrate command line with force it mostly works fine...

    Ok. It seems to be like If you checked it to work manually you can force it


  • @fx991 Mostly fine means that you may run into issues. Just shut down your VM and restart it on the new host.

XCP-ng Pro Support

XCP-ng Pro Support