[Test] XCP-ng 7.5.0 Windows PV-Drivers and Management Agent

  • @borzel

    Like this? Or am I still missing something?

    0_1535537760499_Screen Shot 2018-08-27 at 21.16.05.jpg

  • XCP-ng Center Team

    @cowboy you are using the Critix drivers, they do not work with XCP-ng management agent.

    It's better to wait for our official drivers, because replacing the Citrixdrivers is currently a pain and I did not test this process in its fully dimension.

  • @borzel Oh crap, how did I manage that? 😮

    Not a problem tho - I have a Snapshot image I can revert this too before the installation of the PV drivers.

    Would you be so kind as to direct me to the latest and greatest and proper PV drivers I should be using & I'll revert snapshots and install those. 🙂

  • XCP-ng Center Team

    @borzel said in [Test] XCP-ng 7.5.0 Windows PV-Drivers and Management Agent:

    It's better to wait for our official drivers

    currently we don't have them

  • @borzel said in [Test] XCP-ng 7.5.0 Windows PV-Drivers and Management Agent:

    currently we don't have them

    I'm confused now. I thought that's what I was installing....I am running XCP-ng 7.5 here. I haven't downloaded anything from Citrix at all.

    Edited to add: Okay, I just went back and re-installed Windows10 from scratch and see I end up automatically with XenServer PV drivers. How do I get the XCP-ng pre-release PV drivers installed then?

  • XCP-ng Center Team

    @cowboy we do not have official signed drivers. Thats why we just have the test drivers out.

  • XCP-ng Center Team

    @cowboy said in [Test] XCP-ng 7.5.0 Windows PV-Drivers and Management Agent:

    How do I get the XCP-ng pre-release PV drivers installed then?

    Thats the big question in the moment. I had no time to test. So please wait a bit ...

  • @borzel Okay, I'll wait. I just was very much wanting to help test them. This whole system is a 'test system' for me to play with. 🙂

    Enjoy your vacation. 👍

  • XCP-ng Center Team

  • @borzel

    Tried to install the Test drivers on a new W2012R2 build.

    With the test drivers it looks as if its going to work but fails with:

    "Windows Management Agent failed to install."

    The Event log has the following errors:




    Tried pulling the drivers down via Windowsupdate but nothing happens. Not had any issues with W2016/2019.

  • XCP-ng Center Team

    @allootikeechaat did you restart your windows? After a reboot it should work.

  • @borzel

    Yep restarting fixed it .. good to know I had assumed that the install had failed completely.

  • @allootikeechaat Hi, I have an issue with Windows Server Essentials 2016 when using XCP-ng 7.5 with a MegaRAID 9361-4i configured as RAID 10 using 2TB drives (on Intel M/B with E3 CPU). Windows Server 2016 Standard is fine, but Essentials will either install and then not boot again (perhaps it happens after Windows updates the disk drivers?), or if I copy it from another server, it always stops during boot. I haven't got any 1TB drives to test a RAID 10 on it but have also tried a RAID 10 (and RAID 0 as a test) with 3TB drives and it also failed, but using RAID 1 with the 3TB drives it is fine. I have only just found this thread and haven't got any screen caps to share unless I reconfigure the RAID 10 again, can do if it would help. Just wondering if anyone has experienced this issues with Windows Server Essentials 2016, and perhaps these new divers may help ? Have only noticed this issue when setting up this Server, other test servers with small disk partitions not a problem and not using RAID 10 on them either.

  • XCP-ng Center Team

    @dlkcon I assume you installed XCP-ng on your hardware server? And you installed windows in a vm? If so, there is no relation between drivers and your hardware raid. Windows can not see on which SR its VDIs are located.

  • @borzel Thank you, yes XCP-ng is installed on the server and the Server Essentials 2016 is installed in a vm. I have Xen Orchestra Community version installed too and the Windows Update tools are switched on. I know that the there shouldn't be any relation between the RAID type and vm's but I have tried 2 x sets of disks, 4 x 2TB Seagate EXOS and 4 x 3TB Toshiba desktop types and the RAID 10 failed. I have now used the same controller with the Toshiba drives running in RAID 1 and it is fine, the total size is less that approx 4TB or 6TB that the 2 sets of disks. Windows Server 2016 Standard was ok. I just wondered if Windows Essentials Server 2016 used different disk drivers than the Standard server. This topic seemed to be discussing an issue with Windows 10 disk drivers ....

  • XCP-ng Center Team

    @dlkcon there is no difference with or without disk drivers inside a vm. If your SR does work for one vm it works also for other vms, no matter what OS or drivers are used inside that VM.

    If a VM boots on server A and not on Server B than the Server is faulty or the VM got corrupt during the transfer.

    Did you check your RAID-controller? Maybe it is faulty with RAID10?

    Do you have any logfiles? Screenshots?

  • I have just reinstated the RAID 10, downloaded a new copy of the installation ISO for Essential Server 2016 and done a clean install. After it restarts it halts during the reboot, where do I find the relevant log files you want to see, perhaps they will be better than a screen shot.

    I have also installed Server 2016 Standard and it is fine, it reboots and I can login and download updates, it is currently prompting me to reboot after the XenServer PV Host adaptor has been loaded.

    I note that the driver used on the installation is avago-megaraid-sas-07.701.18.00+rc1-1.el7.centos.x86_64.rpm, but there appears to be a newer version on the Broadcom website 07.706.03.00-1 but its a bit beyond me as to how to install it, none of the rpm files in the downloaded file are similar in wording to the one installed with XCP-ng.

  • In my attempt to update the disk driver I crashed the installation and reconfigured the disk sets in the RAID 10 and reinstalled XCP-ng. I was able to install both Essentials and Standard Server 2016, all working downloaded updates rebooted the vm's and server.. I copied the vm from my old HP (also installed with XCP-ng 7.5) with XCP-ng center and it too has worked all day. I decided to copy the SQL vm across to the new server using XCP-ng center but a message showed up to say that ('name of new server' you attempted to copy a VDI to or from an SR that doesn't support migration). I shut down the Essentials vm and rebooted the new server, I still couldn't copy the SQL vm from from the old server and now both the copied Essentials + clean install Essentials vm will not boot although the Standard Server 2016 will still boot with no issues.

  • XCP-ng Center Team

    @dlkcon that's (maybe) at all not releated to our PV-Drivers. Please open a new thread, so we all can discuss your issue there 🙂

  • XCP-ng Center Team

    Hello @all there in the World,

    I'm currently on analysing why the PV-driver install over Citrix-Drivers is not working.

    I have a test-VM from someone (Windows Server 2012 R2) on which Windows does not accept the test signed driver's.
    I did some tests but don't know why it's not working 😐

    (I perfectly followed MS instructions at https://docs.microsoft.com/en-us/windows-hardware/drivers/install/signing-drivers-during-development-and-test)

    In C:\Windows\Inf\setupapi.log you can find the lines

    File 'C:\Windows\system32\DRIVERS\xen.sys' pruned from copy.
    VerfiyTrustFailed for C:\Windows\system32\xen.sys.

    The test-signature is valid:


    ❓ ❓ ❓ ❓ ❓ ❓ ❓ ❓ ❓

    Has someone a clue? I'm lost in Windowspace 👨‍🚀

    ❓ ❓ ❓ ❓ ❓ ❓ ❓ ❓ ❓

XCP-ng Pro Support

XCP-ng Pro Support