An updated installer for XCP-ng 7.5.0

  • XCP-ng Team


    There may be interesting error messages in the tty3 console (ALT+F3) to switch to it during the raid creation. Can you check and provide them here?

  • XCP-ng Team

    @frank-s Could you re-try the sequence and give us the error message please. You might have found a secondary issue with the error handler, it should have shown the message.

  • I have created two ILO recordings for you to review created in HP ILO4 standalone console . You will be able to see exactly what is happening. How do I send them to you? I have tried the "Upload Image" button but apparently I don't have sufficient privileges to do that. They are small files at 188KB and 124KB.

  • I think the interface does not like the file extension .ilo If I change it to .jpg it uploads but rejects with invalid file signature.

  • You can download the recordings from here:

    Also you will find there the ilo4 standalone console setup file should you need it. I await your response. Thanks

  • @frank-s Hello again. My issue is resolved. I was using used disks which had previously been used with mdadm. Although I applied "mdadm --zero-superblock" to every partition and the device itself before deleting the partition tables and dd zeroed the first 50 Gigs of the drives, the installer didn't like it. Maybe I should also have zeroed the end of the drive??? Anyway I zeroed out the entire drive (both of them) with dd and the installer worked like a charm. I also tested upgrade which also worked flawlessly.
    Thank you for the great work you are doing. Over the years I have spent many many hours loading xenserver with bootable raid. This is going to make life so much easier...

  • XCP-ng Team

    It's now released, thanks for the tests that allowed to improve it:

  • So,
    I tried the ISO but I am not able to create the volume with the softraid; I do not understand where I'm wrong but after choosing the volumes the screen remains blue and does not continue the installation even waiting for minutes...

    What I see:

    1. one process with mdadm that does nothing
    2. strange, I expected to find /proc/mdstat but it is not present
    3. I read error messages on the log terminal (F3)

    mdadm: Unrecognised md component device - /dev/sda
    mdadm: Unrecognised md component device - /dev/sdb

    I tried with the various options (install, safe, multipath) but none seems to go; and I can not understand where I'm wrong.

    PS: The installation test is performed on non-empty disks, where there is a partitioning and an old installation of XenServer 6.2. I have not tried to wipe the disks, I would first understand if I do not skip a few steps...


  • XCP-ng Team

    @rinux Have these disks been used for RAID in the past? There may be some cases where the steps we took to clean the disks are incomplete.

    What's the MD5SUM of the ISO you used (would be a good habit to automatically give that kind of information :))?

  • @stormi no, the disk pair contains an old installation of XenServer (no raid) and I do not think it has ever been used for anything else... md5sum of the ISO: deb2a0990390a6a4eb51a428b6a53995 (the same as the one shown here!).

    I'm not quite inside the xen logic, but on dom0 I do not find any trace of the availability of raid software profiles ... I figured I could find something with "dmesg | grep md" ... sure I'm not forgetting some boot options?

  • XCP-ng Team

    @rinux The version we released officially has had fixes. Please try it:

  • @frank-s newbie here, just 1 week of trying to use, have that exactly same problem, already make raid, did some things, when trying to install again, md127p1 is already in use, I know need the zero raid... But I don't know how.... Using another live Linux?

  • For me it was old mdadm superblocks. Once the partition tables have been deleted they could be anywhere depending on the original raid setup. Best thing is zero the entire disk.

    dd if=/dev/zero of=/dev/sdx bs=1M status=progress
    where x is your drive letter.

    Do this for each raid disk
    Then go and drink some beers. It will take some time...

  • @frank-s, very thanks for the help!
    where I run this line? on shell option at xcp-ng instalation screen, or f3 when installing, or using another live linux?

  • XCP-ng Team

    To avoid filling the whole disk with zeros, you can probably "just" do a mdadm --zero-superblock /dev/sdX (for each disk).

    If it's not enough, please report back 🙂

    @dvdhngs when you are in any menu in the install, use Alt key + right arrow to get a console.

  • @olivierlambert
    I did that Olivier but for me it didn't work. That's why I zeroed both disks entirely. Worth a try though as it doesn't take long.

  • XCP-ng Team

    Do you remember, on this disk, which version of mdadm superblocks did you used before?

  • @olivierlambert
    Hmmm. It might have been 0.9 as it was for boot partition. It wasn't whole disk raid though. Each partition was a different raid set.

  • XCP-ng Team

    I see now! Because we zero the superblock on the whole disk, it doesn't zero all the superblocks on all existing partitions.

    I wonder if doing a loop that runs the zero superblock command on each partition would solved this 🙂

  • @olivierlambert
    Probably that would work or as an alternative use dd to zero the first 45GiB of each disk shouldn't take too long. I was not pressed for time and had other things to do so I just zeroed the disks entirely after which setup was flawless.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support