XCP-ng 8.0.0 Beta now available!


  • Admin

    I think it's a good thing to focus on one "best" tier-one solution, especially on a "small" community like us 🙂



  • HP DL360 v7 with (2) Intel E5649 working good so far. Just finished installation and yum updates and everything came right up, as expected.



  • As a sidenote for everyone interested into ZFS: Look at the release notes:
    https://github.com/zfsonlinux/zfs/releases

    Especially for (my recommended to consider) dedup:

    Allocation classes #5182 - Allows a pool to include a small number of high-performance SSD devices that are dedicated to storing specific types of frequently accessed blocks (e.g. metadata, DDT data, or small file blocks). A pool can opt-in to this feature by adding a special or dedup top-level device.
    

    That means RAM is no more critical (for people who didn't have enough): These dater can now 'oflload' to SSDs, whereas special storage types like Intel Optane should be perfect for that, as they can demonstrate their advantages (high IOPS at small queues, durability, access-time).
    Optane m.2 cards became pretty affordable - but that feature requires mirroring, so you need 2 of them (I see them priced about 26 € for 16 GB)!

    As the satet It's not only for dedup, it can also cover small file blocks and metadata, lowering IOPS on your storage.

    ALSO: TRIM/discard support!



  • I've installed on a HP ML10 G9 server and all works fine on this server using UEFI based BIOS configuration etc.

    The only issue I have found so far is when imported vmdk images using the wizard, even when I choose to set the BIOS to UEFI after the import and conversation has completed the VM won't boot. After looking at the settings for the newly created VM the BIOS is set to BIOS not UEFI.

    Simple to resolve either be detaching the storage and removing/recreating the virtual machine and re-attaching the original imported storage. Or I am guessing (although haven't tried yet), using the console to set the machine type.

    So possibly an issue with the Import Wizard?

    UPDATED

    I tried the shell commands to change the imported VM to UEFI, and although initially it looks fine when examining the console and seeing that the BIOS setting has updated. When trying to start the VM it won't boot due to an error. So after detaching the disk and deleting the VM I recreated a new VM using UEFI and no disk attached. Then once created I attached the original imported disk and it works fine.

    Also I using VirtualBox to export a VM to OCI Format 1.0 which was setup running as UEFI, after the import into XCP it had changed the BIOS to BIOS not UEFI. So again I followed what I did above and the VM works fine.

    So it does look like an issue with the Import Wizard, although it allows you the option to choose BIOS type it doesn't honour the setting and reverts to standard BIOS.



  • This post is deleted!


  • @olivierlambert said in XCP-ng 8.0.0 Beta now available!:

    Dom0 can't boot here. Likely related to a more recent kernel than in 7.6.

    Note that I don't have any issue on a Ryzen 7 (2xxx) nor EPYC.

    Anyone else with a 2200G?

    @olivierlambert Same here but with a Thread ripper CPU. With XCP-ng 8 RC1, I can get part way and then the "Hardware Dom0 halted: halting machine"

    With XCP-ng 7.6, but it gives a Panic on CPU 0 error and stops the install


  • Admin

    Try by reducing dom0 memory in Grub menu

    What threadripper exactly?



  • @olivierlambert AMD RYZEN Threadripper 2920X



  • @olivierlambert said in XCP-ng 8.0.0 Beta now available!:

    Try by reducing dom0 memory in Grub menu

    What threadripper exactly?

    Do you have a link to a good place to start looking to change that?


  • Admin

    When you boot in UEFI mode, press "e" to edit the boot command line, you have a line to change the memory for dom0.


Log in to reply