XCP-ng 8.0.0 Release Candidate

  • XCP-ng Team

    @achim71 I suppose you meant "built"..

    XCP-NG has its own variant of DDK at https://github.com/xcp-ng/xcp-ng-build-env

    Edit: replied on wrong topic.

  • Is there any possibility to make installer nonGUI?
    On my Ryzen 2400G can't load, it boots up, and after choosing installer the screen is just blank. Tried the same image on VM it starts the installer, but with some graphics.

    Addon: ok, i changed 8192M to 2048M in grub.cfg and was able to install the system. Everything is working fine. Now, i got a question: i did yum update and system told me that there is a new kernel with newer xcp-ng:

    kernel x86_64 4.19.19-5.0.9.xcpng8.0 xcp-ng-base 30 M
    xcp-ng-release x86_64 8.0.0-12 xcp-ng-base 15 k
    xcp-ng-release-config x86_64 8.0.0-12 xcp-ng-base 350 k
    xenserver-firstboot noarch 1.0.11-1.1.xcpng8.0 xcp-ng-base 20 k

    After installing and rebooting, it still shows that kernel is 4.19.0 - any idea how to fix? (not sure if xcp-ng itself updated to 8.0.0-12, in xsconsole it shows as 8.0.0)

  • XCP-ng Team

    The new kernel has the same version, except that it has been patched for a security issue. All good.

    There's no such thing as XCP-ng 8.0.0-12 either. 12 is the release number of the xcp-ng-release RPM package, version is 8.0.0.

  • XCP-ng Team

    Those having the 8.0 RC1 running, does live migration from shared storage to local storage (on the same host that is currently running the VM) work for you?

  • Hey

    I tried today to update version 7.6 to version 8.0 RC. Sadly the installer did not start.
    In normal upgrade mode the installer just hangs with a black screen and when i tried the installation in safe mode the installer halted with the message:

    (XEN)[   34.0279] Hardware Dom0 halted: halting maschine

    I have uploaded an image of the boot screen in safe mode:

  • Today i found out, that my xcp was restarted at 3.51AM. There is no crash dump in xcp center. Where do i look to find out what happened?

  • XCP-ng Team

  • @r1
    I thought it's obvious if i am asking in 8.0RC1 thread, that i have this verison.

  • XCP-ng Team

    @dave-opc Making sure that the version is up to date.

    Did you find anything in /var/log/kern.log?

  • XCP-ng Team

    @EliasSeccom Does ALT + Arrow keys (Left/Right) show you any erroneous messages? On one of the screen, there is a shell available.

    If its a hang which is not letting you do anything, you can attach a serial console and see if it outputs any stacktraces.

  • kern.log.txt

    Kern log file shows that it booted at that time, at least i don't see any errors. (file attached)
    It looks like it was just reset and started booting, but i doubt there was an electricity outage, as my xcp is powered by ippon back basic 1050.

  • XCP-ng Team

    @dave-opc To know more on next incident, you may add noreboot options to multiboot2 /boot/xen.gz in /etc/grub.cfg file against default kernel boot entry.

  • Got another issue with RC1:

    I got 2 xcp ng servers. 1st at home on 8.0rc1 and 2nd remote on 7.6
    When i had at home 7.6 (before upgrade) my continuous replication task in XOA was working fine. Every night copying VM to home server.
    After upgrading to 8.0RC1 XOA starts copying. I can see [importing....] in xcp center, but after transfering the file, xoa ends with error XOA.JPG
    I thought i had a problem with iscsi drive, connected to xcp, but i also tried copying to my main sr (nvme) and got the same error.

  • XCP-ng Team

    You are doing CR from 8.0 to 7.6?

  • @olivierlambert
    from 7.6 to 8
    P.S. just checked. the other way from 8 to 7.6 CR is working fine.
    Also copying VM from 7.6 to 8 is working. - problem with CR 7.6 -> 8

  • XCP-ng Team

    Okay so it's maybe something related to how VDI are handled in the "opposite" way (newer to older).

    I would suggest to get everything at the same level if possible. Ideally, try to test from a 8.0 to a 8.0 to be sure it's a version diff that cause the issue.

  • @olivierlambert
    Of course i will try that, but can't install 8.0 on production pc yet. Will wait for 8.0 release.
    I just posted this issue, so maybe you or someone will try to do CR 7.6 -> 8.0RC1 and see if the issue still exists.

  • XCP-ng Team

    XCP-ng 8.0 will now have the EPEL repositories added - but disabled - by default, in order to avoid users add it and not notice that adding it automatically leaves it enabled.

    I have also written this detailed page that attempts to cover the subjet of installing additional packages to dom0: https://github.com/xcp-ng/xcp/wiki/Additional-packages

    By the way, various new utilities have been added to XCP-ng repositories for 8.0, I won't list them here, but you can find the answer in that page (how to lure people into reading it...)

  • Hello

    now it looks like 8.0 will be ready soon. I like to write a article for a big german IT magazin 😉

  • XCP-ng Team

    We plan to release in the next few day, and there have been important changes that need testing before that:

    • the updater XAPI plugin, that handles patch detection and application (through yum) and is used by Xen Orchestra in the pool and hosts views, has been vastly modified to prevent it from running multiple times concurrently (in extreme cases, this could crash your host due to lack of available RAM)
    • updated kernel for http://xenbits.xen.org/xsa/advisory-300.html
    • EPEL repos added by default, in disabled state http://xenbits.xen.org/xsa/advisory-300.html

    Testers who already run XCP-ng 8.0 beta/RC

    To test this, I suggest to:

    1. Update the XAPI plugins only, so that you can test the updater plugin: yum update xcp-ng-xapi-plugins
    2. Update your hosts with Xen Orchestra (if you don't use Xen Orchestra, then you won't be able to test the updater plugin... then just run yum update on your hosts).
    3. Restart the XAPI toolstack (xe-toolstack restart) on your hosts, starting with the pool master.
    4. Reboot your hosts, starting with the pool master as usual, so that the kernel security fix is applied and you can test that everything works well with the updated kernel.

    Testers who could test the "final" installation ISO

    I'll also make pre-release ISOs available to those who want to test them before the final release (we need as many tests as we can get in this final stage). Unless there's an important bug that is found during the tests, the pre-release ISOs and the final ISOs should be identical.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support