Created cloud config, but can't select it when creating a new VM.

  • @eperez539 this guide wont work, this is what I did, installed XOA, created the VM from HUB, modified it and converted again to the template.

  • @geek-baba Thanks, do you happen to have some steps on the additional changes you made to the VM before converting in to the template?

  • @eperez539 just install anything you want, for example I added docker and kubernetes and converted it to template and now when I create new VM it retains everything.

  • @geek-baba oh ok, so are you bypassing cloud init altogether? How do you handle the network config? I was hoping to at least setup network + ssh key and then I could mange with Ansible after that.

    Initially tried using Terraform with XO, but this cloud init issue may be the problem why I was having an issue getting them to work together.

  • no I am not bypassing the cloudinit, I am using a working template that have local cloud config that I was not able to get it working on my own. if you use the template, you would see 2 drives under disk like below.

    alt text

  • @olivierlambert said in Created cloud config, but can't select it when creating a new VM.:

    your VM to understand why it doesn't fetch your config.

    There was a an update to cloud-init recently and it broke the template I've been using to deploy our VMs. What's i've noticed so far is that it overwrites the network configuration files for centos in /etc/sysconfig/network-scripts/ifcfg-eth0. I got around that issue by adding the network: configuration: ignore to the cloud.cfg file..

    I then figured maybe it's time to update my template, so I went ahead and did just that using the same guide found here.

    Once the VM starts it also fails to load the config drive automatically, so I'm thinking the documentation will need to get some sort of refresh .. Once I figure it out, I can show what worked for me here if no one else figured it out first.

  • XCP-ng Team

    Keep us posted please 🙂

  • @olivierlambert
    I got it working by applying the diff you posted above. I edited the ds-identity file and added the fatboot label. I then added the datasource entries to cloud.cfg.

    I converted to a template and 1st bootup it updated automaticaly and ran everything I had already setup in the cloud.cfg.

    I would say that the blog post from December 2015 or the wiki needs to be updated with that new information. Also worth mentioning is that unless a network configuration is specified in the cloud.cfg file you need to add this snippet at the bottom so that any future customization of the network interfaces doesn't get wiped up by cloud-init:

      config: disabled

  • @MrMike could you please post the changes to ds-identity file? Also, I don't see the /usr/lib/cloud-init/ds-identify.ORIGINAL file. Is this something that gets created after the new VM is created?

  • @eperez539

    You need to add the following 2 lines to /usr/lib/cloud-init/ds-identify at or around line 245 if your file is different than mine.

             LABEL_FATBOOT=*) label="${line#LABEL_FATBOOT=}";

    The file diff /usr/lib/cloud-init/ds-identify.ORIGINAL is just a backup of the original file. You should do the same in case you need to roll back changes one day.

    Here's the end result in my file (see line 245 where I added the above):

        236     for line in "$@"; do
        237         case "${line}" in
        238             DEVNAME=*)
        239                 [ -n "$dev" -a "$ftype" = "iso9660" ] &&
        240                     isodevs="${isodevs},${dev}=$label"
        241                 ftype=""; dev=""; label="";
        242                 dev=${line#DEVNAME=};;
        243             LABEL=*) label="${line#LABEL=}";
        244                      labels="${labels}${line#LABEL=}${delim}";;
        245             LABEL_FATBOOT=*) label="${line#LABEL_FATBOOT=}";
        246                              labels="${labels}${line#LABEL_FATBOOT=}${delim}";;
        247             TYPE=*) ftype=${line#TYPE=};;
        248             UUID=*) uuids="${uuids}${line#UUID=}$delim";;
        249         esac
        250     done

  • @MrMike Great, thanks. I'll try this out.

  • @eperez539 good luck

  • @MrMike nope, not working.

    • Created VM
    • Installed guest-tools
    • Installed cloud init, cloud-initramfs-growroot
    • Updated /etc/cloud/cloud.cfg
    • Updated /usr/lib/cloud-init/ds-identify with lines given above
    • Created template
    • Created new vm from template using cloud init config on XO
    • New VM has nothing from the cloud init config...

    I could see how you could tweak the /etc/cloud/cloud.cfg with the users, etc. But cloud.cfg should have minimal settings on it. All the settings and configuration should come from the cloud init config in XO.

  • XCP-ng Team

    Check if you can read the config file in the extra disk while inside the VM. If yes, it's clearly a cloudinit config issue 🙂

  • @olivierlambert I see the drive attached to the new VM but it is not mounted. After mounting, I can see the contents of cloud-init config and everything looks ok unless I missed something:

    drwxr-xr-x  3 root root 16384 Jan  1  1970 ./
    drwxr-xr-x 24 root root  4096 May 22 18:58 ../
    -rwxr-xr-x  1 root root    50 May 22 18:54 meta-data*
    -rwxr-xr-x  1 root root   104 May 22 18:54 network-config*
    drwxr-xr-x  3 root root  2048 May 22 18:54 openstack/
    -rwxr-xr-x  1 root root   469 May 22 18:54 user-data*
    root@cloudbase:/mnt# cat user-data
    hostname: testingtheothertime0
    timezone: America/New_York
    package_update: true
    package_upgrade: true
      - htop
      - tree
      - vim
      - ffmpeg
      - content: |
        version: 2
        path: /etc/netplan/00-installer-config.yaml
      - [ netplan, apply ]
    root@cloudbase:/mnt# cat network-config
    #  version: 1
    #  config:
    #  - type: physical
    #    name: eth0
    #    subnets:
    #      - type: dhcproot@cloudbase:/mnt#
    root@cloudbase:/mnt# cat meta-data
    instance-id: 3824858a-0679-2863-5416-e03640479e8c

    From the cloud config, the packages were not installed. Also, tried the do the networking in different ways but nothing worked.

  • XCP-ng Team

    So double check cloudinit logs, so you'll know at boot what happened and why it didn't take your configuration into account

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support