Using iGPU in VM(s) -- Possible? How?



  • Re: XCP-ng GPU Passthrough - No GPU found

    Hiall! I've gotten myself into sort of a bind. With help from Dell 🙂 We have PE R7425 and PE R6415 servers with integrated Matrox G200eW. Even though we discussed adding "real" GPUs to these pre-sale, they were configured without the "GPU Chassis Option". Dell says because of that, they can't support adding GPU(s) to these servers. They also said we could try putting a GPU in (which they wouldn't support), but they seem unable to tell me which GPU might even physically fit in the standard chassis. Plus, their prices for GPUs are outrageous anyway (i.e., almost $3800 for an $1800 S7150).

    All we need is better gfx in the VMs, not compute (though that would be nice as well).

    My question: Can I either pass the integrated gfx through to a single VM or slice it to multiple VMs? I told one of the servers not to use the iGPU, but after reboot, the GPU settings for a VM still say "No GPU detected in this pool". ???? TIA

    Edit: And even if I was able to do this, would it really make any difference?

    Edit: Following the instructions here (https://support.citrix.com/article/CTX222537) I created a vgpu for one of my VMs, but when I tried to start the VM, this was the result:

    VGPU type is not one of the PGPU's supported types.
    type: 16b0e2a8-2481-43d8-991c-b18c148e1861
    supported_types: <unknown>

    and, xe vgpu-type-list returns nothing. Either the Matrox G200eW ain't gonna cut it, or I'm missing something.

    Edit: Of course, now that I've posted this, we again tried both the things that "weren't working" before, and now they're working. So maybe we don't even need a GPU at all! 🙂



  • vGPU isn't support on Matrox G200. Only Intel GPU (from some of their CPUs), AMD FirePro and NVidia PRO stuff are supported for vGPU.



  • Thanks for the clarification. So, with a FirePro S7150, I could create vGPUs. Guess I'll have to bite the bullet (if the actual need arises), because I know a non-OEM S7150 would be problematic. Bah.



  • @pwason said in Using iGPU in VM(s) -- Possible? How?:

    FirePro S7150

    Note: I never had the opportunity to work with AMD vGPU compatible stuff, so I have no idea how this could/should work.


Log in to reply