Can't increase RAM on VM through XO (Memory Constraint Violation)



  • I'm getting the following:

    vm.set
    {
      "memory": 3221225472,
      "id": "d63cbf1c-e277-7c02-b48d-53a94264a3f8"
    }
    {
      "code": "MEMORY_CONSTRAINT_VIOLATION",
      "params": [
        "Memory limits must satisfy: static_min ≤ dynamic_min ≤ dynamic_max ≤ static_max"
      ],
      "call": {
        "method": "VM.set_memory_dynamic_range",
        "params": [
          "OpaqueRef:021dd6ea-af1a-4b46-b88d-b661de2ab1d7",
          536870912,
          3221225472
        ]
      },
      "message": "MEMORY_CONSTRAINT_VIOLATION(Memory limits must satisfy: static_min ≤ dynamic_min ≤ dynamic_max ≤ static_max)",
      "name": "XapiError",
      "stack": "XapiError: MEMORY_CONSTRAINT_VIOLATION(Memory limits must satisfy: static_min ≤ dynamic_min ≤ dynamic_max ≤ static_max)
        at Function.wrap (/opt/xen-orchestra/packages/xen-api/src/_XapiError.js:16:11)
        at /opt/xen-orchestra/packages/xen-api/src/index.js:635:55
        at Generator.throw (<anonymous>)
        at asyncGeneratorStep (/opt/xen-orchestra/packages/xen-api/dist/index.js:58:103)
        at _throw (/opt/xen-orchestra/packages/xen-api/dist/index.js:60:291)
        at tryCatcher (/opt/xen-orchestra/node_modules/bluebird/js/release/util.js:16:23)
        at Promise._settlePromiseFromHandler (/opt/xen-orchestra/node_modules/bluebird/js/release/promise.js:512:31)
        at Promise._settlePromise (/opt/xen-orchestra/node_modules/bluebird/js/release/promise.js:569:18)
        at Promise._settlePromise0 (/opt/xen-orchestra/node_modules/bluebird/js/release/promise.js:614:10)
        at Promise._settlePromises (/opt/xen-orchestra/node_modules/bluebird/js/release/promise.js:690:18)
        at _drainQueueStep (/opt/xen-orchestra/node_modules/bluebird/js/release/async.js:138:12)
        at _drainQueue (/opt/xen-orchestra/node_modules/bluebird/js/release/async.js:131:9)
        at Async._drainQueues (/opt/xen-orchestra/node_modules/bluebird/js/release/async.js:147:5)
        at Immediate.Async.drainQueues (/opt/xen-orchestra/node_modules/bluebird/js/release/async.js:17:14)
        at runCallback (timers.js:810:20)
        at tryOnImmediate (timers.js:768:5)
        at processImmediate [as _immediateCallback] (timers.js:745:5)"
    }
    


  • Hmm, I tried in XCP-ng Center and that worked fine (though it did reboot the VM, which is fine). Do I need to shut down the VM IN XO before trying to change the RAM, or do I need to go into the advanced settings and adjust the dynamic etc settings first (didn't realise that was there initially)


  • Admin

    1. No need to reboot if you are changing it in the dynamic range (which wasn't the case when you tried first
    2. Must be done with halted VM if you are changing static range

    So you probably tried to change a value that required to move the static while the VM was running.



  • @olivierlambert Riiight, makes sense. I think part of my problem with XO errors is the cause of the problem isn't immediately apparent, you sort of have to pick through the traceback error messages. I'm sure it's not easy but it'd be great to have some instant feedback error popups for (what I assume is) common errors like this.


  • Admin

    In fact, we have some popups (no for this case because it's not that common, otherwise we would saw that), but then we need to be careful regarding/exposing detailed XCP-ng error message to a web client.



  • @olivierlambert Yep for sure, and your support here is so good it's not a huge problem, but I more feel bad bothering you with stupid questions more than anything haha


Log in to reply