Unable to start VMs

  • Hi,

    some VMs do start but a bulk don't.

    By sampling one of them, in the error logs, I get this message. Would appreciate assistance in what I am supposed to do. Nothing has changed and if someone shares why this happens with some and not with other VMs, I'd be very appreciative.

    VDI_MISSING(OpaqueRef:4b55e85f-8fec-4fd2-ac1a-58952a8b3fd3, OpaqueRef:2806410b-4869-4d70-9432-d4a8c029bc28)

    Why would a VDI go missing to begin?

    Thank you!!

  • More details please...

    • What version of XS / XCP-ng?
    • Was your server recently upgraded?
    • Are you starting the VM from XO or XCP-ng Center?
    • Have you ensured that the issue isn't related to a CD mounted in the VMs that won't start?

    FYI, you can eject all CDs with the following command --
    xe vm-cd-eject --multiple

  • The server was just upgraded to 8.0.0!!
    I tried to start them from xsconsole and XO to no avail.
    The VMs are set to auto-start. This was no problem until now where only 3 VMs start but the remaining 5 do not.

    when I run

    xe vm-cd-eject --multiple

    this is what I get:

    [17:17 xenserver-idpiupet ~]# xe vm-cd-eject --multiple
    operation failed on 7991ecab-0275-8e3c-a044-352c949773e6: Operation could not be performed because the drive is empty
    vbd: e243e381-fe10-8c22-b7c5-27aad7a48f22
    operation failed on 8912fdcb-d756-457d-d45f-27d9a894a1ed: Operation could not be performed because the drive is empty
    vbd: 768b001a-1b47-dd45-2012-e91161d65855

  • @okynnor said in Unable to start VMs:

    The server was just upgraded to 8.0.0!!

    That would have been useful information to include in your initial post. Instead you stated "Nothing has changed". 🙄

    What upgrade method did you use? Has the server been rebooted since the upgrade?

  • XCP-ng Center Team

    @okynnor and after you executed the commandline, do the vm's boot?

  • @borzel Indeed, the command

    "xe vm-cd-eject --multiple" worked! All VMs now correctly auto boot on reboot/startup!

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support