Netdata package is now available in XCP-ng


  • XCP-ng Team

    No, I don't know. The iptables rules are rebuilt each time your host starts, and the additional rules for netdata are added when the netdata service starts.



  • @stormi

    I just realized your icon is from Keen4. I use to play that game when I was much younger.

    Thanks again for all your help!



  • @PC_123
    For anyone who has this issue in the future.

    The command stormi provided did fix the problem on a running machine. Unfortunately it did not persist following a reboot.

    The command: iptables -F

    Seems to be a better long term solution.

    Thanks again to @stormi for isolating the issue.


  • XCP-ng Team

    That command I provided is run each time the netdata service starts. So the proper fix is to find out why it doesn't work. Maybe it runs too soon and a dependency needs to be added to another systemd unit.

    iptables -F is NOT a fix nor a "better long term solution". It simply deletes all the iptables rules, so basically you're disabling the firewall. By the way it does not survive a reboot.



  • @olivierlambert I'm experiencing something similar. I recently installed XCP-ng, and the trial Premium license. But it also gives me the netdata not available error. I also don't think I have a xapi0:

    uuid ( RO)                : 35124aac-2b87-4fff-8bc7-44ac346437fa
              name-label ( RW): Host internal management network
        name-description ( RW): Network on which guests will be assigned a private link-local IP address which can be used to talk XenAPI
                  bridge ( RO): xenapi
    
    
    uuid ( RO)                : e2e0991c-17a1-22ce-1b3c-ba5178105b7a
              name-label ( RW): Pool-wide network associated with eth4
        name-description ( RW):
                  bridge ( RO): xenbr4
    
    
    uuid ( RO)                : 63d1ff98-833c-f39f-cc65-d5843b20b037
              name-label ( RW): Pool-wide network associated with eth3
        name-description ( RW):
                  bridge ( RO): xenbr3
    
    
    uuid ( RO)                : 8b649421-9686-d09c-19f0-8726c04f9134
              name-label ( RW): Pool-wide network associated with eth0
        name-description ( RW):
                  bridge ( RO): xenbr0
    
    
    uuid ( RO)                : 8c47afa9-3bc0-dec0-3c2e-cd304d28b064
              name-label ( RW): Pool-wide network associated with eth2
        name-description ( RW):
                  bridge ( RO): xenbr2
    
    
    uuid ( RO)                : 37e022e3-d5dd-e0ea-0be6-e2f07d6c75fc
              name-label ( RW): Pool-wide network associated with eth1
        name-description ( RW):
                  bridge ( RO): xenbr1
    

    I would prefer to use the integrated installation, so that I can be assured of compatibility, etc. Thanks in advance. The product is awesome!



  • @stormi @olivierlambert

    Trying to install it on my xcp-ng host and it having issue with the mirrors.

    Do we need to do anything else?

    453f1238-ad87-40c8-9607-041011860cae-image.png


  • XCP-ng Team

    You had the same issue with two different mirrors according to the message, so I'd first look at network issues or configuration.



  • @stormi

    Just tired downloading one of the package from my other computer and it worked. issue seem to only be with my xcp-ng host. not sure how to troubleshoot this.


  • XCP-ng Team

    I can't help right now myself but I'm sure other users will have ideas. Can you open a separate thread since it's not directly related to netdata?



  • @stormi

    Edit:
    Thank you! Got it working and looking good.

    Troubleshooting non related to Netdata.
    I remember I change my upstream DNS to Quad 9 recently (1 week ago) and I just change it to Cloudflair (1.1.1.1) and it was the problem.

    Look like Quad 9 (9.9.9.9) does not like the Mirrors for some reason.



  • @olivierlambert Just installed netdata package on our xcp-ng cluster. Its running like expected but i can only get ram / memory metrics from the dom0. Is there any way to get the full ram metrics from all VMs / host?

    Thanks


  • XCP-ng Team

    As far as I know, they should be available. I/O metrics aren't at the moment, but RAM should be.



  • @stormi Could it be that there is any difference between the "netdata-ui" rpm package you provide and the official netdata rpm packages?

    netdata-conf-1.23.2-1.el7.noarch
    netdata-data-1.23.2-1.el7.noarch
    netdata-1.23.2-1.el7.x86_64
    

    Or could it be that it's related to XCP-NG 7.x? Because our cluster is still running 7.x ...


  • XCP-ng Team

    There definitly is. Ours is built with xen support. You seem to have enabled CentOS and/or EPEL repositories on your host, which is not recommended.

    See https://xcp-ng.org/docs/additionalpackages.html



  • Still getting this pesky "Netdata is not available on this appliance, please deploy a new one" after updating from the 'latest' channel.
    Config is: XOA Premium Trial
    --- XCP-ng 8.1.0-2
    --- XOA Current version: 5.51.1 - XOA build: 20200627

    • node: 12.18.2
    • npm: 4.6.1
    • xen-orchestra-upload-ova: 0.1.3
    • xo-cli-premium: 0.11.0
    • xo-server: 5.68.0
    • xo-server-audit-premium: 0.8.0
    • xo-server-auth-github-premium: 0.2.2
    • xo-server-auth-google-premium: 0.2.2
    • xo-server-auth-ldap-premium: 0.9.0
    • xo-server-auth-saml-premium: 0.8.0
    • xo-server-backup-reports-premium: 0.16.7
    • xo-server-load-balancer-premium: 0.3.3
    • xo-server-netdata-premium: 0.1.1
    • xo-server-perf-alert-premium: 0.2.3
    • xo-server-sdn-controller-premium: 1.0.4
    • xo-server-telemetry: 0.3.0
    • xo-server-transport-email-premium: 0.5.0
    • xo-server-transport-icinga2-premium: 0.1.1
    • xo-server-transport-nagios-premium: 0.1.1
    • xo-server-transport-slack-premium: 0.0.0
    • xo-server-transport-xmpp-premium: 0.1.1
    • xo-server-usage-report-premium: 0.9.0
    • xo-server-web-hooks-premium: 0.1.1
    • xo-server-xoa: 0.10.0
    • xo-web-premium: 5.72.0
    • xoa-cli: 0.21.1
    • xoa-updater: 0.31.0

    When I try to activate the Netdata plugin I get the error "Netdata is not available on this appliance, please deploy a new one". This is a fresh installation, but I did go to the web site and repeated the XOA deployment... and upgrade, reregister, etc., even though it made no sense to me. The result was the same error.

    What am I missing? 🙂
    Best,
    Razvan


Log in to reply
 

XCP-ng Pro Support

XCP-ng Pro Support