XCP-ng 7.5.0 Release Candidate

  • XCP-ng Team

    @olivierlambert No issue to do it.

  • XCP-ng Team

    👍 Great!

  • @christianuhlmann said in XCP-ng 7.5.0 Release Candidate:

    my first host with xcp-ng upgraded successful to 7.5 (Intel NUC) without an error.
    thanks for the great job !

    second server has also been updated successfully.

    the third server I use pci passthroug for 2 DVB cards.
    So far that was excellent under 7.4.1.

    Since upgrading to 7.5 I get the following error if i want to start the vm with the passthroug pci devices:

      "id": "40bcca30-d07a-db7c-5744-c134a30af5d1"
      "message": "INTERNAL_ERROR(xenopsd internal error: (Failure
      \"Error from xenguesthelper: Populate on Demand and PCI Passthrough are mutually exclusive\"))",
      "stack": "XapiError: INTERNAL_ERROR(xenopsd internal error: (Failure
      \"Error from xenguesthelper: Populate on Demand and PCI Passthrough are mutually exclusive\"))
        at wrapError (/home/node/xen-orchestra/packages/xen-api/src/index.js:197:9)
        at /home/node/xen-orchestra/packages/xen-api/src/index.js:1064:18
        at run (/home/node/xen-orchestra/node_modules/core-js/modules/es6.promise.js:75:22)
        at /home/node/xen-orchestra/node_modules/core-js/modules/es6.promise.js:92:30
        at flush (/home/node/xen-orchestra/node_modules/core-js/modules/_microtask.js:18:9)
        at _combinedTickCallback (internal/process/next_tick.js:131:7)
        at process._tickCallback (internal/process/next_tick.js:180:9)",
      "code": "INTERNAL_ERROR",
      "params": [
        "xenopsd internal error: (Failure
      \"Error from xenguesthelper: Populate on Demand and PCI Passthrough are mutually exclusive\")"
      "method": "VM.start"

    all seem ok

    # lspci
    02:00.0 Multimedia controller: Digital Devices GmbH Octopus DVB Adapter
    08:00.0 Multimedia controller: Digital Devices GmbH Cine V7
    # xl pci-assignable-list
    # xe vm-param-get uuid=40bcca30-d07a-db7c-5744-c134a30af5d1 param-name=other-config
    pci: 0/0000:02:00.0,0/0000:08:00.0; base_template_name: Debian Stretch 9.0; import_task: OpaqueRef:83a9253c-f3c0-448f-aba6-df5efa2c1c4a; mac_seed: 1113ba83-5709-4ca5-a292-f8b81a047db4; install-methods: cdrom,nfs,http,ftp; linux_template: true

    Does anyone have any idea what that might be?
    does anyone have an upgrade to 7.5 with pci passthroug on the run?

    Thanks and Greetings


  • XCP-ng Team

    @christianuhlmann said in XCP-ng 7.5.0 Release Candidate:

    Populate on Demand

    Do you know what's this? It seems incompatible to have it enable in parallel with PCI Passthrought.

    edit: it seems your dynamix min/max and static max aren't set at the same value.

  • @olivierlambert

    After a bit of googling on populate on demand I realized.
    strange that it worked under 7.4.1.

    if I understood correctly, it is the dynamic ram assign with min / max.

    after I entered a fixed size for ram, the start worked fine.

    thank you for the great work 🙂


  • XCP-ng Team

    I think ballooning + PCI passthrough can cause some crashes, so that's why there is a check to avoid using both at the same time.

  • Updated via YUM, all seemed to go well, except the xcp-ng tools ISO only seems to have the Linux directory and the readme.txt file on it, no windows tools.

    Guests on 3 hosts same.

    file appears to be "guest-tools-7.29.0-2.iso" in /opt/xensource/packages/iso


  • XCP-ng Team

    The windows tools are not free software, we can't distribute them. There's a way to install them though: https://xcp-ng.org/2018/04/23/the-future-of-vm-tools/ (see "a better model")

  • The readme doesn't say that. Might need to adjust it.

  • XCP-ng Team

    Indeed. I'll fix it.

  • XCP-ng Team

    @bungo I uploaded a fixed package, can you test it?

    # only needed if you test so quickly that yum's cache couldn't expire
    yum clean metadata --enablerepo='*'
    # install the update candidate
    yum install xcp-ng-pv-tools --enablerepo='xcp-ng-updates_testing*'

    Here's what you should see in the Windows section of README.txt

    We are not allowed to redistribute the windows tools built and signed by
    Citrix, so they are not included here.
    If you are using Xen Orchestra, you can switch the "Windows Update tools"
    advanced parameter on from the "Advanced" tab of the VM view. This will
    allow you to install the tools directly from Windows Updates.
    Any help in building the tools from the sources to add them back in this
    ISO image is welcome. See https://github.com/xcp-ng/xcp/issues/23
    olivierlambert created this issue in xcp-ng/xcp

    closed Windows PV tools #23

  • Ran, tested, all as expected. Thanks.

  • I installed this RC1 version via a fresh install using the ISO image (from Proxmox). I used EXT3 thin provisioning as usual (one day Citrix will give us the opportunity to use LVM Thin 😔).

    No problem at all ! Great ! XenOrchestra 5.22 works great, same for XCP.

    However, I have not yet had the opportunity to test the USB Passthrough. And finally, my network card does not support SR-IOV, so no opinion on it.

  • XCP-ng Team

    @Ruskofff LVM thin won't happen I'm afraid. They had to many issues doing it when they tried (data corruption). The path they are using not for thin pro on block based (eg iSCSI) is GFS2. But this require a cluster working, and this part isn't Open Source…

  • @olivierlambert the fact they didn't succeded doesn't means necessary it does not work.
    I'm still surprise they didn't add for ages what you add in few months (ceph, gluster, zfs)

  • XCP-ng Team

    It's maybe not impossible, but you can't count on Citrix to achieve it, at least with their current priorities.

    One of our objective is to master smapiv3 (which is the new storage stack of XS) to be able to build something thin on LVM (amongst other things), but this will require to hire people with advanced knowledge in both XAPI and SR. As you can imagine, there isn't a lot of places where you can find those.

  • Whenever I use bootable USB , it is booting properly and going to the part of actual installation where it asking for the media (Local,HTTP,NFS) and choose local media it says that media was not found.

    Once I use burned CD all it's OK.

    IN 7.4 release I haven't such kind of problem at all. Installation form USB going smoothly.Suppose this is a problem in this release. Just to clarify that in some very old versions of Xen server the same problem has been found but there it was related with USB 3.0 and USB 2.0.

    Anyone met this issue ?

  • XCP-ng Center Team

    @asus said in XCP-ng 7.5.0 Release Candidate:

    Whenever I use bootable USB

    Did you create your USB bootmedia using dd on commandline?

  • Nope I'm using Lili USB creator and so far it was working fine as I mentioned even if I use Citrix Xen server or XCP-NG.
    But sorry I just realize something and want to make a remark . This software has an option to hide some files . And because I was in a hurry yesterday and forgot to remove the option. I have a backup of my VM's , that is why will test it again today without this option.
    If it is working will update you , as well for those which are not comfortable to use command line 🙂

    Thanks Borzel

  • XCP-ng Team

    Hello dear RC testers!

    We are releasing 7.5.0 final today, so here's how to go from 7.5.0RC to 7.5.0.

    Warning: this is only for people who installed the RC. Detailed procedure will be given in the release announcement for upgrading an XCP-ng 7.4 server

    Option 1, upgrade using the installation ISO

    Will work, although may be a little overkill since you already have a nearly-final 7.5.0.

    Option 2, update yum repository files and update the system

    # remove the RC-specific repository file if present
    rm /etc/yum.repos.d/xcp-ng-7.5.repo -f
    # install the 7.5 official repository file
    wget https://updates.xcp-ng.org/7/xcp-ng-7.5.repo -O /etc/yum.repos.d/xcp-ng.repo
    # update. If you had updated your RC regularly, this will install nothing, else you'll get a few packages
    yum update
    # if the kernel or xen-* packages got updated, reboot your server
    # that's it, you've got 7.5.0 final!
XCP-ng Pro Support

XCP-ng Pro Support