XCP-ng 8.1 PCIe onboard usb controller passthrough does not work

  • Hi

    Sorry for starting a new thread but i dont know if the old one was in the correct area for people to see.

    I have XCP-ng 8.1 beta installed and im trying to passthrough my onboard usb controller on my gigabyte X79-UD5 and vm cannot be started.

    This is the error message i receive: "Failed","Starting VM 'test'
    Internal error: xenopsd internal error: Cannot_add(0000:00:1d.0, Xenctrlext.Unix_error(30, "1: Operation not permitted"))
    Time: 00:00:08","xcp-ng-vkdehkmr","Feb 3, 2020 1:09 PM"

    I know this worked fine in Xenserver 6.5 SP1. i have tested 8.0 but have problems even running default VMs on it and i believe this passthrough blocking issue is a thing that came in Xenserver 7 or something has i temporarily switched to proxmox around that time for this reason IIRC.

    I believe there is some rule blocking this since it is usually not stable? maybe like USB passthrough usb-policy blocking some usb class devices.

    Thanks in advance

  • XCP-ng Team

    Do you have all hardware virt options enabled?

  • All that exist in my UEFI/BIOS yes ofc. VT-d and so on. im running an xeon E5-1660v1 btw

  • XCP-ng Team

    Does this page help in any way? https://github.com/xcp-ng/xcp/wiki/USB-Pass-Through

  • No, i tried that and its doesnt work for keyboard and mouse even with the usb policy change, my keyboard and mouse shows up in the gui and VMs start fine with no errors but they still control dom0 and not the guests.

    it does not matter because the topic is actually about pcie passthrough that refuse to passthrough my onboard moterboard usb. i think there is some configuration that citrix has implemented.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support