Can't deploy XOA

  • The first time I tried this it worked (once I'd worked around certificate problems). Now I've tried it again yesterday on a completely different setup, with latest XCP-ng running under VirtualBox instead of VMWare but I just get the spinner forever. When I checked the XCP-ng console with xe vm-list it shows that the VM has been created. What are the steps to trouble-shoot this process please?


  • XCP-ng Team

    If your VBox can't have a working nested virtualization, it won't work.

    XOA is a HVM guest, so you need HVM support in your XCP-ng.

    Nested virt is complex, and there's not a lot of systems able to make it work.

  • @olivierlambert Good point. I definitely did check the box for nested virt. I will try again from scratch with VMWare Fusion where it worked before.

  • I tried on VMWare Fusion, which worked before. It doesn't work there either. I used the same Fusion settings, the same XCP-ng ISO xcp-ng-8.1.0-2.iso.

    I connected to the http web interface on port 80 to deploy XO this time.

    BTW I would post a screenshot of what I'm seeing, however for the last few days this forum has given an error when I try to do so:

    Something went wrong installing the "sharp" module /lib64/ version ZLIB_1.2.9' not found (required by /usr/share/nginx/html/forum/node_modules/sharp
    - Remove the "node_modules/sharp" directory then run npm install --ignore-scripts=false --verbose" and look for errors - Consult the installation documentation at https://sharp.pixelplumbing/com/install - Search for this error at

    The above error appears in red in the bottom right corner of the screen in a toaster message, it fades after a few seconds.
    (I may have made a mistake with the above because I'm typing it from a screenshot).

    As I said, this only happened since last week.

  • It completed with VMWare Fusion now, just took way longer than it did before for some reason. I need to be more patient.

  • XCP-ng Team

    I know for the picture upload on the forum, but there's no trivial fix for now. I'll spend more time later.

    Good to know about your XOA deploy thing solved 🙂

  • I tested my VBox setup with Proxmox and it worked fine. So it should be capable of running nested hypervisors. I wonder what Xen does that's different.

    Unfortunately this means there is no free way for me to run XCP-ng except bare metal 😞

  • XCP-ng Team


    If XCP-ng doesn't work on top of some KVM installs, it doesn't mean Xen can't run in nested. In fact, it works: you can run XCP-ng on top of XCP-ng.

    Xen is a bit different than KVM, so I'm not surprised there's bug when you have Xen on top of it. I don't know for the other way, it might be interesting to test.

    And to fix your last statement: untrue too. XCP-ng on top of XCP-ng.

  • You start your post with the word 'untrue' Although I'm not sure what that's in response to. You then go on to state that my last statement is untrue. I presume there you are talking about the line:

    "Unfortunately this means there is no free way for me to run XCP-ng except bare metal"

    I stand by that statement. If you're telling me I can, in fact run XCP-ng (to experiment with it) if only I'll just install XCP-ng first then I don't actually need to run anything nested in the first place, I just wipe my desktop OS and put XCP-ng on. That is simply not an option (for me). Note that I said 'for me' in the above line. I'm surprised you'd say that's untrue.

  • XCP-ng Team

    I said that for both statements:

    1. It's not Xen fault if it doesn't work on top of KVM, but Xen accessing some virt features that aren't correctly exposed by KVM. I'm not blaming them, nested virt is a mess to properly code and test. Consider this as experimental everywhere.
    2. I missed the "for me". But it's also vague, I don't know your constraints/what do you want. Also, I think I heard that some users made it work with Virtualbox, but it might also depends on your hardware. As I said, nested virt is a mess, and sometimes, some hardware works better than others (or even some VBox versions).

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support