XCP-ng 7.6 RC1 available



  • A new pre-release is ready for XCP-ng 7.6🚀.

    This announcement is basically a copy-and-paste from the announcement of the beta, except the first section and the upgrade instructions.

    What changed since the beta

    Signed files on our mirror

    Until now, our packages and ISO images were not signed. This meant that if someone would have managed to hack our servers, they would have been able to modify the ISO images or packages installed through further updates. This also prevented us from spreading XCP-ng to mirrors outside our own servers, since we had no way of ensuring that the files were not altered by a third party.

    We have worked on this, so starting with this RC:

    • every RPM package is signed and the signature is checked when you install or update a package from the repositories;
    • repository metadata are signed and checked by yum
    • for each ISO image, we provide a checksum file called SHA256SUMS and a signature in SHA256SUMS.asc for you to verify the authenticity and integrity of the downloaded file
    • for each .repo file that we make you download for yum update-style upgrades, we also provide SHA256SUMS and SHA256SUMS.asc for you to verify the authenticity and integrity of the downloaded file

    Details at https://github.com/xcp-ng/xcp/wiki/How-to-check-the-authenticity-of-files-downloaded-from-XCP-mirrors

    Other notable changes

    • Updated XCP-ng Center
    • As you already know, support for GFS2 is not available because it depends on proprietary software from Citrix. However our license daemon would report the feature as being available, which caused XCP-ng Center to offer the option to users (then failed to make it work). The license daemon now correctly reports the feature as not available.

    What changed since XCP-ng 7.5

    • Based on XenServer 7.6 (see https://xen-orchestra.com/blog/xenserver-7-6/). It's mostly a maintenance update.
    • New welcome HTML page when you enter the IP address of your server in a web browser. See screenshots in my next comment to this thread.
    • Experimental packages:
    • Fixed some upgrade bugs in our packages.
    • In case you missed it: the installer now has support for software RAID 1.
    • In case you also missed it, there's a network installer ISO available too.
    • Some proprietary packages have been removed because we can't distribute them:
      • Citrix packages, most of them related to their work on improving the storage layer (smapiv3, GFS2...)
        • xapi-clusterd
        • sm-transport-lib: was LGPL in 7.5, became proprietary in 7.6
        • xapi-storage-plugins: was LGPL in 7.5, became proprietary in 7.6
        • livepatch-utils
      • Emulex management tools. "elxocm" stands for "Emulex One Command Manager". Can probably be downloaded from their site.
        • elxocmcore
        • elxocmcorelibs
        • elxocmlibhbaapi
      • QLogic tools. Available on their website.
        • QConvergeConsoleCLI-Citrix
        • QCS-CLI

    Documentation :

    I structured the home page of our wiki and started a thread for what I called the "let's improve the documentation together" campaign.

    • Glass half full: everybody likes the idea and agrees that we need a great documentation, and some have contributed.
    • Glass half empty: most pages remain empty at the moment.

    We, as a community, really need your help. Can we manage to fill, say, half the empty pages before we release XCP-ng 7.6?

    How to upgrade

    There are two different upgrade methods: classical upgrade via installation ISO or upgrade using yum.

    Before upgrading, remember that it is a pre-release, so the risks are higher than with a final release. But if you can take the risk, please do and tell us how it went and what method you used!

    Reminder: always upgrade the master first (reboot it first, THEN the slaves).
    Also disable HA before upgrading.

    Now to the upgrade methods:

    Upgrade via the installation ISO image

    Upgrade via the network installation ISO image

    Warning: this method does not verify the authenticity of the files downloaded accross the network yet.

    • Download xcp-ng-7.6.0-RC1-netinstall.iso
    • Check the authenticity and the integrity of the downloaded ISO
    • Make sure the server has access either to *.xcp-ng.org or to a local mirror
    • Copy the ISO (byte to byte copy, such as using dd) to an usb stick and boot it. Or find another way to boot the ISO.
    • Do not use the default repository URL: it would install the latest stable version instead of the development version.
    • Use this URL instead: https://updates.xcp-ng.org/netinstall/7.6/

    Upgrade from 7.5 with yum

    Follow the Upgrade Howto

    Upgrade from 7.6 beta with yum

    Usually yum update would be enough to go from beta to RC1, but in this specific case, do as if you were upgrading from 7.5 else you will still be using a configuration of yum that does not check the signatures.

    What to test

    Mostly that what used to work still works! Report or ask anything as replies to this thread.

    If you have QLogic or Emulex hardware, please test that they still work properly without the proprietary packages that we removed. From what I know they are only management tools. If you need those tools, then please download and install them from the vendor and write down your steps in the wiki for the other users.



  • Yay, signed repo, ISO and packages \o/ Mirrors for everyone 😄



  • Yum update is a big help! No need to re-install whole OS 🙂



  • Yup, tested that and I only spent 1 minute to do the upgrade from 7.5. I had longer reboot time 😅





  • Yay, looking forward to setting up a mirror.

    There seems to be a live migration bug. It happens both with storage migration and between hosts. The VMs migrate to 95% and then it just sits there with network traffic but nothing happening. I also saw this on 7.5 and was hoping 7.6 fixed it.
    Does it have to do with the work around for the now closed source citrix packages?



  • I also experience this issue randomly 🙂



  • This is migrating from local SR to shared SR(Storagemotion)...
    The VMs CPUs max out/hang when this happens.
    xensource.log while it is hanging constantly repeats the following lines

    Oct 12 15:12:26 xcp-ng-tnogfalp xenopsd-xc: [debug|xcp-ng-tnogfalp|16 |Async.VDI.pool_migrate R:9429eefc8295|xenops] VM = cf2e6622-67c6-682a-4a42-0c1c41c8cb7b; domid = 11; progress = 99 / 100
    Oct 12 15:12:26 xcp-ng-tnogfalp xenopsd-xc: [debug|xcp-ng-tnogfalp|16 |Async.VDI.pool_migrate R:9429eefc8295|xenops_server] TASK.signal 193 = ["Pending",0.8999999999999999]
    Oct 12 15:12:26 xcp-ng-tnogfalp xapi: [debug|xcp-ng-tnogfalp|141 |org.xen.xapi.xenops.classic events D:78feb0765d3f|xenops] Processing event: ["Task","193"]
    Oct 12 15:12:26 xcp-ng-tnogfalp xapi: [debug|xcp-ng-tnogfalp|141 |org.xen.xapi.xenops.classic events D:78feb0765d3f|xenops] xenops event on Task 193
    


  • Just found this,

    Oct 12 15:23:53 xcp-ng-tnogfalp xenopsd-xc: [debug|xcp-ng-tnogfalp|39 |Async.VM.pool_migrate R:963d85595a12|xenops] looking for emu-manager in 
    

    Should it be calling for the new xcp-emu-manager?



  • @johnelse will take a look when he can 🙂



  • I also experienced this a few times with XCP-ng 7.5.

    In one case (Windows VM) a process in Windows was on 100%, after I killed that process, the VM spontaniously migrated... till the process killing the VM was very slow, was a pain to get pass the login screen and start the taskmanager.

    So I expected old PV drivers to be the reason. After upgrading the PV Driver (with latest package from Citrix) the issue went away for that VM ... but I did not test this further because it was on a productive pool.



  • I've had this happen migrating the XOA VM.
    I also have it happening on some linux VMs that don't have any tools installed.



  • I also experience this migrate issue with Linux or Windows, PV driver installed or not, vm or storage live migrate. Ramdomly as @olivierlambert said. Not always.



  • I just updated the first message to add a note for those who want to update their 7.6 beta to 7.6 RC1.



  • @rizaemet-0 said in XCP-ng 7.6 RC1 available:

    migrate issue with Linux or Windows, PV driver installed or not, vm or storage

    I can reproduce on my end almost every time. the migration hangs more often than not.



  • Anything in logs that could help us to track down the issue?



  • I haven't seen much, but I am curious about my post earlier about xcp-emu-manager, I see emu-manager referenced in the logs and was curious if xcp-emu-manager should be referenced.



  • I did a test. Tried a storage live migrate on a vm which have one sanpshot. And cause this migrate problem. stack in 99%.
    Then I delete snapshot of this vm and wait coalesce process. then tried again storage live migrate. Successfull.
    I did this test on same vm. so, for now I think problem source is look like snapshot. I will do more test.



  • On 7.6, right?



  • @olivierlambert Sorry, maybe not right topic for this issue but my xcp-ng is 7.5