Xen Tools support for RancherOS in XCP-ng



  • Hello !

    I don't know if there some of you know RancherOS from RancherLabs ? Basically, this is a very stripped OS to run Docker containers. This something I tried to setup a Kubernetes cluster and I liked it a lot, so I want it in my XCP-ng lab 😋

    It has the same purpose as CoreOS. It can be used to container host but also it can be extended with their orchestration system (Cattle with the Rancher Server) and now it can deploy Kubernetes cluster "finger in the nose" through his Rancher Kubernetes Engine (with Rancher 2.0).

    Rancher 2.0 : https://rancher.com/docs/rancher/v2.x/en/

    And you probably know that CoreOS is going to evolve since it has been buyed by Red Hat (moving to a Fedora project ?!)

    So it use a Linux kernel but the whole system is completly different as a standard Linux distribution such as Debian or CentOS. Everything except the kernel is container !

    Rancher Arch

    You have details here : https://github.com/rancher/os

    So this thing is interesting but this doesn't provide any possibility to use Xen Tools. The console is a busybox (but they provide a way to use Fedora, Debian or Ubuntu console), there is no package manger so you can't install any additionnal package... For the Xen drivers, that seems good because it's use a modern Linux kernel according to the following topic, but concerning the tools by themselves...no ☹

    https://github.com/rancher/os/issues/813

    I found something that seems to use the RancherOS design to provide a way to install tools by using a dedicated container.

    https://github.com/ShibaOnTheMoon/rancher-xe-guest

    But this thing seems completly outdated (and not working on modern XS version), that why I will try to find a way to adapt it to make it works on XCP-ng. And I wonder if there is a way to use xs-container to simply manage the container inside the VM, let's experiment 😀

    I will let you know if I find a way, a solution or nothing 😉

    ExecDevOps created this issue in rancher/os

    open Include XenServer guest utilities #813



  • I will wait to have real hardware, nested virtualization is a bit problematic to test these things...

    I have a question concerning the tools, I read the script of installation, but I need to be sure about one thing. All the RPM present in the tools ISO should be installed ? Or only the "xe-guest-utilities-7.10.0-1.x86_64.rpm" is enough ?



  • I continue to work on it but the results are not that good. The main problem is one of the main feature, "everything is container".

    I managed to start the xe-daemon in a privileged CentOS container by installing the xe-guest RPMs, but only the show of virtualization mode worked, nothing for the network or soft shutdown. RancherOS should work in PVHVM mode by default for sure due to it's recent 4.14 kernel btw.

    I hate give up on things, but I start to think more and more to use CoreOS instead of RancherOS, and use Rancher Server or RKE on top, it will be the same and much more hassle-free. Moreover, the XenServer tools supports CoreOS, it's clearly a better way to proceed.


  • Admin



  • Yes I gave a look but Rancher is so much more different than a regular distribution, even CoreOS. The problem is everything on system is container, I can't install something by default even manually (using the tar.gz) because when you are login, you are in a BusyBox container in some way...

    IMHO, I don't think the Citrix tools has been design to run in a container (even privileged) and to retrieve information for the entire system that is also in a container... What a mess right ? 😂

    But in the end, these kind of Docker-ready OSes start giving me headache, even CoreOS now is not working like it was in the past, the fault of a very fast-paced developement from the CoreOS devs, the outdated documentation since they has been buyed by Red Hat (they move to Fedora CoreOS with lot of changes), and Citrix who seems to not giving much interest in CoreOS support.


Log in to reply