XO new boot delay feature not working



  • Hi all,

    there is a new feature available in XO to set a defined time in seconds to delay the autostart of a VM.

    For details about the new feature can be found here: implementation of start delay for VM - issue #3909

    It seems the parameter is also set in the VM correctly. Here is a shortened part of result of xe vm-param-list uuid=...:

                         live ( RO): true
                guest-metrics-last-updated ( RO): 20190313T06:38:53Z
                       can-use-hotplug-vbd ( RO): unspecified
                       can-use-hotplug-vif ( RO): unspecified
                  cooperative ( RO) [DEPRECATED]: true
                                      tags (SRW): 
                                 appliance ( RW): <not in database>
                         snapshot-schedule ( RW): <not in database>
                          is-vmss-snapshot ( RO): false
                               start-delay ( RW): 240
                            shutdown-delay ( RW): 0
                                     order ( RW): 0
                                   version ( RO): 0
                             generation-id ( RO): 6481430157605823834:6102110844557853395
                 hardware-platform-version ( RO): 0
                         has-vendor-device ( RW): false
                           requires-reboot ( RO): false
                           reference-label ( RO): 
    
    

    I tested with 2 VMs:
    VM1: auto-start enabled with 0 seconds boot-delay
    VM2: auto-start enabled with 240 seconds boot-delay (see above)

    What is happening:
    Instead of starting VM1 on boot and start VM2 240s later, it happens that VM2 is starting immediately and VM1 is started an undefined time later. For my point of view, XO implementation is working but there is something not working in my XCP-ng installation.

    Can anybody help?





  • The topic you mention is using vApps or high availability.

    I mean this quite new feature "Start delay (seconds), programmed the last days in XO:

    Bildschirmfoto 2019-03-13 um 19.41.53.png

    Do I need to define a HA mode?



  • I understand. However, @olivierlambert stated that the start-delay feature would only be useful on a HA / vApps environment.

    They implemented the feature, but I suspect that this "limitation" still applies.



  • Is it possible to turn on HA mode on a single machine Setup?



  • my solution for now:

    • implement new vApp
    • writing start script to start vApp-uuid after boot

    By the way, the start delay feature edits the time delay between two start up groups of the vApp feature.


  • XCP-ng Center Team

    Is it possible to turn on HA mode on a single machine Setup?

    @payback007 No. "XenServer"-style HA needs at least 3 hosts.



  • Any ideas for a more elegant way than to write a script? For my point of view vApps should work without HA mode but unfortunately it doesn't work on my XCP-ng server. Only console/script start of the vApp using

    xe appliance-start uuid= "set here the uuid of the vAppp"
    

    is working. But it is again rework for the next XCP-ng version, I think manually set vices in systemd are not persistent through an update. Will vApp supported also in future? there are some discussions about it, if really needed.


Log in to reply
 

XCP-ng Pro Support

XCP-ng Pro Support