SOLVED: xen orchestra running as guest in parallels cannot connect to freenas nfs share



  • Goal is running xen orchestra from my macbook.

    Macbook yosemite (network connected by utp cable)
    Parallels Desktop 12
    Guest: Ubuntu 18.04 LTS sever (Shared network) with a installation Xen Orchestra latest (it runs and can connect to xcp-ng server)
    NFS share on a freenas for remote backup Xen Orchestra

    In the guest terminal session i can mount the freenas nfs share with cli command:
    mount ipnumber:/mnt/raid/nfs/backup /mnt/tmp

    But when i try to make a nfs connection in xen orchestra i get a error:

    Connection failed
    Command failed: mount -t nfs ipnumber:/mnt/raid/nfs/backup /run/xo-server/mounts/d092edc4-4aba-42a3-8a26-c1873603f97e -o vers=3 mount.nfs: access denied by server while mounting ipnumner:/mnt/raid/nfs/backup

    Access denied by server?
    Running xen orchestra in a vm on xcp-ng i don’t have freenas nfs share mounting problems.
    Where is the difference?


  • Admin

    Depends on how you are using your network settings in Parallels. What's the IP address of your Ubuntu VM?



  • lan range 192.168.10.0/24
    parallels guest ip 10.211.55.19/24 so its behind NAT
    But mounting with cli command mounts well. Same ip ...


  • Admin

    So in your Ubuntu VM in parallels, you can mount the NFS share with the same arguments?



  • Yes,
    Cli mount goes well but xen orcestra mount give a error. Same guest vm.


  • Admin

    XO is basically calling mount from the system so it might be something you don't use manually (a mount option?)



  • After:
    mount 192.168.10.6:/mnt/raid/nfs /mnt/jan

    and i look with mount i get this:
    192.168.10.6:/mnt/raid/nfs on /mnt/jan type nfs4 (rw,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=10.211.55.19,local_lock=none,addr=192.168.10.6)
    So its working.

    After manual typing what XO tried:
    mount -t nfs 192.168.10.6:/mnt/raid/nfs/backup /mnt/jan -o vers=3

    I get the same error:
    mount.nfs: access denied by server while mounting 192.168.10.6:/mnt/raid/nfs/backup

    So the β€œ-o vers=3" option is the problem.
    Can i edit a file in XO to get rid of the β€œ-o vers=3” option?

    SOLVED πŸ™‚
    In XO i used the option -o vers=4 and this works.


Log in to reply