Delta backup first full backup failed after 24h



  • Hello xoa-ng community,

    I have the problem that I want to backup a 1.5 TB vhd over a vpn connection to a cloud server(delta backup). This takes only about 36 hours due to a very good Internet connection. But if the job last longer than 24 hours the task in xen orchestra disappears, but the upload is still working (networktraffic indicates it is still running, the filesize also rises to 1.5 TB).

    But after finnishing the backup job says failled and at the next sceduled job it starts a completly new fullbackup.

    I have updatetd xen orchestra (from source) to newest version.

    Is there any restriction, like a max time for a backup which i can increase?
    Does somebody has the same problem?

    Thank you for yor advice.

    dmartini1337

    Edit: The files are deleted after the failure message from xen orchestra.

    Edit: Backup Log
    alt text


  • Admin

    Ping @julien-f



  • Hello @olivierlambert,

    in this Post (from citrix) is a 24 hours export time limit mentioned. Is this limit also part of xcp-ng? Could this time limit be increased to some higher values in any config file? I think this limitation is the problem with my delta backup.

    Edit:
    Same here (from xen-orchestra.com)

    Edit:
    It also has found a way to xcp-ng's github

    If the time limit couldn't be increased is there any other way to get the initial full backup up in the cloud. Like uploading from the local NAS via rsync and then afterwards add the remote cloudbackup to the backup job, don't causing a new full backup due to the change of the backup job?

    Or changing the systemtime to expand the 24 hours limit by turning back the clock, or a manipulated "slower" ntp server or something like that...

    To make smaller vhds which aren't uploaded simultaneously would also do the trick, but this was already asked in the github post. Is something from the asked already implemented?

    Thank you for your response,
    dmartini1337





  • Thank you @Danp this is something that I could try.

    But I see there one issue... I want to use two remotes (one local NAS and one in the Cloud over a vpn connection). I'll try to continue with the same files on both remotes, hopefully this will work. I'll start a new delta chain now to local NAS.

    Edit:
    I also make a copy of the metafiles to see what is changed by editing the backupjob, maybe I will get something working for two remotes...



  • I have tried the to seed the files like described in your link with a small vm. This worked, also with two remote targets with the same files. I will try it now with the big vm. I'll inform you If this is working.

    Thank you for your advice!
    dmartini1337


  • Admin

    Keep us posted!


Log in to reply
 

XCP-ng Pro Support