Netdata package is now available in XCP-ng



  • FYI, after upgrading my XOA VM to the latest version, I was unable to turn on the new NetData plugin. Instead, I received the message --

    Netdata is not available on this appliance, please deploy a new one
    

    Subsequently had issues attempting to install a new XOA VM. Tried both the known methods --

    The first just sat at a spinning graphic but never deployed. The second just stopped without any warning after the import attempt.

    Further investigation shows that both methods were yielding the following error during VM.import --

    The value given is invalid
    field: bridge
    value: xapi0
    

    I ended up downloading the file from http://xoa.io:8888, renaming to an XVA file and then importing with my other XO VM.

    Don't know if these issues will affect others, but hopefully these details will prevent someone else from tearing out their hair. ๐Ÿ˜ฎ


  • XCP-ng Team

    • what was the XCP-ng version where you tried to deploy it?
    • do you have a xapi0 on it?

    I did tests on XS 6.5 and XCP-ng 8.0, and deploy worked on my side.



  • @olivierlambert v8 fully patched. Here's the output from xe network-list --

    uuid ( RO)                : a379a6e7-f099-f838-6514-486de4d56e80
              name-label ( RW): Pool-wide network associated with eth0
        name-description ( RW):
                  bridge ( RO): xenbr0
    
    
    uuid ( RO)                : 3d13d4c3-546f-3f51-19c9-792a2d899a94
              name-label ( RW): Bond 1+2+3
        name-description ( RW):
                  bridge ( RO): xapi1
    
    
    uuid ( RO)                : b14a0bdd-2f77-25f7-3a76-b830ff971624
              name-label ( RW): Pool-wide network associated with eth2
        name-description ( RW):
                  bridge ( RO): xenbr2
    
    
    uuid ( RO)                : 00b6604f-9098-023b-5880-0ef9f8e1b437
              name-label ( RW): Pool-wide network associated with eth1
        name-description ( RW):
                  bridge ( RO): xenbr1
    
    
    uuid ( RO)                : e3be0e1a-9872-4b90-c851-35eb30a86920
              name-label ( RW): Pool-wide network associated with eth3
        name-description ( RW):
                  bridge ( RO): xenbr3
    
    
    uuid ( RO)                : ea7dce53-81ff-3b7c-155f-966721119bac
              name-label ( RW): Private LAN
        name-description ( RW): Internal LAN network
                  bridge ( RO): xapi0
    
    
    uuid ( RO)                : c54ecffe-9467-5d5f-cb73-ec10dedef2b9
              name-label ( RW): Host internal management network
        name-description ( RW): Network on which guests will be assigned a private link-local IP address which can be used to talk XenAPI
                  bridge ( RO): xenapi
    

  • XCP-ng Team

    Okay I think I get it. The template with its VIF was build on a machine with xapi0 network. For some reason, it fails to import on a host without this network.

    I'll try to modify the XML to use xenbr0 that should be for everyone. Why XAPI fails? Why importing "directly" works? IDK.


  • XCP-ng Team

    @Danp I regenerated XOA with xenbr0 instead of xapi0. Can you try to redeploy?



  • @olivierlambert The "quick deploy" via web worked correctly this time ๐Ÿ‘



  • I am getting "netdata plugin is necessary" when I mouse over the "Enable Advances Live Telemetry" option. The host is a fully patched XCP-ng 8 and I have tested with both XOA Free and the the self compiled XOA both are running xo-server 5.53.0 & xo-web 5.53.3. I manually installed netdata-ui.x86_64 & netdata.x86_64 via command line and netdata is working fine and is accessible via http://host_address:19999

    I did reboot the XCP-host and both the XOA and the problem persists, what should I check next?



  • @flipsidecreations There's a new Netdata plugin, which appears to only be available in XOA Premium edition. It doesn't appear that you will be able to enable the new Advanced Live Telemetry using the versions you are currently running.



  • @Danp Thanks, that makes sense. Perhaps is should show "Premium Feature" instead of "netdata plugin is necessary" when using the free versions.


  • XCP-ng Team

    @flipsidecreations said in Netdata package is now available in XCP-ng:

    @Danp Thanks, that makes sense. Perhaps is should show "Premium Feature" instead of "netdata plugin is necessary" when using the free versions.

    This was explained in my 1st post in this very topic ๐Ÿ˜‰ We just released in time, so we'll make it more clear for next release ๐Ÿ™‚ BTW, I think you have a XOA Premium available ๐Ÿ˜‰ If it's not the case anymore, just let me know.


  • XCP-ng Team

    @Danp said in Netdata package is now available in XCP-ng:

    @olivierlambert The "quick deploy" via web worked correctly this time ๐Ÿ‘

    Thanks for the feedback!



  • Not specifically related -- however FreeNAS is doing away with Netdata I believe in the 11.3 release upcoming -- say there is big memory link when running. I don't have specifics but there development team was pretty adamant about the shortcomings of netdata -- so much so they are dropping it. I find it curious while they are dropping support, xcp-ng is adding support. Any testing for this condition?



  • This post is deleted!

  • XCP-ng Team

    @kevdog not aware of memory leaks with Netdata. I'm graphing on long term on my own hosts. In XCP-ng, we are using the latest version.



  • Just some feedback, don't know if is normal.

    Have a host, with a VM ON but nothing run, before netdata plugin 24% load (stacked values) after netdata install and reboot the host reports 29%, so netdata need 5% cpu ?

    Thanks


  • XCP-ng Team

    You can check what amount of CPU usage netdata uses in htop... or in netdata.

    Note that netdata runs with a very low priority so in theory the overhead should not slow your important tasks down.



  • @kevdog The issue with Netdata that caused it to be removed from FreeNAS was specifically a memory leak in the FreeBSD version of Netdata.

    https://github.com/netdata/netdata/issues/7356

    ncmans created this issue in netdata/netdata

    open Re-introduce Netdata to FreeNAS #7356



  • @flipsidecreations

    Thanks for clarification on that issue -- Weird however -- I read through a bunch of those links referenced in your post, and the last post was 2017 which fully described the problem. One of the things in general I hate about github are many tickets are closed without any mention of how the problem was resolved -- or if it wasn't just due to lack of inactivity in the thread. Freenas now dropping package based on this thread information that is almost 3 years old.



  • Rebooted my host today and the Netdata graphing is messed up in several sections. The individual VMs are showing broken graphs for every report. The graphs are just dots. No lines.

    Also under the โ€œDisksโ€ section, the graphs are working but the numerical reporting is broken. Itโ€™s showing all zeros for Read, Write, and Utilization even though the graphs are showing activity.

    Iโ€™m on iPad now looking at it so I canโ€™t post screenshots. Later today Iโ€™ll post some captures so you can see what Iโ€™m talking about.

    Any other reports of Netdata not working after reboot?



  • Small nitpick -- you can tell me to go away. Anyway to install certs so I can view the data using https?


Log in to reply
 

XCP-ng Pro Support

XCP-ng Pro Support