Monitor XOA Disk Space



  • Hi everyone,

    I am new to XO but so far I was able to integrate it into our XenServer environment without further problems. Now I am looking for a way to Monitor the XOA Appliance itself? I'd like to integrate at least the Disk space usage (mostly regarding local backup disks and maybe Syslog into our PRTG Monitoring. I guess maybe the Nagios Plugin does things like that, but I don't have Nagios.

    Of Topic: are there more Plugins available like the ones included in XOA Appliance?


  • XCP-ng Team

    Latest XOA now uses Netdata. You can use it, create alerts or even stream to another netdata. You can reach netdata dashboard on your usual XOA URL, adding /netdata/ in the end.



  • only to clarify, now I am on the stable release channel with 5.40.2. to get netdata I need to switch to the latest channel?


  • XCP-ng Team

    You need to use the latest XOA (export config from your current one, import in the new one)



  • Hello Oliver,

    thanks for your update. I have updated my XOA to Version 5.42.0 and it seems the Netdata is running. But I cannot connect to it. I get the message "There was a problem proxying this request." when trying to access the site. I also searched in the Documentation and found that I need to Enable Advanced Live telemetry on each Host to use this. At this point I started thinking If we are talking about the same here.

    I have no need to Monitor my Hosts for additional Information. I would like to Monitor the XOA Appliance itself. Lets say for availability, Backup Volume Disk Space, maybe even Logs for the latest Backups being successful or not. And other nights I can't think of right now.
    I know for the Backup I can send an E-Mail but I would prefer displaying it in our monitoring.


  • XCP-ng Team

    Any latest XOA have a netdata monitored if you go to the URL /netdata at the end.



  • Maybe I understood something wrong, but I cannot open that page. Here a Screenshot what I am seeing when trying to access the Netdata URL. Do I need to activate anything for this? I am already logged in to XOA and I tried different URLS but the only one I found "working" was this one.

    e348f30a-2d01-4b50-980b-ba5730e39316-image.png


  • XCP-ng Team

    Are you sure you are using the latest XOA? When you SSH on it, you should have the build number.



  • On the Web UI no Update is available in the latest Branche. the Build number on SSH is 19.06.24


  • XCP-ng Team

    So you aren't using the latest XOA 😉 I mean the appliance (XOA=Xen Orchestra virtual Appliance), not Xen Orchestra's code inside.

    New appliances contains Netdata but also runs on Debian 10.

    Use https://xen-orchestra.com/#!/xoa to deploy the new one. You can export the config from the old one and import it to the new one.



  • Ok thanks for that Information. I am using a local disk for my Backups. how can I move them to the new Appliance?

    How often will I need to Update the XOA Appliance?


  • XCP-ng Team

    In general, we do a fresh XOA every 2 years or so. It depends on various things, but we try to keep relatively recent version of Debian.

    Using local disk for backup is not really recommended, and one of the reason is that you'll lose a bit of flexibility: XOA can be considered as almost stateless (ie disposable), which conflicts a bit with the fact to backup locally. I strongly recommend a network share to store your backups (even a cheap NAS is better than local backups).



  • My Backup is located on a iSCSI mounted storage on an additional Disk I attached to the XOA, but at the moment I have no NFS or SMB capabilities on Storage side to do it in another way. This will change in the next 6 Months.

    Would it be possible to detach the Virtual Disk in XenServer from the old XOA and attach/mount it in the new one at the same mount point?


  • XCP-ng Team

    Yes, as long as you don't write to it a two places on the same time. I would suggest to unplug from the old XOA first, then plug to to the new one. Then it will be totally transparent because of the configuration import on the new one (nothing lost)



  • Hello Oliver,

    everything worked fine and I am now on the new Version. I also can find the netdata page now 🙂

    Unfortunately the page doesn't seem to look like it should. Most of the links are not working or sending me to the top of the page. It seems some CSS is missing. Java Script is enabled and I triesd it in Chrome, Firefox and Edge. all the Same. Also rebooted the Appliance after the last Update.

    2b2cc3ef-fc69-4979-9a9f-218757823e87-image.png


  • XCP-ng Team

    Try netdata/ with a trailing slash at the end.



  • easy as that 🙂

    Thanks for you help.


Log in to reply
 

XCP-ng Pro Support