Console keyboard problems using Firefox

  • I'm currently having problems with typing in the console of all of my VMs, but only when using Firefox on MacOS:

    • keys pressed with the shift key pressed will be entered as if the shift key was not pressed;
    • keys pressed with the option key pressed will not be entered at all.

    This occurs using Firefox 70.0.1 and also Tor Browser based on Firefox 68.0.3.

    This does not happen when using Safari or Chrome. I have not tested this using Windows browsers.

    I do not use Xen-Orchestra very often, and the consoles even less often, so I do not know when this started; several aspects of the system - XOA, Firefox, Tor - have likely been updated since I last tried the consoles.

    Current version: 5.40.2

    • node: 8.16.2
    • npm: 4.6.1
    • xo-server: 5.52.1
    • xo-server-telemetry: 0.2.0
    • xo-server-xoa: 0.3.0
    • xo-web-free: 5.52.0
    • xoa-cli: 0.16.0
    • xoa-updater: 0.23.1

  • This just got me, too. No shift nor CTRL when using Firefox, but all keys work fine in Chrome.

    • Firefox 75.0
    • xo-server 5.56.3
    • xo-web 5.56.2

  • @ccsmith Is Firefox's System Preferences > Keyboard > Input Sources set to U.S. , or whatever language you're using?

    I don't know if it's related but some guy in had set it to Unicode Hex and had problems with Option-Shift-Arrow

  • I've experienced this as well using the Window's version of Firefox. Not sure of the cause, but a restart of the browser seemed to fix it for me.

    If you are using XOA w/ support, you may want to open a support ticket.

  • @peder: Yes, the keyboard is set to U.S.
    @Danp: No change after Firefox restart.

  • @ccsmith Please update your XO VM and then retest.

  • Rule out problems with your old firefox profile by creating a new firefox profile dedicated to non internet stuff. We should always use a dedicated profile for internal only websites such as your firewall webpage, XenOrchestra, freeNAS, and so on.

    firefox -no-remote -new-instance -createprofile intranet
    firefox -no-remote -new-instance -P intranet

  • @rjt said in Console keyboard problems using Firefox:

    Rule out problems with your old firefox profile by creating a new firefox profile dedicated to non internet stuff

    Just tried this, but didn't resolve the issue for me. In the current scenario, I am trying to launch an SSH session. I clicked the "SSH as..." button, but my typing is going to the console instead of the popup window.

    Seems to be intermittent. This issue will go away, but then returns if I switch away from and then back to the XO console tab.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support