XCP-ng 8.1 Release Candidate now available!


  • XCP-ng Team

    I have pushed three new updates: kernel-alt, xcp-python-libs and xapi(-*).

    • kernel-alt updated to 4.19.108 by @r1
    • xcp-python-libs updated as a requirements for handling the grub configuration update when kernel-alt will be updated, now and in future updates
    • xapi updated with code by @BenjiReis to handle export and restore of VMs in a suspended state. This is a foundation for a future XO feature related to that.

    Please update and make sure that you notice no regression related to those updates.



  • @stormi is the server restart necessary and how do I know with future updates if a server restart necessary


  • XCP-ng Team

    Rule of thumb:

    • if there's an update on a kernel you are using in the dom0, you must reboot to run on the updated kernel
    • if there's a Xen update, idem
    • if there's a XAPI update, in most case, toolstack restart is enough
    • for other thing, it's more variable and hard to predict. But let's say in general, no mandatory reboot. However I'd like to stress that rebooting is a good thing, especially for all security related updates.

  • XCP-ng Team

    I'd add: if you don't reboot, always restart the toolstack. It's better to restart it for nothing than to forget to restart it. Note that the above Rule of thumb is also written in the updates howto.

    For precise instructions related to any update, refer to the blog post that announces them (until we can get them directly in XO). I try to always give such instructions. Forgot here because it's the RC.


  • XCP-ng Team

    Final release is really close. I have built "pre-final" ISOs that do not differ much from the RC except from the updated kernel-alt, xcp-python-libs, xapi and xsconsole (replaced ext3 with ext in the local SR display since it can be either ext3 or ext4 depending on when the SR was created). Another fix: the netinstall ISO now correctly detects that it is a netinstall ISO when started in UEFI mode. The only visible change is that it doesn't offer local media anymore, consistently with the behaviour it already had in BIOS mode.

    Things to test:

    • booting and installing kernel-alt
    • netinstall in UEFI
    • installation, basic features, coalesce...

    ISOs can be downloaded from https://updates.xcp-ng.org/isos/8.1/



  • @stormi

    I've been holding out moving to 8 until it was finalized since I'm running the experimental ext4 driver. Can you confirm the following steps for transition to 8 if running the experimental ext4 driver?

    1. Update to 8 and reboot
    2. Copy/Export VMs somewhere off ext4 experimental SR
    3. Unplug via CLI old experimental SR
    4. Forget via CLI old experimental SR
    5. Create new SR via CLI
    6. Reinstall XO
    7. Copy VMs back to new SR

    Will the below command specifically create the new SR on the host/disk of my choosing using the new ext4 driver?

    xe sr-create type=ext name-label=mySR host-uuid=<host_UUID> device-config:device=/dev/sdX
    

    So the above command would create the new SR using ext4 just by giving it the type of ext?

    I'm running MDRAID on this host and it appears that when running xe pbd-list it shows my SR in question is at device /dev/md127p4. That's partition 4 of the mdraid array that is holding the old experimental ext4 SR partition. I'm assuming when I run the above xe sr-create command that I want to make sure that I feed it device-config:device=/dev/md127p4.

    It looks pretty straight forward if I have the above logic right. I'll have to find out how to find my host UUID but I'm sure that is pretty easy. Copying the VMs somewhere may be a larger and more time consuming challenge.



  • @stormi Will the RC release with yum update become the final release


  • XCP-ng Team


  • XCP-ng Team

    @Biggen It's on my TODO list to write detailed instructions for that migration before the release. I'll follow the procedure myself and see what happens. Others can comment too and help making it perfect.


  • XCP-ng Team

    New updates are available for those who have installed the beta, the RC or from the pre-final ISOs. They fix an issue that no one had seen yet but very important: the chronyd service was not enabled when updating via yum, nor chrony-wait.service, vm.slice and sm-mpath-root.service (Citrix Hypervisor's update from 8.0 to 8.1 exhibits the same issue).

    They also modify the tty console welcome message to mention Xen Orchestra as the official graphical client.

    I have also built new ISOs ("prefinal2") with the updated packages. I hope those will be the final ones. Download from https://updates.xcp-ng.org/isos/8.1/


  • XCP-ng Team

    @stormi said in XCP-ng 8.1 Release Candidate now available!:

    @Biggen It's on my TODO list to write detailed instructions for that migration before the release. I'll follow the procedure myself and see what happens. Others can comment too and help making it perfect.

    Done: https://github.com/xcp-ng/xcp/wiki/XCP-ng-8.1-Release-Notes#migrate-from-experimental-ext4-storage-repositories



  • @stormi

    Can you export and import VMs with xcp-ng Center? I have a single host pool so I'm not sure what the best method is of exporting them and then importing them once the new SR is created.

    My XO Community Edition resides on the experimental SR . So I can use that to move/export my other VMs first but I'm not sure how to move the actual XO CE last. I may have to simply reinstall it from scratch which isn't a big deal.



  • @Biggen Not sure if this will work for you, but I temporarily migrated my VDIs to my backup source (I created an NFS SR) and then deleted / recreated my local storage.



  • @Danp

    I think that is what I'll do.

    Its the import that I'm not quite sure how to handle. If I backup everything to a NFS and delete the old SR, then I have no controlling XO any longer to begin the import. So I either have to manually reinstall XO CE or use xcp-ng Center.



  • @Biggen To be clear, I didn't export / import. Here's what I did --

    • Created a new NFS SR on my backup device
    • Migrated the existing VDIs to the NFS SR
    • Removed the existing local storage (was LVM)
    • Recreated the local storage as Ext4
    • Migrated the disks back to local storage

    IIRC, I had to restart a few of the VMs post migration but otherwise the process worked fine for me



  • @Danp

    What did you use to migrate with? Did you have another host where you could run XO(A) from?



  • @Biggen No, the host doesn't change at all. You are just moving all disks to different storage so that you can recreate your local storage. I believe the latest version of XO lets you do this from the SR > Disks tab.

    If you run into issues with moving your XO instance, you could always spin up a 2nd instance or use XOA.



  • @Danp

    Oh, I see. You are talking about migrating everything including XOA to NFS and running it from there while I'm destroying/recreating the SR, and then moving everything back.

    Yeah I get it now.



  • Upgrading to 8.1 from 8.0 went just fine. Thanks for the help @Danp. Moving everything to a temporary NFS share worked easy (although one stubborn VM couldn't be migrated for some reason. I had to perform a copy instead).

    Just be aware if you pass through any disks or have a local ISO SR setup in dom0, you will have to set it back up again. The pass through disks are easy since the data itself on the drives isn't touched. You just have to pass them back through and reattach to the appropriate VM. The local ISO SR is another story since it gets wiped if it resides in dom0. Not a big deal. Just have to copy back into it the installation ISOs required and add it back in the storage menu.



  • @Biggen said in XCP-ng 8.1 Release Candidate now available!:

    local ISO SR

    Why not just setup an NFS one?


Log in to reply
 

XCP-ng Pro Support