Blank Screen CentOS 8 in fresh xcp-ng 8 installation

  • After accepting the license for CentOS 8, it gives me infinite blank screen
    And I also have this problem with RHEL and Oracle Linux and Manjaro
    Only Ubuntu and Windows works


  • XCP-ng Team

    Are you in UEFI or BIOS? Have you enable or disable "VGA" in advanced tab?

  • I also have the same issue. VGA was enabled by default but I did try disabling it. I also did try switching from BIOS to UEFI but doesn't boot at all.

    If I do the shutdown command it still gracefully shutsdown the VM so it seems like it is still running but the GUI doesn't respond in CentOS 8.

  • @linhnb hi, I had similar problem in xenserver 7.0 old times. Did you use CentOS template??, try to create a new VM with windows server template or maybe ubuntu and attach the hard drive from CentOS VM, it will probably work.

  • @xisco Thanks! I did use the CentOS 8 template when creating the VM. I'll try one of the templates you suggested when I get home tonight.

  • So I remade the VM twice. Once with 18.04 template which I have used before and another with the Windows 2016 template. Neither of them work as well. Still boots up to the same screen that is shown in the first post.

  • @Kraken89 maybe you can try to attack the hard disk to an existing VM and try to boot?, I think in my case was that the template had PV enabled

  • @xisco thanks for the advice. I did try attaching the disk to an existing VM I had running but it still boots to the same screen.

  • Hope I'm not too late for the party... I was fighting this one too... or something similar.

    Try installing CentOS 8 with the Workstation group install (so yum groupinstall "Workstation" if you've already run the setup wizard). Also, VGA is enabled for me but I bumped the Video RAM up to 16MiB from 8; this seems to make the difference for me.


    This, at last, gets me a consistent login screen.

    Red Hat had advised against setting up v8 VMs as "Server with GUI" due to issues with console display; not sure if this is still current. The CentOS 8 template appears to be a non-factor, at least for me.

  • Did anyone get a solution to this? I've a piece of software that only works on CentOS 8 (doesn't work on CentOS 7) and I can't get this installed due to the "Black Screen of Death" (sorry.... I had to name it).

    I'm having the same issue that @m076162 had. I've tried upping the RAM to 16GB but I don't get to the login screen. Just stays on the Logo 8 black background screen. @m076162 How did you run the "yum groupinstall "Workstation" command? Cent OS 7 out of the box doesn't have a network configured within the installation. Hence you can't SSH into the box using PuTTy to configure the network and run the Yum command. Did you configure the network as part of the installation process for CentOS 8?

    Edit: Just to say that I've just tried a new install of CentOS 8 and configuring the Network during the installation procedure, then I could successfully SSH into the box using PuTTy to run the suggested command. Even still, I'm still getting the black screen of death.

  • @MichaelCropper
    I was struggling with this also. A class I am taking I wanted to set up a CentOS 8 VM.
    I used CentOS 8.1.1911-x86_64-boot.iso for the install.
    Using the graphical installer I just accepted the default group which for this ISO is "Server with GUI"
    I also installed the "Development Tools" package (not that I think that matters for this issue)
    When I booted I got the "black screen of death" (it now has official name lol)
    I did a shutdown graceful shutdown of VM.
    I went to the "Advanced" tab and switched from VGA 8 to VGA 16 (VGA was on by default).
    When I created the VM I used the CentOS 8 template btw.
    I rebooted the screen and.. yup I got the GUI login screen!

    I hope this helps.

    ps make sure you install those xen tools right away and then reboot.. otherwise , it's painful. 😉

  • @ben20ben Thanks, This works. Do you know the reason why we need to select video RAM as 16 MB instead of 8 MB?

  • XCP-ng Team

    Not enough video memory for the OS to load the graphical UI.

  • @MichaelCropper, to answer your question, yes, I enabled networking during the installation process. This allowed me to SSH in following the subsequent reboot to run yum groupinstall "Workstation". VGA was enabled for me and then Video RAM was at 16MiB. @ben20ben brings up good advice with the XCP-ng tools, install it and life gets easier.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support