Migrating docker host to new XCP host not working.



  • Hi Guys,

    I've just had to reformat and re-add one of my hosts to the pool after some issues yesterday. Everything is happy, except, when I try and migrate the docker host I have running onto this host (that used to work fine) I get "The host does not have some of the CPU features that the VM is currently using" in XCP-ng Center and "The VM is incompatible with the CPU features of the destination host. Would you like to force it anyway?" in XO.

    I have yum installed xscontainer on it (and rebooted) but no joy at the moment.

    Ideas??


  • XCP-ng Team

    You are trying to live migrate a VM started on a more recent CPU to an older CPU. Doing this live can cause a VM crash on destination. You have to shutdown, migrate and boot on destination.



  • Ohh... OK. That's interesting. I must have done it the other way the first time I set this up because I've been migrating it backwards and forwards happily for a while (the joys of lab hardware where everything is different).

    Thanks Oliver, I'll give it a go.

    Peter.


  • XCP-ng Team

    If it's in a pool, CPU features will be "leveled" to the lower one, so no problem to migrate. However, between pools, it's different. Migrating from older to newer CPU is OK, but not the opposite.



  • Yep.. that did it... started it on the older host, and can now migrate it backwards and forwards with on issues...

    Thanks Olive... as always.

    Peter.


Log in to reply
 

XCP-ng Pro Support

XCP-ng Pro Support