[Beta Release] XCP-ng Windows Client tools 8.2.1-beta1



  • Hello all together!

    I think this time the Drivers (Version 8.2.1) and Management Agent are put together in the right way, so please test again our XCP-ng Client Tools for Windows!

    🎆 https://github.com/xcp-ng/win-pv-drivers/releases/tag/v8.2.1-beta1 🎆

    Because of some unknown errors in the WMI-part of the Management Agent, which are also present in the official Citrix ones, I decided to declare it a Beta-Release 🙂

    Any help/pointers/ideas to resolved these issues are very very welcome!
    You can see these errors in Event Manager -> Applications and Services Logs -> Microsoft -> Windows -> WMI-Activity -> Operational

    0_1542583366428_a226156b-970e-4428-98c9-1eaed44fe72b-grafik.png



  • nobody has complained 😃 All ok?
    Please leave just a OK if all is good, so we have a bit of feedback for the next steps.



  • I did few tests yesterday under my nested XCP-ng lab, with a Win Server 2019 VM (French Locale). It failed to install, the classic error "Management Agent failed to install" and no drivers was able to came from Windows Update (i guess it's normal due the recents problems with W10).

    But this is nested virtualization under VMware, I don't know if these tests are relevant since they are not accomplish on a real situation on real hardware.



  • I am testing today in my lab and tomorrow in production if things go well. I am testing Windows Server 2016, Windows Server 2012 R2, Windows 10 1803 and Windows 10 1809



  • @Ruskofff Please try to stick to Windows in US. Other languages gives issues, even with XS and XS tools.



  • @Ruskofff just reboot! This error is a false alarm.

    And there is no need to get drivers from Windows Update, because xcp-ng drivers are not in windows update.



  • @olivierlambert I want to have these tests. No need for US locale on french windows.



  • So my Windows Server 2016 VMs had previously the XenServer drivers. After removal, reboot, install of XCP-NG tools and completes successfully and reboot. The VM still shows the VM without any tools running and the XV PV storage device under Device Management shows an Exclamation sign.



  • I will give an another try this evening.

    Usually I use English version, but I only have access to a French version of WS 2019 (still waiting stuff from MS Imagine 😔 ). I can test with W10 and WS 2016 too.

    For Windows Update, that was just a XOA test, just try to install the drivers but they seems not available.



  • I will not able to make some additionals tests, too many problems with nested virtualization and VMware..... And I can't using QEMU/KVM due to a wtf problem with XS/XCP-ng in nested virtualization (XS/XCP-ng VM crash due to a thermal interrupt when launching a nested VM 😒 ). And my VM server is 2000km away from where I live now.



  • On a host running XCP-ng 7.6 I tested the tools on 2 VMs:

    1. On new install of Server 2016: Ran XCP-ng tools' setup.exe as administrator which gave a "Windows Management Agent failed to install" error message. Then remembered I needed .net framework 3.5 and installed it then tried again. Installed successfully and was prompted to reboot. It appears to be working correctly. Both XO and XCP Center tell me the management agent is not installed on the VM (though I believe it is). You might consider adding a reminder about the .net 3.5 requirement in the setup.exe prompts.

    2. On existing install of Server 2016 with .net 3.5 installed: Uninstalled Citrix guest tools then rebooted. Server came back up with full capabilities of guest tools and correctly recognized NIC. From what I can tell, Citrix's tools didn't actually uninstall. I then installed Citrix's guest-tool-leftovers uninstaller (xluninstallerfix.exe), ran it, and rebooted to a blue screen. Restored to snapshot. Attempted same process (xluninstallerfix.exe) then installed XCP-ng guest tools before reboot but still blue screen. Attempted to remove Citrix's guest tools in safe mode using the process described here: https://antisp.in/recovering-windows-server-2012-on-xen-server/ (author fails to mention you need to manually start the two services). Restarted several times but Citrix's tools are still active. Did the same thing with xluninstallfix.exe in safe mode and then attempted to install XCP tools while still in safe mode. XCP tools failed to install as it was unable to start a service (error 1603, related to task scheduler I believe). After several failed install attempts rebooted to another blue screen. I could have booted to safe mode again but I'd still be unable to install tools in safe mode so out of luck.

    As far as I can tell it works great on new VMs but there seems to be no way to safely replace Citrix tools with XCP-ng tools at the moment.



  • @harrise I have the same experience.



  • @dbeato said in [Beta Release] XCP-ng Windows Client tools 8.2.1-beta1:

    @harrise I have the same experience.

    Actually mine said Management Agent installed, then I also needed to do Cause A( steps on the troubleshooting guide here
    https://github.com/xcp-ng/xcp/wiki/Troubleshooting#windows-management-agent--windows-pv-tools



  • See below my results
    0_1543318176087_2018-11-27_0629.png
    0_1543318351240_2018-11-27_0632.png
    0_1543318394138_2018-11-27_0632_001.png



  • @dbeato glad that it works now... I actually don't know an automated way to find all the little things that can cause the drivers to fail. It's mostly detective work 😕



  • @borzel said in [Beta Release] XCP-ng Windows Client tools 8.2.1-beta1:

    @dbeato glad that it works now... I actually don't know an automated way to find all the little things that can cause the drivers to fail. It's mostly detective work 😕

    Yeah, that is why I am reporting here 🙂 One thing I would say though, it doesn't seem to do the paste from the host as XenServer used to. Not sure if it is supposed to be that way.



  • @dbeato hmm.. never saw this feature ... I'll try with some test VMs



  • @dbeato it just works!

    0_1543354762165_1e58c732-fb06-4288-870b-207858a7cd40-grafik.png



  • @borzel said in [Beta Release] XCP-ng Windows Client tools 8.2.1-beta1:

    @dbeato it just works!

    0_1543354762165_1e58c732-fb06-4288-870b-207858a7cd40-grafik.png

    Good, that's what I need to review again as this morning did not want to work.



  • I've installed this on Win server 2019, PV Drivers install, but XCP-ng center reports the management agent is not installed AND under the performance it says to install XCP-ng tools to view memory data.