XCP-ng
    • Categories
    • Recent
    • Tags
    • Popular
    • Users
    • Groups
    • Register
    • Login

    HA Operation Would Break Failover Plan

    Scheduled Pinned Locked Moved Solved Advanced features
    13 Posts 4 Posters 3.2k Views 3 Watching
    Loading More Posts
    • Oldest to Newest
    • Newest to Oldest
    • Most Votes
    Reply
    • Reply as topic
    Log in to reply
    This topic has been deleted. Only users with topic management privileges can see it.
    • M
      Midget @olivierlambert
      last edited by

      @olivierlambert

      xe pool-ha-enable heartbeat-sr-uuids=<XOSTOR UUID>
      

      I ran this on the pool master.

      1 Reply Last reply
      Reply Quote 0
      • olivierlambertO
        olivierlambert Vates 🪐 Co-Founder CEO
        last edited by

        Can you do a xe pool-ha-compute-max-host-failures-to-tolerate please?

        M 1 Reply Last reply
        Reply Quote 0
        • M
          Midget @olivierlambert
          last edited by

          @olivierlambert 3 good Sir.

          1 Reply Last reply
          Reply Quote 0
          • olivierlambertO
            olivierlambert Vates 🪐 Co-Founder CEO
            last edited by

            Hmm that's probably the issue 🤔

            Can you do xe pool-param-set ha-host-failures-to-tolerate=2 uuid=pool-uuid and then retry to enable HA on your VM?

            1 Reply Last reply
            Reply Quote 0
            • M
              Midget
              last edited by Midget

              It's been a long week. I have wasted your time. I never installed the guest tools.../facepalm

              EDIT
              I realized it right after I ran that command. HA is now enabled.

              1 Reply Last reply
              Reply Quote 0
              • olivierlambertO
                olivierlambert Vates 🪐 Co-Founder CEO
                last edited by

                So the error message was not great. It worked a soon you got tools installed in the VM?

                M 1 Reply Last reply
                Reply Quote 0
                • M
                  Midget @olivierlambert
                  last edited by

                  @olivierlambert Correct Sir. I apologize for wasting your time.

                  1 Reply Last reply
                  Reply Quote 0
                  • olivierlambertO
                    olivierlambert Vates 🪐 Co-Founder CEO
                    last edited by

                    Don't worry. The error message was not great. Time to enjoy the week-end 🙂

                    1 Reply Last reply
                    Reply Quote 0
                    • olivierlambertO olivierlambert marked this topic as a question on
                    • olivierlambertO olivierlambert has marked this topic as solved on
                    • A
                      arc1
                      last edited by

                      Hi,
                      I'm getting same error - HA_OPERATION_WOULD_BREAK_FAILOVER_PLAN() - when I try to put host in maintenance mode.
                      I have 3 nodes in pool and I set xe pool-ha-compute-max-host-failures-to-tolerate to 1.
                      In error log I'm not able to find why causes this error.
                      Any ideas? Tools are installed on all VMs.

                      DanpD 1 Reply Last reply
                      Reply Quote 0
                      • DanpD
                        Danp Pro Support Team @arc1
                        last edited by

                        @arc1 What does xe pool-ha-compute-max-host-failures-to-tolerate return?

                        A 1 Reply Last reply
                        Reply Quote 0
                        • A
                          arc1 @Danp
                          last edited by arc1

                          @Danp said in HA Operation Would Break Failover Plan:

                          xe pool-ha-compute-max-host-failures-to-tolerate

                          It returns 1.:
                          [13:34 log]# xe pool-ha-compute-max-host-failures-to-tolerate
                          1

                          1 Reply Last reply
                          Reply Quote 0

                          Hello! It looks like you're interested in this conversation, but you don't have an account yet.

                          Getting fed up of having to scroll through the same posts each visit? When you register for an account, you'll always come back to exactly where you were before, and choose to be notified of new replies (either via email, or push notification). You'll also be able to save bookmarks and upvote posts to show your appreciation to other community members.

                          With your input, this post could be even better 💗

                          Register Login
                          • First post
                            Last post