XCP-ng 8.0.0 Beta now available!

  • XCP-ng Team

    @AllooTikeeChaat I'm always stunned by the fact Citrix communication on Xen is equal to /dev/null, despite all the great efforts made by the Xen devs (half of them are from Citrix!)

    So as I said, it's not there yet, but it's going into that direction pretty well, I would expect this stuff to be backported in the future I suppose, because it's really powerful!

  • When will the final version of XCP-ng 8.0.0. be available?

  • XCP-ng Team

    This will depend a bit on community feedback: more feedback means faster release 🙂

  • @olivierlambert I’m sorry I’m not more available to bring more testing to the table this week, I am AFK.

  • XCP-ng Team

    No worries mate! To give a more precise answer, we might target a RC for the end of the month, maybe sooner, IDK yet.

    Then if there is no big issue spotted with the RC, release will come near after 🙂

  • Connecting an iSCSI SR in xsconsole fails if there's a discovery password.
    It works if I disable the authentication.

    It works in XenOrchestra if I attach it as a new SR (With auth) AND have the same discovery username and password in the ACL of the iqn.
    That still doesn't work in xsconsole.

    My iscsi server uses targetcli-fb/LIO.

  • XCP-ng Team

    Is it something broken before? Because I don't think we ever touched xsconsole outside colors

  • I’ve fairly certain I’ve had this problem since xenserver 6.x

  • XCP-ng Team

    Okay so this issue could be opened somewhere, but IMHO it shouldn't be a blocker for the release 🙂

  • I used tgt and no authentication before so I can't say.
    I decided to try targetcli and authentication when I installed 8 beta.

    No, it's probably not a blocker.

  • @olivierlambert Go figure - just two days after that posting, my creaky old HP DL365 Gen1 up and died. CPU 1 memory bank shows a solid set of lights for RAM sockets, i.e. the memory controller can't access RAM. Bummer.

    My wife took pity on me - or got me a father's day gift, depending on your point of view - and sprung for a Dell R815, which is supported. Of course, I gave the 8.0 beta a spin.

    Installation was slightly faster, but there have been a few minor quirks along the way:

    • The USB key I stuck into the unit wasn't an option for the OS install, but did show up as an option when creating storage for VMs. No big deal, but still kinda strange.
    • Peeking at a different console via Alt-F2 and Alt-F3 showed some patches? And the kernel/dracut root/boot installation section took a loooong time to complete; everything else flew by. If it's downloading those patches that would explain the delay - the unit has a slow wifi bridge connection.

    Other than those, it seems fine. I'm still poking around it, getting a few for what's changed.

  • XCP-ng Team

    @apayne I'm not aware of the installer being able to download patches from the internet. Can you create a tarball of /var/log/installer and make it available to me so that I check that?

    Not being able to install the system on usb key is a good thing: it is not recommended because it would wear out too quickly due to frequent writes.

  • XCP-ng Center Team

  • @stormi

    Xen Orchestra is not letting me log in after deploying with the Quick Deploy. Always returns "invalid credentials". I have attempted to quick deploy a number of times with different usernames and passwords but no joy. As I am just kicking the tires I did not created an account on xen-orchestra.com so I left those fields empty, not sure if this would make a difference.

  • XCP-ng Team

    Please yum update before, we fixed some stuff regarding that.

  • @apayne said in XCP-ng 8.0.0 Beta now available!:

    @DustinB said in XCP-ng 8.0.0 Beta now available!:
    [...] Citrix just waved their hands and said "these don't work anymore".

    As for so many other people: Start reading and understand what you read.
    It's not said that they don't work anymore, what they say is: They don't care if any THESE CPU/PLATFORM RELATED PROBLEMS occure. They might try but will give up rather soon, as it's called "best effort".

    And a pretty good, understandable, reason is: Vendors don't help anymore, means in case something's wrong on that and you need their support, because you promised customers, that you support that... guess what?
    Solution: Drop it!

    I'm sure you could get support forever - if you pay the right amount.
    Otherwise: Somewhen it's time to replace old stuff and buy new(er), way less energy consuming, hardware.

    And why paying for Hyper-V? It's free, like the smallest version of VMware is. Most people and small companies are pretty fine with what their limits. Don't get me wrong: If XCP-ng continues the roadmap, I see a good chance to beat them up.

    You should way more read about all of that, than yelling and complaining at/about Citrix or XCP-ng.

    "We still have the experimental ZFS support and zfs packages have been updated to 0.7.13. The known limitations (no VDI export...) remain for now."
    As you posted it's on 0.8.0 now, you should update the startpost. 😉
    Also IIRC you said migration/export is still not supported with ext4/zfs etc. - when (or for what/when) will that change?
    Do backup tools need to know about ext4... and/or does it make any difference for them, or is it just interally, so it's like as if nothing ever changed?

  • XCP-ng Team

    ZFS in XCP-ng 8.0 is fully functional. Migration/export/backup, everything is working.

  • @cg re: old CPU support, the note was already taken 😸 it just strikes me as ironic. I understand the need for less power hungry processing but in my case I’m using a hefty 260 watts idling for the server alone. I am guessing the old SAS/SATA enclosure I have rigged to it is another 300 or so at idle. That’s a lot of draw for “newer”, but the capacity is excellent so I won’t be needing more hardware. Plenty of room to spin up new VMs.

    Re: Hyper-V, I already use the 2nd Gen at work via old 2012r2 installs. It’s OK and gets the job done. However I’ve been tasked with shuffling and consolidating some older installations to newer hosts/hardware, and the move process is a bit clunky for that version. Device pass through seems a bit limited.

    Last time I saw VMware it was a demo lab we did at work, and it too was “just ok”, that was with the vmsphere(?) web interface, etc. However last I heard they are slowly tightening the list of supported hardware drivers, and by extension, supported hardware. That was a few years back so maybe they have added new drivers.

    XCP benefits from decades of Linux device driver development. It simply boots, and that removes a lot of “officially supported hardware” headache for me. And the price is right too 😉

  • Sorry if this has been asked before but since the 8.0.0 is working very good, especially with XO backups, is there any estimation when the final release will be out ?

    br, Pete

  • XCP-ng Team

    The official date is "when it's done" (understand: when we have enough community feedback and we did all our tests).

    But no major block appeared so an RC should come really soon.

    And remember: more community feedback: faster release.

Log in to reply

XCP-ng Pro Support

XCP-ng Pro Support