"Host time and XOA time are not consistent with each other" error after a reboot

  • On this server we are testing XCP-ng 8.0.0. before going to production.

    We have 2 RAIDs on this server: SSD (sda) and SAS (sdb).
    XCP-ng installation (without asking) created a single LVM partition merging both disks.
    We need to have two separated SRs, so (from XOA) we removed the single LVM SR: trying to create the new ones we got errors ("storage is in use").
    We rebooted the server and suddenly appeared in XOA the "Host time and XOA time are not consistent with each other" error.
    Now the server icon is orange and it is not fully manageable.
    Please note that all servers attached to XOA have the same timezone (Europe/Rome) and all date/times are correct (even hwclock is synced with systime).

    Any idea on what caused the issue and how to recover the server status?

  • I assume you are running XO as a VM. Did you check to see that the date/time in this VM is set correctly?

  • I would like to report this as a bug to be honest.

    I have had the same issue on 4 servers running as 2 pools on XCP 8. Never had the problem before. All 4 servers are set to UTC time in the bios, and after the first time I got the message I made sure XO and all 4 XCP installs were set to the correct timezone and double-checked they reported the same time and dates (they did, but not sure if they did prior to thoroughly checking them), and yet on occasion still get the same error.

  • Admin

    Ping @pdonias if he got an idea why could trigger that. I assume we have a "basic" check comparing time, I know if toolstack is restarted we probably got an empty field or something like that. Maybe we could improve some edge case?

  • XO Team

    We compare the time reported by XAPI's method host.get_servertime and Node's Date.now() in XOA and check if they're more than 30 seconds apart. We work with timestamps so the timezones shouldn't matter.

  • Admin

    What if host.get_servertime is empty/null? Are we able to differentiate vs a 30sec+ time diff?

  • XO Team

    If it's not a UTC formatted string, then it will indeed behave as if the 2 dates were more than 30 seconds apart. Is it supposed to happen? We can easily fix that.

  • Admin

    I think we might have cases with something else or an empty result (just after restarting the toolstack?)

    What could have be interesting before searching for those cases: displaying in the tooltip the host time and XOA time, so we can actually see what we are comparing. So people experiencing the bug will be able to report what they are actually seeing.

Log in to reply