first attemp with XOCE



  • it seems that the git diff didn't include a modification I made, maybe the file isn't tracked.

    in file @xen-orchestra/audit-core/node_modules/@babel/helper-compilation-targets/package.json
    I had to modify the exports:

    "exports": {
      ".": "./lib/index.js"
    },
    

    the original was like (not sure):

    "exports": none
    

    but was throwing error during build:

    Error [ERR_PACKAGE_PATH_NOT_EXPORTED]: No "exports" main resolved
    


  • @BenjiReis yes but XOA is using v12.16.1 so I believed the documentation was a little old. I will try to build from scratch with the LTS that is 12.16.1.


  • XCP-ng Team

    @nackstein Please use markdown when quoting code for readability 🙂


  • XCP-ng Team

    It seems you are really angry again JS dev/build system, but you missed the a sentence that's in bold in the documentation 😉 For instance, Node version. Please take time to read the doc carefully before going further, or you'll lose your time 🙂

    edit: our doc should be considered as "source of truth" for your installation

    edit 2: XOA is a bit different, we can provide a coherent solution with the environment, until we decide we are sure with Node 12, we keep the version on 8.



  • @olivierlambert ok thanks for the clarification. I was deliberating exploring new territories. I don't like the build system in javascript but maybe it's useful on windows platform so you don't have to port make and shell script. to me it's a new complicated thing to just execute some command in a pipe. Anyway my post was sarcastic, I don't want to blame anyone.


  • XCP-ng Team

    No worries 😉 Just telling you that following the doc will save you a lot of time!



  • @nackstein said in first attemp with XOCE:

    then as documented I cloned git and tried building with yarn:
    git clone -b master http://github.com/vatesfr/xen-orchestra
    cd xen-orchestra
    yarn build

    Did you issue the yarn command prior to the yarn build? If not, that would explain the missing dependencies.



  • @Danp oh yes, I just forgot to post it here. I'm going to edit my post. thanks.
    I think the broken dependency is due to bcrypt 2.x that come only in 64 npm version and by using a too recent node/npm the build system look for bcrypt 2.x 79 npm version



  • I tried building from scratch and with node 8. I had a couple of build error but building one package by directly entering its directory and relaunching building without --parallel in the main package.json solved my problem. I think the VM I used to build with 2GB RAM is not enough for parallel building (I took the hint from the post about building on FreeBSD).

    now I would like to install on a local directory and not using the git directory to start services. how do you usually do in your development environment?


  • XCP-ng Team

    Exactly like how it's displayed in the documentation.


Log in to reply
 

XCP-ng Pro Support

XCP-ng Pro Support