XCP-ng 8.2.0 beta now available!


  • I just updated using the ISO-method because the yum method didn't boot successfully.
    What would be the best way to migrate from a ZFS file-SR to ZFS-SR? I assume setting the SR type after creation isn't intended and I can't find that in the XAPI docs either.
    Is the cleanest solution to create a new ZFS dataset, ZFS-SR on top and move the virtual drives?

  • XCP-ng Team

    I would have been interested in debugging why the system didn't boot successfully after an update using yum. Can you give us more details?

    To migrate the ZFS SR, the only clean way I am aware of is to create a new one. There may be a hacky way but it would probably involve modifying XAPI database objects dans metadata written in the SR itself so I wouldn't attempt it.

  • XCP-ng Team

    @brezlord said in XCP-ng 8.2.0 beta now available!:

    Could not change pool master from 8.2.0-beta to 8.1.0 host. Get Unknown error from peer.

    When you get such error in XO, there's usually more information in XO's log page. However, it is expected that you can't move the master to a host running a lower release.

    Both host on 8.2.0-beta, shut down host-02 which was not the pool master and the shared storage shows partially connected and no stats available for storage. Reboot host-02 and shared storage is now healthy and stats are back. Disabled host-02 and shutdown and still had the same issue as above. The only was to get stats back and get shares storage back to healthy and stats working is to forget the storage attached to host-02 that was shut down.

    Ok, I don't think it's a regression but it may be interesting to create a GitHub issue with all the details.

    Had to reinstall xscontainer package to have docker container visibility in XO.

    That is expected, unless you upgrade using yum.

    if you need any specific tests just let me know.

    If your host has an nVIDIA GPU, we would be interested in knowing it because there used to be bugs specific to hosts with such a GPU, even when not used.

    And be ready for testing UEFI VMs soon! I'll post here when the updated uefistored package is available.


  • Thanks for the info. So doing a ISO update is essentially like a fresh install but keeps settings.

    I don't have any nVIDIA GPUs, sorry can't help there.

    I'll boot the second host and get more info to raise an issue for the SR problem.



  • And be ready for testing UEFI VMs soon! I'll post here when the updated uefistored package is available.

    Does the host have to be booted in UEFI mode for UEFI VMs to function?

    If it does, is there an easy way to make the change from legacy to UEFI?
    All I know, is the install docs clearly state you should never change mode when upgrading.
    Is the only way to export all the vms, and reinstall, then import the vms back?

  • XCP-ng Team

    @technot said in XCP-ng 8.2.0 beta now available!:

    Does the host have to be booted in UEFI mode for UEFI VMs to function?

    No, it's not related to the host's mode.


  • @stormi
    Is it only lacking to get built/compiled? If so I could do it sometime during the weekend. Or has the code not been updated to reflect any changes done with xcp-ng 8.2. If the latter, I am afraid I cant help.

  • XCP-ng Team

    It's not ready yet so you can't help now. Our developer who wrote that piece of code (uefistored) is chasing the last known bugs and then I'll build an update and push it to our RPM repository for XCP-ng 8.2. I'll announce it when it's ready.


  • I dont know if this is expected behaviour, after upgrading all the way from 7.6 to 8.2 beta. But on a windows guest I have an AMD gpu in full pci passthrough, the device didnt show up after boot. And instead there was another device showing fault.
    Intel 8237sb pci to usb universal host controller, was throwing an error 43.
    And under Display adapters, there was only the microsoft remote emulated and a "Microsoft Basic" devices showing.
    I reinstalled the AMD driver, and rebooted. And it came back to life.

    Also, I must say the vms feel snappier. Faster boots, and less delay/latency. But I have not meassured pre/post, so its only a feeling!:D


  • @stormi
    Im sorry, it wasnt clear. What I meant is XCP-ng Center. If that code has been updated, or just a question of compiling it.

  • XCP-ng Center Team

    @stormi Heyho! I'll try to find some time. But first I'll setup an XCP-ng 8.2 host πŸ™‚

  • XCP-ng Center Team


  • Hi! When will 8.2 be released, and will there be an easy upgrade between 8.1 and 8.2?

    I am currently setting up a new pool of EPYC servers to replace some older Xeon servers and well, I'd like to go on 8.2 right away if it is released soon πŸ™‚


  • @S-Pam Literally the first post has a big bold headline that tells exactly how you go about upgrading by linking to the docs.

    And then in the sixth post from the top Oliver says it’s reasonable to believe the final release will be in 2 months.

  • XCP-ng Team

    And I expect that XCP-ng 8.2.0 will be perfectly stable well before we release it officially. The main missing piece is fixes to UEFI VM support.

  • XCP-ng Team

    I just pushed xcp-ng-pv-tools-8.2.0-1.xcpng8.2.noarch.rpm to the 8.2 base repository. Beta testers can install it with a simple yum update. No reboot required. Please check that :

    • guest tools attached to existing VMs are detached during the update
    • the new guest tools ISO is available for attaching to VMs after the update
    • the updated README.txt looks fine (updated links to the docs, and added a FreeBSD section)
    • tools can be installed to linux and FreeBSD VMs

  • @stormi The new iso worked as usual on a Ubuntu 20.04 VM.
    README text formatting looks fine, updating guest tools using the install.sh worked.
    When done it still asks the user to reboot the VM though.
    Without a working XCP-ng center I'm not sure how to test the guest tools features.

  • XCP-ng Team

    @demanzke with the preferred client for XCP-ng: Xen Orchestra πŸ™‚ You'll have Ubuntu logo and VM IP address πŸ™‚

  • XCP-ng Team

    The new implementation of UEFI support for VMs just landed through the last update to the beta.

    yum update will install uefistored-0.2.1-1.xcpng8.2.x86_64, then a simple xe-toolstack-restart will take it into account.

    Dedicated thread for tests, feedback, debug and discussion: https://xcp-ng.org/forum/post/32335

XCP-ng Pro Support

XCP-ng Pro Support