xoa-updater failing



  • Hi,

    I just installed and configured fresh XOA vm and having troubles to run update on it.

    [13:39 12] xoa@xoa:~$ xoa-updater --upgrade
    stable selected
    New versions available:
      xo-server 5.46.0
      xo-web-free 5.46.0
      xoa-cli 0.14.0
    Downloading packages...
      xo-server ................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................ ok ✔
      xo-web-free .................................................................................................................................................................................................................................................................................................................................................................. ok ✔
      xoa-cli .................................................................................................................................................................................................................... ok ✔
    Installing packages...
      xo-server ✔
    
    ✖ Command failed: npm i -g --unsafe-perm --silent --proxy http://repoproxy01.syspay.com:3128 /tmp/1568295590593/xo-server.tgz
    
    /usr/local/bin/run-vhd-test -> /usr/local/lib/node_modules/xo-server/bin/run-vhd-test
    /usr/local/bin/xo-server -> /usr/local/lib/node_modules/xo-server/bin/xo-server
    /usr/local/bin/xo-server-logs -> /usr/local/lib/node_modules/xo-server/bin/xo-server-logs
    /usr/local/bin/xo-server-recover-account -> /usr/local/lib/node_modules/xo-server/bin/xo-server-recover-account
    [bcrypt] Success: "/usr/local/lib/node_modules/xo-server/node_modules/bcrypt/lib/binding/bcrypt_lib.node" already installed
    Pass --update-binary to reinstall or --build-from-source to recompile
    /usr/local/lib
    └── (empty)
    
    logs:
    Sep 12 13:39:53 xoa xoa-updater[3202]: Installing packages...
    Sep 12 13:39:54 xoa xoa-updater[3202]: [27B blob data]
    Sep 12 13:41:27 xoa xoa-updater[3202]: [27B blob data]
    Sep 12 13:41:27 xoa xoa-updater[3202]: [Thu Sep 12 2019 13:41:27 GMT+0000 (UTC)] ERROR Command failed: npm i -g --unsafe-perm --silent --proxy http://repoproxy01.syspay.com:3128 /tmp/1568295590593/xo-server.tgz
    Sep 12 13:41:27 xoa xoa-updater[3202]: /usr/local/bin/run-vhd-test -> /usr/local/lib/node_modules/xo-server/bin/run-vhd-test
    Sep 12 13:41:27 xoa xoa-updater[3202]: /usr/local/bin/xo-server -> /usr/local/lib/node_modules/xo-server/bin/xo-server
    Sep 12 13:41:27 xoa xoa-updater[3202]: /usr/local/bin/xo-server-logs -> /usr/local/lib/node_modules/xo-server/bin/xo-server-logs
    Sep 12 13:41:27 xoa xoa-updater[3202]: /usr/local/bin/xo-server-recover-account -> /usr/local/lib/node_modules/xo-server/bin/xo-server-recover-account
    Sep 12 13:41:27 xoa xoa-updater[3202]: [bcrypt] Success: "/usr/local/lib/node_modules/xo-server/node_modules/bcrypt/lib/binding/bcrypt_lib.node" already installed
    Sep 12 13:41:27 xoa xoa-updater[3202]: Pass --update-binary to reinstall or --build-from-source to recompile
    Sep 12 13:41:27 xoa xoa-updater[3202]: /usr/local/lib
    Sep 12 13:41:27 xoa xoa-updater[3202]: └── (empty)
    

  • Admin

    Do you have a proxy that intercepts SSL?



  • yes

    is this the problem ?

    1568295590.772     71 10.99.4.23 TCP_TUNNEL/200 3883 CONNECT xen-orchestra.com:443 - HIER_DIRECT/212.83.180.141 -
    1568295592.356   1576 10.99.4.23 TCP_TUNNEL/200 14844401 CONNECT xen-orchestra.com:443 - HIER_DIRECT/212.83.180.141 -
    1568295593.247    799 10.99.4.23 TCP_TUNNEL/200 5670500 CONNECT xen-orchestra.com:443 - HIER_DIRECT/212.83.180.141 -
    1568295593.699    394 10.99.4.23 TCP_TUNNEL/200 3335409 CONNECT xen-orchestra.com:443 - HIER_DIRECT/212.83.180.141 -
    1568295663.435      0 10.99.4.23 TCP_DENIED/403 2069 CONNECT nodejs.org:443 - HIER_NONE/- text/html
    1568295664.079      0 10.99.4.23 TCP_DENIED/403 2011 CONNECT github.com:443 - HIER_NONE/- text/html
    1568295664.542      0 10.99.4.23 TCP_DENIED/403 2069 CONNECT nodejs.org:443 - HIER_NONE/- text/html
    

  • Admin

    Please see https://xen-orchestra.com/docs/troubleshooting.html#behind-a-transparent-proxy

    If it's still a problem, please report or ideally open a support ticket so we can take a look remotely 🙂

    Also quick ping to @julien-f while he's around 😉


  • XO Team

    @psutty I don't see anything obvious, as @olivierlambert said, please open a support ticket for more advanced support.



  • is it the updater who is trying to reach nodejs.org and github.com 443 ?
    1568296381.804 0 10.99.4.23 TCP_DENIED/403 2069 CONNECT nodejs.org:443 - HIER_NONE/- text/html
    1568296382.483 0 10.99.4.23 TCP_DENIED/403 2011 CONNECT github.com:443 - HIER_NONE/- text/html
    1568296382.942 0 10.99.4.23 TCP_DENIED/403 2069 CONNECT nodejs.org:443 - HIER_NONE/- text/html




  • Admin

    IIRC we have something in the pipes to solve this, but not yet. Please open a support ticket so we can continue discuss with more details related to your infrastructure 🙂


Log in to reply
 

XCP-ng Pro Support