Categories

  • All news regarding Xen and XCP-ng ecosystem

    145 Topics
    5k Posts
    A
    @gleh Up and running on busy pools. Rolling pool reboot worked correctly.
  • Everything related to the virtualization platform

    1k Topics
    15k Posts
    O
    @dinhngtu rpm -qa | grep xapi xapi-rrd2csv-26.1.19-1.1.xcpng8.3.x86_64 xapi-core-26.1.19-1.1.xcpng8.3.x86_64 xapi-tests-26.1.19-1.1.xcpng8.3.x86_64 python2-xapi-storage-24.19.2-1.10.xcpng8.3.x86_64 xapi-nbd-26.1.19-1.1.xcpng8.3.x86_64 xapi-xe-26.1.19-1.1.xcpng8.3.x86_64 xcp-ng-xapi-plugins-1.17.0-1.xcpng8.3.noarch xapi-storage-script-26.1.19-1.1.xcpng8.3.x86_64 But now i can't connect to ther server after downgraded the packages and updating from testing. Oct 3 16:28:15 xcp-ng-akz xapi-init[35439]: Stopping xapi: xapi stopped successfully Oct 3 16:28:15 xcp-ng-akz systemd[1]: Unit xapi.service entered failed state. Oct 3 16:28:15 xcp-ng-akz systemd[1]: xapi.service failed. Oct 3 16:28:16 xcp-ng-akz systemd[1]: xapi.service holdoff time over, scheduling restart. Oct 3 16:28:16 xcp-ng-akz systemd[1]: Cannot add dependency job for unit lvm2-activation.service, ignoring: Unit is masked. Oct 3 16:28:16 xcp-ng-akz systemd[1]: Cannot add dependency job for unit lvm2-activation-early.service, ignoring: Unit is masked. Oct 3 16:28:16 xcp-ng-akz systemd[1]: Starting XenAPI server (XAPI)... Oct 3 16:28:16 xcp-ng-akz systemd[1]: Started XenAPI server (XAPI). Oct 3 16:28:16 xcp-ng-akz xapi-init[35451]: Starting xapi: Oct 3 16:28:17 xcp-ng-akz message-switch[983]: main: [ info|message-switch] Session xapi:34278 cleaning up Oct 3 16:28:17 xcp-ng-akz xapi-nbd[24597]: main: Failed to log in via xapi's Unix domain socket: Unix.Unix_error(Unix.ECONNREFUSED, "connect", ""); retrying in 4.000000 seconds Oct 3 16:28:19 xcp-ng-akz systemd[1]: xapi.service: main process exited, code=exited, status=2/INVALIDARGUMENT Oct 3 16:28:19 xcp-ng-akz xapi-init[35588]: Stopping xapi: xapi stopped successfully Oct 3 16:28:19 xcp-ng-akz systemd[1]: Unit xapi.service entered failed state. Oct 3 16:28:19 xcp-ng-akz systemd[1]: xapi.service failed. Oct 3 16:28:20 xcp-ng-akz systemd[1]: xapi.service holdoff time over, scheduling restart. Oct 3 16:28:20 xcp-ng-akz systemd[1]: Cannot add dependency job for unit lvm2-activation.service, ignoring: Unit is masked. Oct 3 16:28:20 xcp-ng-akz systemd[1]: Cannot add dependency job for unit lvm2-activation-early.service, ignoring: Unit is masked. Oct 3 16:28:20 xcp-ng-akz systemd[1]: Starting XenAPI server (XAPI)... Oct 3 16:28:20 xcp-ng-akz systemd[1]: Started XenAPI server (XAPI). Oct 3 16:28:20 xcp-ng-akz xapi-init[35600]: Starting xapi:
  • 3k Topics
    29k Posts
    johnnezeroJ
    @pierrebrunet Thanks for the update. So is there any way to run the reclaimSpace function (i.e from the XO CLI or something, without having to build a whole REST API application or whatever that involves)?
  • Our hyperconverged storage solution

    54 Topics
    824 Posts
    J
    @poddingue Turns out it is all secondary-to-secondary out of sync. So that makes it less intense, though if primary dies I wonder how it will resolve this, or if it will become split brained. Still unsure of how it happened, but the ones I manually cleaned up have not come back. Going to continue to manually clear them up. If it happens again I will have an alert setup to notify me, and I have all the xcp-ng logs and everything to be able to see what happened. If that happens I will post here with details and logs for the resource so we can see how it occurs. [image: image.jpeg]
  • 37 Topics
    136 Posts
    J
    @AtaxyaNetwork Merci pour tes recherches ! Oui "cd_label" serait cool comme ajout au plugin ce qui permet sur les distro type Fedora/Redhat de ne pas avoir de boot_command à gérer