XCP-ng
    • Categories
    • Recent
    • Tags
    • Popular
    • Users
    • Groups
    • Register
    • Login

    Backup fails with "Body Timeout Error", "all targets have failed, step: writer.run()"

    Scheduled Pinned Locked Moved Solved Backup
    114 Posts 21 Posters 20.5k Views 22 Watching
    Loading More Posts
    • Oldest to Newest
    • Newest to Oldest
    • Most Votes
    Reply
    • Reply as topic
    Log in to reply
    This topic has been deleted. Only users with topic management privileges can see it.
    • J
      JB @christopher-petzel
      last edited by

      @christopher-petzel Olá Chris!
      Yes, this is a local XCP-ng management network and there are no other backups simultaneous.

      1 Reply Last reply
      Reply Quote 0
      • J
        JB @poddingue
        last edited by

        @poddingue Olá! The failure has a fixed duration of 5 minutes.

        1 Reply Last reply
        Reply Quote 0
        • acebmxerA
          acebmxer
          last edited by acebmxer

          Just got a failure today but with a different pool.

              "message": "backup task failed with undefined error",
              "name": "Error",
              "stack": "Error: backup task failed with undefined error\n    at forwardResult (file:///usr/local/lib/node_modules/xo-server/src/_handleBackupLog.mjs:37:25)\n    at handleBackupLog (file:///usr/local/lib/node_modules/xo-server/src/_handleBackupLog.mjs:68:12)\n    at onTaskUpdate (file:///usr/local/lib/node_modules/xo-server/src/xo-mixins/metadata-backups.mjs:117:13)\n    at onTaskUpdate (file:///usr/local/lib/node_modules/xo-server/node_modules/@xen-orchestra/mixins/Tasks.mjs:205:23)\n    at onLogFct (/usr/local/lib/node_modules/xo-server/node_modules/@vates/task/combineEvents.js:61:5)\n    at metadataBackup._executor (file:///usr/local/lib/node_modules/xo-server/src/xo-mixins/metadata-backups.mjs:122:11)\n    at Jobs.runJob (file:///usr/local/lib/node_modules/xo-server/src/xo-mixins/jobs/index.mjs:297:7)\n    at file:///usr/local/lib/node_modules/xo-server/src/api/schedule.mjs:84:9\n    at Task.runInside (/usr/local/lib/node_modules/xo-server/node_modules/@vates/task/index.js:204:22)\n    at Task.run (/usr/local/lib/node_modules/xo-server/node_modules/@vates/task/index.js:188:20)\n    at Xo.runSequence (file:///usr/local/lib/node_modules/xo-server/src/api/schedule.mjs:73:3)\n    at Task.runInside (/usr/local/lib/node_modules/xo-server/node_modules/@vates/task/index.js:204:22)\n    at Task.run (/usr/local/lib/node_modules/xo-server/node_modules/@vates/task/index.js:188:20)\n    at Api.#callApiMethod (file:///usr/local/lib/node_modules/xo-server/src/xo-mixins/api.mjs:475:18)"
            }
          }
          

          Screenshot_20260803_212536.png

          1 Reply Last reply
          Reply Quote 0
          • J
            JB
            last edited by

            Every day I update XO-CE hoping this error gets fixed, but so far, no solution!

            1 Reply Last reply
            Reply Quote 0
            • olivierlambertO
              olivierlambert Vates 🪐 Co-Founder CEO
              last edited by

              Is there a way in private message to give access to the XCP-ng host and XO VM in question OR to get all logs from 2 machines somewhere? 5min is clearly a timeout error.

              acebmxerA J 2 Replies Last reply
              Reply Quote 0
              • acebmxerA
                acebmxer @olivierlambert
                last edited by

                @olivierlambert

                Mine has not done it since last post but i have opened a support ticket along with tunnel being opened - Ticket#7762089

                1 Reply Last reply
                Reply Quote 1
                • J
                  JB @olivierlambert
                  last edited by

                  @olivierlambert Yes, I can grant it.

                  olivierlambertO 1 Reply Last reply
                  Reply Quote 0
                  • marcoiM
                    marcoi
                    last edited by

                    looks like mine also just started working.
                    9093a86c-0ec3-48b8-ab41-236e86cf37f8-image.jpeg

                    J 1 Reply Last reply
                    Reply Quote 0
                    • J
                      JB
                      last edited by

                      6123a044-a5bd-4816-b937-6a096b26bc0a-image.jpeg

                      Master, commit be960

                      1 Reply Last reply
                      Reply Quote 0
                      • olivierlambertO
                        olivierlambert Vates 🪐 Co-Founder CEO @JB
                        last edited by

                        @JB I'd like to test a different way of investigating the problem. So I won't do it for many people, just send me a private message with a way to SSH to your host and XOA, promise it's not a scam 😆

                        1 Reply Last reply
                        Reply Quote 0
                        • J
                          JB @marcoi
                          last edited by

                          @marcoi Try doing it three times, and the problem comes back.

                          marcoiM 1 Reply Last reply
                          Reply Quote 0
                          • marcoiM
                            marcoi @JB
                            last edited by

                            @JB seems okay after a few back to back runs.
                            bd76af32-4767-42fe-b956-6270fde29325-image.jpeg

                            J 2 Replies Last reply
                            Reply Quote 0
                            • J
                              JB @marcoi
                              last edited by

                              @marcoi Does your backup include METADATA and XO CONFIG?

                              marcoiM 1 Reply Last reply
                              Reply Quote 0
                              • marcoiM
                                marcoi @JB
                                last edited by marcoi

                                @JB both
                                Also Xen Orchestra, commit be960

                                ab69a1e2-43cd-4491-8a2f-b48765886b8c-image.jpeg

                                J 2 Replies Last reply
                                Reply Quote 0
                                • J
                                  JB @marcoi
                                  last edited by

                                  @marcoi The problem is with the METADATA backup. XO Config is working fine!

                                  1 Reply Last reply
                                  Reply Quote 0
                                  • J
                                    JB @marcoi
                                    last edited by

                                    @marcoi So the problem is with my infrastructure.

                                    1 Reply Last reply
                                    Reply Quote 0
                                    • J
                                      JB @marcoi
                                      last edited by

                                      @marcoi I see that you use NFS to store the backup. I use SMB.

                                      1 Reply Last reply
                                      Reply Quote 0
                                      • J
                                        JB
                                        last edited by

                                        This post is deleted!
                                        1 Reply Last reply
                                        Reply Quote 0
                                        • J
                                          JB
                                          last edited by

                                          070b68c3-bcf2-40ca-8667-ad41a9dd6f42-image.jpeg

                                          1 Reply Last reply
                                          Reply Quote 0
                                          • marcoiM
                                            marcoi
                                            last edited by marcoi

                                            i switched one of the backups for my extra pool from nfs to smb and its been sitting so i expect it to fail. might be a smb issue. ill update this post with results once it either fails or works

                                            2d4d9b1d-9aa5-4f1d-a1c1-d8ea5e079047-image.jpeg

                                            i did test smb and it works.

                                            back to nfs works
                                            b2b807b8-d422-4719-8088-817b08d3c5ad-image.jpeg

                                            1 Reply Last reply
                                            Reply Quote 0

                                            Hello! It looks like you're interested in this conversation, but you don't have an account yet.

                                            Getting fed up of having to scroll through the same posts each visit? When you register for an account, you'll always come back to exactly where you were before, and choose to be notified of new replies (either via email, or push notification). You'll also be able to save bookmarks and upvote posts to show your appreciation to other community members.

                                            With your input, this post could be even better 💗

                                            Register Login
                                            • First post
                                              Last post