XCP-ng
    • Categories
    • Recent
    • Tags
    • Popular
    • Users
    • Groups
    • Register
    • Login

    CBT: the thread to centralize your feedback

    Scheduled Pinned Locked Moved Backup
    456 Posts 38 Posters 863.7k Views 30 Watching
    Loading More Posts
    • Oldest to Newest
    • Newest to Oldest
    • Most Votes
    Reply
    • Reply as topic
    Log in to reply
    This topic has been deleted. Only users with topic management privileges can see it.
    • M
      manilx @manilx
      last edited by

      @manilx restart toolstack did it. Thx for pointing this out 🙂

      1 Reply Last reply
      Reply Quote 0
      • olivierlambertO
        olivierlambert Vates 🪐 Co-Founder CEO @rtjdamen
        last edited by

        @rtjdamen That was a big sprint 🌶

        R A 2 Replies Last reply
        Reply Quote 0
        • R
          rtjdamen @olivierlambert
          last edited by

          @olivierlambert indeed but the first version is here!

          I allready noticed some strange behavior, when a backup job is running with both switches on (cbt and data destroy), the first run the job processes succesfull but some snapshots stay orphan after the job is finished and coalesced. @florent any idea what is causing this?

          1 Reply Last reply
          Reply Quote 0
          • A
            Andrew Top contributor @olivierlambert
            last edited by

            @olivierlambert With today's update (feat: release 5.96.0, master 96b7673) things are working well again. I have not seen any Orphan VDI/snapshots or stuck Control Domain VDIs (but it may take time to test). Thanks to the Vates team!

            R 1 Reply Last reply
            Reply Quote 1
            • R
              rtjdamen @Andrew
              last edited by

              @Andrew need to do some more testing but second run does clean them out, keep u all posted on the results over the weekend!

              1 Reply Last reply
              Reply Quote 1
              • R
                rtjdamen
                last edited by

                I did some digging on this orphan snapshots. i found this error in the backup logging for these vms

                Couldn't deleted snapshot data
                error
                {"code":"VDI_IN_USE","params":["OpaqueRef:d52c23f7-4008-45e0-9852-6ecb3aeb8567","data_destroy"],"call":{"method":"VDI.data_destroy","params":["OpaqueRef:d52c23f7-4008-45e0-9852-6ecb3aeb8567"]}}
                vdiRef
                "OpaqueRef:d52c23f7-4008-45e0-9852-6ecb3aeb8567"

                i do not see them currently on normal vms and also not on second run

                R 1 Reply Last reply
                Reply Quote 0
                • ajpri1998A
                  ajpri1998
                  last edited by

                  It worked just fine for me during an overnight unattended backup. I also did a manual backup to watch things.

                  Couple questions:

                  1. If NBD is used, is there a 100% chance that CBT will also be used, or is it possible to have a NBD backup without CBT?
                  2. Can it be added to the xo-server-backup-reports emails that NBD/CBT was used?
                  R 2 Replies Last reply
                  Reply Quote 0
                  • R
                    rtjdamen @ajpri1998
                    last edited by

                    This post is deleted!
                    1 Reply Last reply
                    Reply Quote 0
                    • R
                      rtjdamen @rtjdamen
                      last edited by

                      It seems the orphan vdi is showing when the data_destoy fails, maybe the vdi is not yet ready? @florent Is this something you can look into? Maybe a retry when it fails?

                      1 Reply Last reply
                      Reply Quote 0
                      • Tristis OrisT
                        Tristis Oris Top contributor
                        last edited by

                        most of backup succed, but few suddenly looks like:
                        e989fcc0-d760-4600-a2c6-4b57ea932a43-image.png

                        1 Reply Last reply
                        Reply Quote 0
                        • R
                          rtjdamen @ajpri1998
                          last edited by

                          @ajpri1998

                          From what i have seen if CBT fails for some reason, the chain is broken or the metadata is missing it will fall back on single NDB, most likely a new full.

                          1 Reply Last reply
                          Reply Quote 0
                          • P
                            probain
                            last edited by probain

                            Enabling the new Purge snapshot data when using CBT on Delta backups
                            results in

                            cleanVm: incorrect backup size in metadata. But it seems to be successful anyway.
                            Update: I'm getting this regardless of what "Purge snapshot data when using CBT" is set to. So I'm right now not sure about what causes it.

                            XOsource: commit 96b76. ?
                            fa80f49d-545c-457c-932c-460a057a0961-image.png

                            1 Reply Last reply
                            Reply Quote 0
                            • Tristis OrisT
                              Tristis Oris Top contributor
                              last edited by Tristis Oris

                              [NOBAK] tag is ignored with CBT patch.
                              126572d0-3637-48bf-9590-2f2ff62f677c-image.png

                              before update it works fine. no 2nd disk available for restore.
                              28f3a0ba-3bda-4d5f-ac2a-00001b0ef790-image.png

                              my share is run out of space)
                              de125045-6bd6-480c-8018-292e25ca8b45-image.png

                              Tristis OrisT 1 Reply Last reply
                              Reply Quote 0
                              • Tristis OrisT
                                Tristis Oris Top contributor @Tristis Oris
                                last edited by

                                @Tristis-Oris is it any way to remove only 1 disk backup chain, to not wait rotation? i can't just clear everything.

                                1 Reply Last reply
                                Reply Quote 0
                                • olivierlambertO
                                  olivierlambert Vates 🪐 Co-Founder CEO
                                  last edited by

                                  @ajpri1998 IIRC:

                                  1. CBT will be enabled as soon you use NBD, no other choice (having 2 different code paths was too prone to problems and bugs, without forgetting the initial VHD diff code)
                                  2. Sure, we can do that! Telling @Bastien-Nollet about it 🙂
                                  1 Reply Last reply
                                  Reply Quote 1
                                  • D
                                    Delgado
                                    last edited by

                                    I started seeing this error this afternoon.
                                    Screenshot 2024-07-07 162333.png

                                    The failed job also happened to run after a monthly backup job that I have setup that does a full backup to some immutable storage that I have but I am not sure if it is related I just wanted to add that information. Below is the log from the failed backup.
                                    2024-07-07T11_00_11.127Z - backup NG.json.txt

                                    A 1 Reply Last reply
                                    Reply Quote 0
                                    • A
                                      Andrew Top contributor @Delgado
                                      last edited by

                                      @Delgado I saw those errors when I disabled/enabled CBT on disks or changed the NBD+CBT option in the backup job. If you have more than one job that works on the same VM you need to have the backup options the same.

                                      I think that migrating the VDI to a different SR also changes the CBT setting.

                                      D 1 Reply Last reply
                                      Reply Quote 0
                                      • D
                                        Delgado @Andrew
                                        last edited by

                                        @Andrew Thanks for the info! I had a feeling it may have been that one normal backup mode I ran. I'll stick to the deltas.

                                        A 1 Reply Last reply
                                        Reply Quote 0
                                        • A
                                          Andrew Top contributor @olivierlambert
                                          last edited by

                                          @olivierlambert Having a strange failure now (XO and XOA the same). I'm trying to migrate a VDI (only) to a new SR (same pool) after it has been backed up with CBT enabled. The VM is off (cold). XO disables CBT and requests the migration but the migrate fails and it tries again repeatedly endlessly. If I delete the snapshots then it moves.

                                          R 1 Reply Last reply
                                          Reply Quote 0
                                          • A
                                            Andrew Top contributor @Delgado
                                            last edited by

                                            @Delgado Full/CR/Delta backups should work as long as CBT is left enabled on the guest VDI and other backup jobs don't disable it.

                                            D 1 Reply Last reply
                                            Reply Quote 0

                                            Hello! It looks like you're interested in this conversation, but you don't have an account yet.

                                            Getting fed up of having to scroll through the same posts each visit? When you register for an account, you'll always come back to exactly where you were before, and choose to be notified of new replies (either via email, or push notification). You'll also be able to save bookmarks and upvote posts to show your appreciation to other community members.

                                            With your input, this post could be even better 💗

                                            Register Login
                                            • First post
                                              Last post