Installed on 3xDell PowerEdge R350 in HA. And so far, I haven't noticed anything out of the ordinary.
-
RE: XCP-ng 8.3 updates announcements and testing
-
RE: Building from source, now introduces local changes in typed-router.d.ts?
I noticed you merged https://github.com/vatesfr/xen-orchestra/pull/9787
I just tried it. And it does seem to fix my original issue!
Thank you! I am always impressed by you guys. Making testing and reporting upstream (to you guys) a good experience!
-
RE: Backblaze as Remote error Unsupported header 'x-amz-checksum-mode' received for this API call.
I submitted this as a GitHub issue last week.
TL;DR: Backblaze aparently doesn't support those flags that are enabled by default
"Backblaze does not yet accept these headers, so we recommend downgrading to AWS Javascript 3.x SDK version 3.728.0." -
RE: Enable Maintenance Mode = Host Not Enough Memory
@poddingue
Our HA-pool is a 3 host system, yes.I'll add a note about our plans to go paid in that feedback-item. Thanks for the tip.
In the meantime, I'm testing and reporting as much as I can. In order to hopefully help the product be better for all.Cheers!
-
RE: Enable Maintenance Mode = Host Not Enough Memory
Huh.. Good catch.
I set all of the VMs torestart, and now it does make maintenance mode possible, on the host.However, when we go into licensed/paid production (soon tm). It would be an absolute nightmare to try and find one VM that might not be on the right HA-plan... And it does kind of feel that Maintenance-mode should be compatible with whatever HA-plan is chosen regardless.
Perhaps there could be a way to assign a global/pool-wide HA-plan along with enabling HA alltogether?
Update: Shining light on that there is already a feedback-item, wishing for this kind of mass-operation for HA.
https://feedback.vates.tech/posts/45/bulk-operation-for-setting-vm-ha-option -
RE: [Solved] SR_SOURCE_SPACE_INSUFFICIENT - Problems enabling HA
Thanks again for your input and recomendations! I'll verify that this is solved by having the LUN expanded to 8GB instead. Afterwards I'll mark your answer as the solution!
-
RE: Rolling Snapshot not cleaning up old snapshots, regardless of retention is set to.
@olivierlambert
I've finally had time to sit down and do some more troubleshooting.
It seems that the issue is somehow tied to the backup-jobs themselves.
Deploying XOA and subsequently importing XO-config from my XOCE instance. I continued to see several issues between both instances.
These issues pretty much went away, when I re-did the backup-jobs from scratch. And are now much more in-line with what I'm excepting to see. This was done on both XOA Stable, Latest and XOCEI am no longer able to repoduce this at all.
So my guess is that a bug of some sort got introduced with this being a constantly updated from source instance.Marking as solved. As I don't believe there is much more to do at this time.
-
RE: VM vCPU allocation
@McHenry
Differences could be things such as:- Amount of cores between hosts for migrations
- Guarantee performance between guests. So that they don't affect each other as much.
Same with overprovisioning dynamic RAM
-
RE: [V2V] Without VDDK problems
Thanks for a fantasticly quick answer, and detailed as well. I will test this immediately!
Update:
I can confirm that this was indeed the problem! -
RE: V2V migrated VMs don't autostart
Thanks for taking a look.
Yes it is this part that tells me that it should start the VM automatically once the import has completed.
"After the transfer, the VM on XCP-ng side is started:"
Followed by, "This process is fully automated, without any human intervention after it starts on step 1."

https://docs.xcp-ng.org/installation/migrate-to-xcp-ng/But my findings/experience is that the VM does not start once the import/transfer has completed.
So either the docs are wrong. Or the function is not behaving as intended. I'm acctually fine either way. As long as I know what to expect. However, I would like to have it auto-start the VMs after transfer completion. Which would make the procedure "Fully automated".
Update:
Am I assuming correctly that "the XO V2V guide says to start the VM yourself once the migration is complete " you're reffering to, is part of the "test migration"-procedure? Not the acctual production mgiration?
Because:"Final migration Run the production migration When you're ready for the final migration: Shut down the source VM completely. Start the V2V migration in Xen Orchestra with the Stop source option enabled. This ensures the final sync happens while the VM is powered off, and prevents any inconsistencies."In my mind doesn't state that the VM should be started manually post-transfer.
Great thanks in advance for discussing!
Cheers!
-
RE: [V2V] Without VDDK problems
Thanks for a fantasticly quick answer, and detailed as well. I will test this immediately!
Update:
I can confirm that this was indeed the problem! -
RE: [V2V] Without VDDK problems
Looking into
journcelctlon the XO-server, after I enabled CBT-tracking on the VM (using this KB from Broadcom https://knowledge.broadcom.com/external/article/315370/enabling-or-disabling-changed-block-trac.html). I get the following:The initial V2V-snapshot on vmware is created as expected. So there is communication between XO and vmware (vcenter-host)
Oct 02 13:24:33 hostname-xo-server xo-server[55639]: 2026-10-02T11:24:33.361Z xo:vmware-explorer:esxi INFO got the data map from the change tracking of the host { Oct 02 13:24:33 hostname-xo-server xo-server[55639]: blocks: 16, Oct 02 13:24:33 hostname-xo-server xo-server[55639]: bytes: 20912799744, Oct 02 13:24:33 hostname-xo-server xo-server[55639]: diskPath: 'vm-name_1/vm-name.vmdk', Oct 02 13:24:33 hostname-xo-server xo-server[55639]: full: true, Oct 02 13:24:33 hostname-xo-server xo-server[55639]: seconds: 0, Oct 02 13:24:33 hostname-xo-server xo-server[55639]: vmId: 'vm-1169935' Oct 02 13:24:33 hostname-xo-server xo-server[55639]: } Oct 02 13:24:44 hostname-xo-server xo-server[55639]: 2026-10-02T11:24:44.496Z vates:nbd-client:stdio WARN the nbd server process exited unexpectedly { Oct 02 13:24:44 hostname-xo-server xo-server[55639]: error: Error: the nbd server process exited (code: 1, signal: null) Oct 02 13:24:44 hostname-xo-server xo-server[55639]: at ChildProcess.<anonymous> (file:///opt/xen-orchestra/@vates/nbd-client/NbdStdioClient.mjs:107:21) Oct 02 13:24:44 hostname-xo-server xo-server[55639]: at ChildProcess.wrapper (node:events:639:12) Oct 02 13:24:44 hostname-xo-server xo-server[55639]: at ChildProcess.emit (node:events:514:28) Oct 02 13:24:44 hostname-xo-server xo-server[55639]: at ChildProcess.patchedEmit [as emit] (/opt/xen-orchestra/@xen-orchestra/log/configure.js:52:17) Oct 02 13:24:44 hostname-xo-server xo-server[55639]: at Process.ChildProcess._handle.onexit (node:internal/child_process:295:12) { Oct 02 13:24:44 hostname-xo-server xo-server[55639]: code: 'NBD_SERVER_EXITED', Oct 02 13:24:44 hostname-xo-server xo-server[55639]: exitCode: 1, Oct 02 13:24:44 hostname-xo-server xo-server[55639]: signal: null, Oct 02 13:24:44 hostname-xo-server xo-server[55639]: command: '/opt/xen-orchestra/@xen-orchestra/vmware-explorer/vectura/vectura', Oct 02 13:24:44 hostname-xo-server xo-server[55639]: stderr: 'vectura: data plane: could not connect: timed out\n' Oct 02 13:24:44 hostname-xo-server xo-server[55639]: } Oct 02 13:24:44 hostname-xo-server xo-server[55639]: } Oct 02 13:24:44 hostname-xo-server xo-server[55639]: 2026-10-02T11:24:44.526Z xo:api WARN username-1 | vm.importMultipleFromEsxi(...) [17s] =!> Error: stream has ended without data, was looking for 8 bytes -
[V2V] Without VDDK problems
First of all. Thanks for putting alot of effort into getting migrations to work without VDDK. https://github.com/vatesfr/xen-orchestra/pull/10421
However. I did a new provisioning of an XO-source instance. And wanted to test it without any hanging dependencies from previously installed vddk's.
Now I'm getting met with failed import-attempts.
Attempts with my previous XO instance, on the same commit: b59c8 works just fine. Except the VMs not starting automatically after import (discussed in separate thread: https://xcp-ng.org/forum/post/108686)
vm.importMultipleFromEsxi { "concurrency": 2, "host": "vcenter-host", "network": "72471fb1-58fd-d2d1-9a1e-46aea05374b4", "password": "* obfuscated *", "sr": "4d58d7f1-087a-bc7b-a957-e8f8be8b1f77", "sslVerify": false, "stopOnError": true, "stopSource": true, "template": "37e7a3b9-8c45-c7f2-7d09-249a935dd33d-1a647cf9-99c1-4e9c-b3b4-6b9989c530be", "user": "obfuscated", "vms": [ "vm-1169935" ] } { "succeeded": {}, "message": "stream has ended without data, was looking for 8 bytes", "name": "Error", "stack": "Error: stream has ended without data, was looking for 8 bytes at readChunkStrict (/opt/xen-orchestra/@vates/read-chunk/index.js:83:13)" } ´´´ -
RE: XCP-ng 8.3 updates announcements and testing
Installed on 3xDell PowerEdge R350 in HA. And so far, I haven't noticed anything out of the ordinary.
-
RE: Enable Maintenance Mode = Host Not Enough Memory
@poddingue
Our HA-pool is a 3 host system, yes.I'll add a note about our plans to go paid in that feedback-item. Thanks for the tip.
In the meantime, I'm testing and reporting as much as I can. In order to hopefully help the product be better for all.Cheers!
-
RE: Enable Maintenance Mode = Host Not Enough Memory
Huh.. Good catch.
I set all of the VMs torestart, and now it does make maintenance mode possible, on the host.However, when we go into licensed/paid production (soon tm). It would be an absolute nightmare to try and find one VM that might not be on the right HA-plan... And it does kind of feel that Maintenance-mode should be compatible with whatever HA-plan is chosen regardless.
Perhaps there could be a way to assign a global/pool-wide HA-plan along with enabling HA alltogether?
Update: Shining light on that there is already a feedback-item, wishing for this kind of mass-operation for HA.
https://feedback.vates.tech/posts/45/bulk-operation-for-setting-vm-ha-option -
Enable Maintenance Mode = Host Not Enough Memory
Doing some more testing, where I wished to place one Host in maintenance mode. I was then met with
HOST_NOT_ENOUGH_FREE_MEMORY.
The pool is a 3 host pool in HA, with load balancing enabled.My guess is that when trying to enable Maintenance mode. It tries to migrate ALL VMs on that host, to ONE single Host on the receiving end. And then it exhausts the amount of available memory.
What I had to do, was manually disable load balancing. And manually migrate VMs to the two other hosts, to distribute them. This worked.
What I expected to have happened:
The evacuation of the host going into Maintenance mode, would be distributing the VMs in a smarter fashion. So that their workload would fit in the pooled resources available.Commit: 2f846
XCP-NG: Fully updated as of writinghost.setMaintenanceMode { "id": "<obfuscated>", "maintenance": true } { "code": "HOST_NOT_ENOUGH_FREE_MEMORY", "params": [ "OpaqueRef:<obfuscated>" ], "task": { "uuid": "c3a83a2d-003d-ac0f-48b8-79a905c9e557", "name_label": "Async.host.evacuate", "name_description": "", "allowed_operations": [], "current_operations": {}, "created": "20260929T07:46:40Z", "finished": "20260929T07:46:40Z", "status": "failure", "resident_on": "OpaqueRef:<obfuscated>", "progress": 1, "type": "<none/>", "result": "", "error_info": [ "HOST_NOT_ENOUGH_FREE_MEMORY", "OpaqueRef:<obfuscated>" ], "other_config": {}, "subtask_of": "OpaqueRef:NULL", "subtasks": [], "backtrace": "(((process xapi)(filename ocaml/xapi/xapi_host.ml)(line 629))((process xapi)(filename hashtbl.ml)(line 159))((process xapi)(filename hashtbl.ml)(line 165))((process xapi)(filename hashtbl.ml)(line 170))((process xapi)(filename ocaml/xapi/xapi_host.ml)(line 625))((process xapi)(filename ocaml/libs/xapi-stdext/lib/xapi-stdext-pervasives/pervasiveext.ml)(line 24))((process xapi)(filename ocaml/libs/xapi-stdext/lib/xapi-stdext-pervasives/pervasiveext.ml)(line 39))((process xapi)(filename ocaml/xapi/rbac.ml)(line 228))((process xapi)(filename ocaml/xapi/rbac.ml)(line 238))((process xapi)(filename ocaml/xapi/server_helpers.ml)(line 78)))" }, "message": "HOST_NOT_ENOUGH_FREE_MEMORY(OpaqueRef:<obfuscated>)", "name": "XapiError", "stack": "XapiError: HOST_NOT_ENOUGH_FREE_MEMORY(OpaqueRef:<obfuscated>) at XapiError.wrap (file:///opt/xen-orchestra/packages/xen-api/_XapiError.mjs:16:12) at default (file:///opt/xen-orchestra/packages/xen-api/_getTaskResult.mjs:13:29) at Xapi._addRecordToCache (file:///opt/xen-orchestra/packages/xen-api/index.mjs:1358:24) at file:///opt/xen-orchestra/packages/xen-api/index.mjs:1392:14 at Array.forEach (<anonymous>) at Xapi._processEvents (file:///opt/xen-orchestra/packages/xen-api/index.mjs:1382:12) at Xapi._watchEvents (file:///opt/xen-orchestra/packages/xen-api/index.mjs:1589:14)" }Update: Edited title, since it would suggest Load Balancing was the problem. It isn't. It's the assignment of migration target(s) that is the issue (imho)
-
RE: V2V migrated VMs don't autostart
Thanks for taking a look.
Yes it is this part that tells me that it should start the VM automatically once the import has completed.
"After the transfer, the VM on XCP-ng side is started:"
Followed by, "This process is fully automated, without any human intervention after it starts on step 1."

https://docs.xcp-ng.org/installation/migrate-to-xcp-ng/But my findings/experience is that the VM does not start once the import/transfer has completed.
So either the docs are wrong. Or the function is not behaving as intended. I'm acctually fine either way. As long as I know what to expect. However, I would like to have it auto-start the VMs after transfer completion. Which would make the procedure "Fully automated".
Update:
Am I assuming correctly that "the XO V2V guide says to start the VM yourself once the migration is complete " you're reffering to, is part of the "test migration"-procedure? Not the acctual production mgiration?
Because:"Final migration Run the production migration When you're ready for the final migration: Shut down the source VM completely. Start the V2V migration in Xen Orchestra with the Stop source option enabled. This ensures the final sync happens while the VM is powered off, and prevents any inconsistencies."In my mind doesn't state that the VM should be started manually post-transfer.
Great thanks in advance for discussing!
Cheers! -
RE: V2V migrated VMs don't autostart
Further testing:
Testing with newer commit: 27882fb1dcd24fc5257835e60b3fa1002e4e885c
Still same results.I've tried with both original VM powered on, and off. No change in end-result. The VM imports properly. But it doesn't power on automatically as expected after the import has completed. Manual powering on is then needed to be performed.
I'm only importing 1 VM at a time. And I've tried with the field
Number of VMs to import in parallelboth at the default value of2and reduced to1. No change in behaviour from this either. -
RE: V2V migrated VMs don't autostart
Thanks for your long post. I hope someone else will find it helpfull.
However, I am pretty much reporting that the autostart after importing with V2V might be buggy at best or broken at worst. Not the autostart after boot part
(that works).Cheers